summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-04 19:05:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-04 19:05:07 -0500
commit0d96a2aaad08c5f3875ff95ac42f12fcff2db5c5 (patch)
tree23be9127f29088fe13dd3edca4fd7a0aac8dcee7 /media-sound
parentvirtual/libudev: 232 version bump to drop static-libs use flag from udev (diff)
downloadgentoo-0d96a2aaad08c5f3875ff95ac42f12fcff2db5c5.tar.gz
gentoo-0d96a2aaad08c5f3875ff95ac42f12fcff2db5c5.tar.bz2
gentoo-0d96a2aaad08c5f3875ff95ac42f12fcff2db5c5.zip
media-sound/spotify: bup for bug 598936
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.42.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 9022395d0cf1..2173e23240ad 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.38.171.g5e1cd7b2-22_amd64.deb 75021350 SHA256 a0905dbf02657996356e4779dac9554f8679c3e7cb52c6f867213c91385b1956 SHA512 089ef68419ade8bc8370b2a001e08ddde5ad5c131c18be872db124d8c9c502d13d2ac51bb38980d6c2a6dbcfb9ca3b345d5bbe484ad50d9e5522df99f40fe1aa WHIRLPOOL 5dbe641a5844ace83e93fa998793e5bd3c9639f65cbef4c2b8726dabe2acea835fd42f4fb70c5380bf95b71b96495c96eab0521cdba6fdbb20115e9021431bf7
DIST spotify-client_1.0.38.171.g5e1cd7b2-22_i386.deb 83209544 SHA256 0d6db03c51aea6ad2ddcb5cff2cb3212f209497b4152aac603fbb3ceb2c38586 SHA512 c7bc3d37f252d93d68b0e2387d26bdce8247dba7bf0888180c2b4509eb9ec6319044f3f12c4d0392c43dd04648642390227e9fd2bceeb286c5cc6733de18b0be WHIRLPOOL 722290057d9716b805366ad37883d1ad724356093c3af6514cbee7fa66c91a9116a8ca1ce20a8a3e0a8706de9ff6566da1aeafd6db1d526c2e8552e633a3842f
+DIST spotify-client_1.0.42.145.g7a5a182e-17_i386.deb 72456462 SHA256 ffc5f2d2e30d6cca17449d1cd07f50085df57a0c3a2943f8ba8608f8b9d01d8a SHA512 9e65dd6f92802b597cb12474b39daade64ac93d73c1ca2c3158926fd67f7fd1240b4127537bef7a5633cea6d4563a275da83c48bb72a5df300306ceebcc36824 WHIRLPOOL 0a0cd52daa111a0061dcdab62613c0ea179ece3fe38fec5c7a290686c5979cc6225b96c51af3929b778f0ebc669eee8130820c29d13812b09890dba922bd7488
+DIST spotify-client_1.0.42.145.g7a5a182e-37_amd64.deb 71143408 SHA256 3fb12b496b52fcd4e42c95f430b75ef3874ad21564615a460fb5380b9b7a14b3 SHA512 854f64366123540c3d1a17d287fa022b83103806cd8fc599a63909ce758cd79c11b0fd8006d42343dda3e9f3933cb44ebfc8d20b91a5330f86e918d3b59d01ed WHIRLPOOL d0bb0c56241f83c636f2e4d0fcefc8d84817211372845ba3867c0ad74d9e32d5bc6f8efcbefe8c121a885318fcc71df08d7be944a35d016ff0df478d5c5b59d0
diff --git a/media-sound/spotify/spotify-1.0.42.ebuild b/media-sound/spotify/spotify-1.0.42.ebuild
new file mode 100644
index 000000000000..2e8fb2793b93
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.42.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.145.g7a5a182e-37_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.145.g7a5a182e-17_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}