summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-11-22 16:26:43 +0100
committerSebastian Pipping <sping@gentoo.org>2017-11-22 16:38:03 +0100
commit14af31068c014f3674511d9926b0484d7cb90f0a (patch)
tree7f264d2960b7c4b1c57ebb43814fe28349421ab5 /media-sound
parentdev-util/strace: Removed old. (diff)
downloadgentoo-14af31068c014f3674511d9926b0484d7cb90f0a.tar.gz
gentoo-14af31068c014f3674511d9926b0484d7cb90f0a.tar.bz2
gentoo-14af31068c014f3674511d9926b0484d7cb90f0a.zip
media-sound/spotify: 1.0.67
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.67.ebuild117
2 files changed, 119 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index d6689a852805..4ebc15b850da 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -2,3 +2,5 @@ DIST spotify-client_1.0.64.407.g9bd02c2d-26_amd64.deb 93425432 SHA256 8c97a95ade
DIST spotify-client_1.0.64.407.g9bd02c2d-26_i386.deb 97705428 SHA256 0e32bc8b21d591f8def932403b8ef3632e95eba4b5628506dfdf6d521dce7941 SHA512 43342faf26b7530dbb3fecafebcb7dac6ed6b7323c845f373bb63760ab309f4f01c6f4dd1cb4ab1bfd9a97b383fb863ba5f2aa7e73d32d1575bf8964dcdf30a5 WHIRLPOOL f3c42136e0682bddaec17829a05a9237d95b6d8f79b9ed27e2cdd77d011ea015fb4532d5f5878c03e15661207779a65e7e228a46821c13899b17513f12612863
DIST spotify-client_1.0.66.478.g1296534d-39_amd64.deb 90932368 SHA256 a2e739c0ee009df1c899e42c095735bca231312b75b82e311147d41fb72404c1 SHA512 cd8b073f981b5bf793d87de22922054df141dbf58c5eac96eb55e44f1672b8057c79ee950a14a8a34aaa5d59e961b87df56198f382330d079553212189a1975c WHIRLPOOL 5c3cfe26e3c7eaee53e506eeb72e3ab4fa13601f4debb6f003804abb0953c6c8796ff49fa983aa734750b773889d9d23d4634655a4c8526918e3f45e4c269a37
DIST spotify-client_1.0.66.478.g1296534d-39_i386.deb 95213590 SHA256 29795bd5c226e54d531621e645ffe7bd2cc6b4e5c69956c63bdcaade165cb8d9 SHA512 5c1b56787930a672da9a8ead8246cb779c6680dce6e5514c098e81712c9b131b77d45afa2ccedb95635b5387aab4db8c7e7f6dddb0cefb3cbdfb573d60920af7 WHIRLPOOL 5cfaa8fb5ede2bcec27c2bd557cc3c2dbda8e75cb140c48cecae21dfdfb18129996a1d6a7707b97ecfab1227c1a1f4b0420a44b16146233641141882ac5b19bf
+DIST spotify-client_1.0.67.582.g19436fa3-28_amd64.deb 90723508 BLAKE2B 9551bcaae09895fd73b35b2e95a0dd4fff64e0cd70af9bd88fcf1a288f79195f99dae89852164fe66e6aebc6efb45ea6b258457e39727c0f6081cf68ff95cc42 SHA512 f9db71c5bce18fc4e2121316e1f229f06ca5510211698f79f75b5ff6b297d9603ff50810bf2b7dae38d8625ed9c5a09c17549d6989eaef1ebe1f856e63858b3c
+DIST spotify-client_1.0.67.582.g19436fa3-28_i386.deb 95004956 BLAKE2B 751e14573f5dd7aac7134545f147da293b1051dbcb37c055ad18224e5df4c155ba7142997ed77e5f90940850982e4a7162b66aa621ea5133d782b12e5cb9fb3a SHA512 7fcfb0b39bdbe1427c35c56f78cc5129d07630863553c025505a5bbe9c216f4dd8af123512e9853c75f9791b0a0a819e076d95a20788cd759ea8033b485b47e3
diff --git a/media-sound/spotify/spotify-1.0.67.ebuild b/media-sound/spotify/spotify-1.0.67.ebuild
new file mode 100644
index 000000000000..d6e3920aea55
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.67.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+BUILD_ID="582.g19436fa3-28"
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID}_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl[ssl,curl_ssl_openssl]
+ net-print/cups[ssl]
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ dev-python/pygobject:3
+ dev-python/dbus-python
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+ #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+ default
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}