summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-04-19 14:09:14 +0300
committerMart Raudsepp <leio@gentoo.org>2019-04-19 14:09:14 +0300
commit3649e6997f06230a876a86fe1b7812565dcbf50b (patch)
treee5ef9ea78acae05ccc86ff58f608bcb741a8279d /media-sound
parentnet-wireless/gnome-bluetooth: security cleanup (diff)
downloadgentoo-3649e6997f06230a876a86fe1b7812565dcbf50b.tar.gz
gentoo-3649e6997f06230a876a86fe1b7812565dcbf50b.tar.bz2
gentoo-3649e6997f06230a876a86fe1b7812565dcbf50b.zip
media-sound/soundconverter: bump to 3.0.2
This version fixes up GConf handling and doesn't hard require it. GConf usage is about ancient gnome-media-profiles stuff, which we've removed over 5 years ago, it seems, thus no USE flag toggling of it. If it does find gconf introspection files, fine, it'll just gracefully try to find the gconf stored media profiles, not find them and not use gconf further. Bug: https://bugs.gentoo.org/676256 Closes: https://bugs.gentoo.org/683262 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/soundconverter/Manifest1
-rw-r--r--media-sound/soundconverter/soundconverter-3.0.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index b5f29b05e2d3..c2adb1b90e2b 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1 +1,2 @@
DIST soundconverter-3.0.0.tar.xz 201548 BLAKE2B bdca42d22d2e497b807149dcd5c8f911519b71dc7e836ad359831d0b7cd2241f58f8f9f60fa4580e2f038528e9c249dfa8a811d1681d0c8dead2c53e0f58f7ce SHA512 6f5518711c76e7748447805dbf16ac8622c5041c3f3cac2de6f31968aab4eff43a2fde2da48c47d12093ce1732208923d83d57b6a97ea99fbf882dfef239a62d
+DIST soundconverter-3.0.2.tar.xz 208440 BLAKE2B e7817648fe27b2083629ea718b0479f7b9e2607a017868b1e1ce3fb0407a84a548bd007647e73a1d4163a7f51b162a89e3914419ccdbfd07586c2a94a23f4af2 SHA512 0746395de412a4d845e3df4d6cce0dbcba266c9efc8db71663dd1c751d2a5de5b0dc266f24bbfe6c00f69428801ce5f9558fc8e5e2f5d5e6be8562085cd7fe92
diff --git a/media-sound/soundconverter/soundconverter-3.0.2.ebuild b/media-sound/soundconverter/soundconverter-3.0.2.ebuild
new file mode 100644
index 000000000000..502d7be8e386
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-3.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+MY_PV="${PV/_/-}"
+SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="aac flac libnotify mp3 ogg opus vorbis"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/gobject-introspection:=
+ x11-libs/gtk+:3[introspection]
+ media-libs/gstreamer:1.0[introspection]
+"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/pango[introspection]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ libnotify? ( x11-libs/libnotify[introspection] )
+
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+RESTRICT="test" # broken pot files list in 3.0.0 release, making src_test fallback to "make test" which fails
+
+src_prepare() {
+ python_fix_shebang .
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
+}