summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-21 22:09:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-21 23:23:02 +0200
commit425bf47e3a1a50bca7ddda6f95b77d68cf2fb4d1 (patch)
tree3849e2e3b637526d62c0859b517e7b8a7e81505a /media-sound
parentmedia-sound/musescore: Switch to https, add newline at end of file (diff)
downloadgentoo-425bf47e3a1a50bca7ddda6f95b77d68cf2fb4d1.tar.gz
gentoo-425bf47e3a1a50bca7ddda6f95b77d68cf2fb4d1.tar.bz2
gentoo-425bf47e3a1a50bca7ddda6f95b77d68cf2fb4d1.zip
media-sound/musescore: Set USE_SYSTEM_QTSINGLEAPPLICATION=ON
Bug: https://bugs.gentoo.org/489144 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch28
-rw-r--r--media-sound/musescore/musescore-2.1.0-r1.ebuild72
-rw-r--r--media-sound/musescore/musescore-9999.ebuild12
3 files changed, 108 insertions, 4 deletions
diff --git a/media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch b/media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch
new file mode 100644
index 000000000000..1e362dd3298a
--- /dev/null
+++ b/media-sound/musescore/files/musescore-2.1.0-qtsingleapplication.patch
@@ -0,0 +1,28 @@
+From 4c28258db05dd6d33bbcd037a05a7fbbb66f67ab Mon Sep 17 00:00:00 2001
+From: Joachim Schmitz <jojo@schmitz-digital.de>
+Date: Wed, 8 Aug 2018 09:16:54 +0200
+Subject: [PATCH] Fix #52106: fails to compile with
+ -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
+
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3a30c03d63..be6a50578a 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -537,8 +537,13 @@ endif(APPLE)
+ ##
+
+ if (USE_SYSTEM_QTSINGLEAPPLICATION)
++ if (USE_PATH_WITH_EXPLICIT_QT_VERSION)
++ find_path(QTSINGLEAPPLICATION_INCLUDE_DIRS qtsingleapplication.h PATH_SUFFIXES qt5/QtSolutions)
++ find_library(QTSINGLEAPPLICATION_LIBRARIES Qt5Solutions_SingleApplication-2.6)
++ else (USE_PATH_WITH_EXPLICIT_QT_VERSION)
+ find_path(QTSINGLEAPPLICATION_INCLUDE_DIRS qtsingleapplication.h PATH_SUFFIXES QtSolutions)
+ find_library(QTSINGLEAPPLICATION_LIBRARIES QtSolutions_SingleApplication-2.6)
++ endif (USE_PATH_WITH_EXPLICIT_QT_VERSION)
+ else(USE_SYSTEM_QTSINGLEAPPLICATION)
+ subdirs (thirdparty/singleapp)
+ set(QTSINGLEAPPLICATION_INCLUDE_DIRS ${PROJECT_SOURCE_DIR}/singleapp/src)
diff --git a/media-sound/musescore/musescore-2.1.0-r1.ebuild b/media-sound/musescore/musescore-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..5ba187f53159
--- /dev/null
+++ b/media-sound/musescore/musescore-2.1.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="WYSIWYG Music Score Typesetter"
+HOMEPAGE="https://musescore.org/"
+SRC_URI="https://github.com/musescore/MuseScore/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~mgorny/dist/${P}-fix-buildsystem.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug jack mp3 portaudio portmidi pulseaudio"
+REQUIRED_USE="portmidi? ( portaudio )"
+
+RDEPEND="
+ dev-qt/designer:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qthelp:5
+ dev-qt/qtprintsupport:5
+ >=dev-qt/qtsingleapplication-2.6.1_p20171024
+ dev-qt/qtsvg:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtxmlpatterns:5
+ >=media-libs/freetype-2.5.2
+ media-libs/libsndfile
+ sys-libs/zlib:=
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+ jack? ( virtual/jack )
+ mp3? ( media-sound/lame )
+ portaudio? ( media-libs/portaudio )
+ portmidi? ( media-libs/portmidi )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${WORKDIR}/${P}-fix-buildsystem.patch"
+ "${FILESDIR}/${P}-qt-5.11.patch"
+ "${FILESDIR}/${P}-qtsingleapplication.patch"
+)
+
+S="${WORKDIR}/MuseScore-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
+ -DUSE_PATH_WITH_EXPLICIT_QT_VERSION=ON
+ -DBUILD_ALSA="$(usex alsa)"
+ -DBUILD_JACK="$(usex jack)"
+ -DBUILD_LAME="$(usex mp3)"
+ -DBUILD_PORTAUDIO="$(usex portaudio)"
+ -DBUILD_PORTMIDI="$(usex portmidi)"
+ -DBUILD_PULSEAUDIO="$(usex pulseaudio)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cd "${BUILD_DIR}" || die
+ cmake-utils_src_make -j1 lrelease manpages
+ cmake-utils_src_compile
+}
diff --git a/media-sound/musescore/musescore-9999.ebuild b/media-sound/musescore/musescore-9999.ebuild
index 09988cf9c632..3272159f0c89 100644
--- a/media-sound/musescore/musescore-9999.ebuild
+++ b/media-sound/musescore/musescore-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,23 +24,25 @@ RDEPEND="
dev-qt/qtgui:5
dev-qt/qthelp:5
dev-qt/qtprintsupport:5
+ >=dev-qt/qtsingleapplication-2.6.1_p20171024
dev-qt/qtsvg:5
dev-qt/qtwebkit:5
dev-qt/qtxmlpatterns:5
>=media-libs/freetype-2.5.2
media-libs/libsndfile
- sys-libs/zlib
+ sys-libs/zlib:=
alsa? ( >=media-libs/alsa-lib-1.0.0 )
jack? ( virtual/jack )
mp3? ( media-sound/lame )
portaudio? ( media-libs/portaudio )
portmidi? ( media-libs/portmidi )
pulseaudio? ( media-sound/pulseaudio )
- "
+"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
virtual/pkgconfig
- "
+"
+
PATCHES=(
"${WORKDIR}/${P}-fix-buildsystem.patch"
)
@@ -52,6 +54,8 @@ src_unpack() {
src_configure() {
local mycmakeargs=(
+ -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
+ -DUSE_PATH_WITH_EXPLICIT_QT_VERSION=ON
-DBUILD_ALSA="$(usex alsa)"
-DBUILD_JACK="$(usex jack)"
-DBUILD_LAME="$(usex mp3)"