summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-21 09:57:01 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-21 09:57:15 +0200
commit4ad03854c0bba00955723fe69366343829103f4f (patch)
tree26a5f2bc041ba8e238b2cdc49ff014ea3326f3ec /media-sound
parentprofiles/package.mask: mask dev-haskell/regex-tdfa-rc for removal (diff)
downloadgentoo-4ad03854c0bba00955723fe69366343829103f4f.tar.gz
gentoo-4ad03854c0bba00955723fe69366343829103f4f.tar.bz2
gentoo-4ad03854c0bba00955723fe69366343829103f4f.zip
media-sound/grip: bump to 4.2.0
Closes: https://bugs.gentoo.org/738254 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/grip/Manifest1
-rw-r--r--media-sound/grip/grip-4.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/grip/Manifest b/media-sound/grip/Manifest
index b0ad66d4d2de..4e8c873b2523 100644
--- a/media-sound/grip/Manifest
+++ b/media-sound/grip/Manifest
@@ -1 +1,2 @@
DIST grip-4.1.1.tar.gz 1211196 BLAKE2B 677ace9ef740db150a2cfc9b597b148b50015dda79cb41b53cd656451b038ff71d6efdf3e17bea65accc071ec0116c6025a7c9619cb09a3782eeb94904e431a9 SHA512 c6af48b0fa89fb342c73614c6193973811ccf72837a46eb1a3971ffcfa9a20bb4fb8705ba674b093e2c4f6f78f9ded323cf5453cdecf53c467238430f98ba267
+DIST grip-4.2.0.tar.gz 1209972 BLAKE2B 087118b0871b149745fa083f3eeaa79ac8c00c2b094a486cb9c5188e215dd7ce4cb06d13fb362914d7b688c89989e3b6b86ee889b4027e38b727876a06f06dd1 SHA512 26cb32064019da1d1683c44caa3c52ae513cec5b1fb435930e8e4c62433a70f14145d92f2215bf54a5bface96945d3e5e879302e2824029650d2a34218528e94
diff --git a/media-sound/grip/grip-4.2.0.ebuild b/media-sound/grip/grip-4.2.0.ebuild
new file mode 100644
index 000000000000..b6045a79ad78
--- /dev/null
+++ b/media-sound/grip/grip-4.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils flag-o-matic toolchain-funcs libtool xdg
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper"
+HOMEPAGE="https://sourceforge.net/projects/grip/"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+# lame and vorbis-tools are no real RDEPENDs. But without them
+# grip cannot convert ripped files to any format. So use them as
+# a sane default.
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/id3lib
+ media-sound/cdparanoia
+ media-sound/lame
+ net-misc/curl
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ vorbis? ( media-sound/vorbis-tools )
+"
+# gnome-extra/yelp, see bug 416843
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nb nl pl_PL pt_BR ru sr vi zh_CN zh_HK zh_TW
+
+ econf
+}