summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-04-12 00:00:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-04-12 00:01:36 -0500
commit4b8d5ec58b6ba765c84e2df5f3d0f2b19fe6fac9 (patch)
tree1ed5b98fbf64c342f18ee673c6d3dc13ae1e9ac5 /media-sound
parentdev-util/android-ndk: bump to 11c, 32bit support has been dropped (diff)
downloadgentoo-4b8d5ec58b6ba765c84e2df5f3d0f2b19fe6fac9.tar.gz
gentoo-4b8d5ec58b6ba765c84e2df5f3d0f2b19fe6fac9.tar.bz2
gentoo-4b8d5ec58b6ba765c84e2df5f3d0f2b19fe6fac9.zip
media-sound/spotify: bug for bug 579558
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/Manifest2
-rw-r--r--media-sound/spotify/spotify-1.0.27.ebuild114
2 files changed, 116 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index 85402258262b..9c4412794125 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,4 @@
DIST spotify-client_1.0.26.125.g64dc8bc6-15_amd64.deb 76862466 SHA256 e15b159dd2f20f8c00067545d5899f40f991fa89e1cf246b280289944396c407 SHA512 de30313a58288dd6f29fadf9f2c74c556cdf3002edbc0aedc657c3e79555feb07bf5793e8e08ae0011413cc52eefb9781b538e39904e8341468117dcd1b06a8a WHIRLPOOL 171f6ab59d068922294267617a1873aa3eb9ee6ce756dfd2338bfb360709e87a7c5b821b9438f4bcc177ab1acf5a8df4e1e6bf8fe6467408d33c07a0e52388bc
DIST spotify-client_1.0.26.125.g64dc8bc6-5_i386.deb 79948634 SHA256 13dfa424106762821765a900612ab40982a32d640e13c266c0a5102cdc6cea5a SHA512 3e19ae1cf72511648de65e80ed0cb85c3c39c49ef75d7a63cb952c35f878343580bb69540a2e9e728dbce7e98341efb955881019687cb09a60ac84448bf3059e WHIRLPOOL 8549c2dab6f48630af3c0d00a794078f674de39c961f7370e0f8442e78de85826ca6d964f31423fc4e01118f764adc0bc7052ad6bfd1d31adb5ae67dd16eddb6
+DIST spotify-client_1.0.27.71.g0a26e3b2-9_amd64.deb 77971642 SHA256 82dc602ed17bbb9d0f2b161c69226f8a291f85d544fe4abffa347860374340e7 SHA512 acb80c2d605f0957c9c149a61ab633be40d38e7328ae295a6ffada58263a70eff1fdd80dd07d5df497fa69a45c0a46038fa01b4084e48ba1465296329dbb885e WHIRLPOOL ca0479c3dc4e15e87d380508f7131900fce338261f33d7b46c99160b0bb15885d7b693c8daf5a26e3446e1a0efbab1e7fa3b224b635e7529a47e8c394eae50a1
+DIST spotify-client_1.0.27.73.g602ced10-2_i386.deb 81135262 SHA256 b7113e2aa305cd2389d8861c6212de05ed5a9cfaa2a85e8021b355a848634f34 SHA512 c77165046472853a7be5da35924ef0b1296bdcac90342b99ad87b492117487645f4845deb5014ba739a7c8edbffce829f65c849a822a72af0441f3f74a8c740a WHIRLPOOL 43b06ac12ae0aaf2436e21c2a755ff5e074727b44e6897f956c647b85ecd4403ac10c918dbcaed360ea235959d7b3d49318b050668f0b324d2daf81e384b915e
diff --git a/media-sound/spotify/spotify-1.0.27.ebuild b/media-sound/spotify/spotify-1.0.27.ebuild
new file mode 100644
index 000000000000..a06537399fb7
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.27.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}-client/"
+SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.71.g0a26e3b2-9_amd64.deb )
+ x86? ( ${SRC_BASE}${PN}-client_${PV}.73.g602ced10-2_i386.deb )"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=""
+# zenety needed for filepicker
+RDEPEND="
+ ${DEPEND}
+ dev-libs/nss
+ gnome-base/gconf
+ gnome-extra/zenity
+ media-libs/alsa-lib
+ media-libs/harfbuzz
+ media-libs/fontconfig
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups[ssl]
+ sys-libs/glibc
+ x11-libs/gtk+:2
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ pulseaudio? ( media-sound/pulseaudio )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/spotify/spotify.desktop || die "sed failed"
+ fi
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.Debian.gz
+
+ SPOTIFY_PKG_HOME=usr/share/spotify
+ insinto /usr/share/pixmaps
+ doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify/spotify-client
+ insinto ${SPOTIFY_HOME}
+ doins -r ${SPOTIFY_PKG_HOME}/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify || die
+ #! /bin/sh
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 512; do
+ newicon -s ${size} "${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+ "spotify-client.png"
+ done
+ domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+ if use pax_kernel; then
+ #create the headers, reset them to default, then paxmark -m them
+ pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+ pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+ eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+ eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ eqawarn "you suspect that ${PN} is being broken by this modification,"
+ eqawarn "please open a bug."
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+ ewarn
+ ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might still see the old icon."
+ ewarn "Run"
+ ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+ ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}