summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 19:24:23 +0100
committerSam James <sam@gentoo.org>2021-04-18 07:03:07 +0100
commit5825057704fb1914c4ff9998fbbdcd0f805df2e1 (patch)
tree485b6c2751355b7a87dec35831433dc9c72644a6 /media-sound
parentmedia-sound/tapestrea: eutils->epatch (diff)
downloadgentoo-5825057704fb1914c4ff9998fbbdcd0f805df2e1.tar.gz
gentoo-5825057704fb1914c4ff9998fbbdcd0f805df2e1.tar.bz2
gentoo-5825057704fb1914c4ff9998fbbdcd0f805df2e1.zip
media-sound/xmms2: eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild b/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
index 8b2934f38db4..f092930f7a2b 100644
--- a/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
+++ b/media-sound/xmms2/xmms2-0.8_p20161122-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
USE_RUBY="ruby24 ruby25 ruby26"
-inherit eutils multiprocessing perl-functions python-single-r1 ruby-single toolchain-funcs
+inherit multiprocessing perl-functions python-single-r1 ruby-single toolchain-funcs
# generated as 'python2 ./utils/gen-tarball.py' from clean git tree
MY_P="${P%_p*}DrO_o-949-gca15e830"
@@ -127,22 +127,22 @@ pkg_setup() {
}
# use_enable() is taken as proto
-# $1 - useflag
-# $2 - xmms2 option/plugin name (equals to $1 if not set)
+# ${1} - useflag
+# ${2} - xmms2 option/plugin name (equals to ${1} if not set)
xmms2_flag() {
- [[ -z $1 ]] && eerror "!!! empty arg. usage: xmms2_flag <USEFLAG> [<xmms2_flagname>]."
+ [[ -z ${1} ]] && eerror "!!! empty arg. usage: xmms2_flag <USEFLAG> [<xmms2_flagname>]."
- local UWORD=${2:-$1}
+ local UWORD=${2:-${1}}
- case $1 in
+ case ${1} in
ENABLED)
echo ",${UWORD}"
;;
DISABLED)
;;
*)
- use $1 && echo ",${UWORD}"
+ use ${1} && echo ",${UWORD}"
;;
esac
}
@@ -258,12 +258,12 @@ src_configure() {
local option
for option in "${option_map[@]}"; do
- optionals+=$(xmms2_flag $option)
+ optionals+=$(xmms2_flag ${option})
done
local plugin
for plugin in "${plugin_map[@]}"; do
- plugins+=$(xmms2_flag $plugin)
+ plugins+=$(xmms2_flag ${plugin})
done
if use perl; then
@@ -309,7 +309,7 @@ src_install() {
local m
for m in "${ED}"/usr/share/man/man1/*.gz; do
# For some combination of USEs no mans are installed.
- if [[ -f $m ]]; then
+ if [[ -f ${m} ]]; then
einfo "Uncompressing '${m#${ED}}' back."
gzip -d "${m}" || die
fi