summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-22 15:42:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-22 17:41:21 +0200
commit66645e2f9cf414253a052fad4b174b364747a7bb (patch)
treea3cc677bfa7f72cccb5e1e7a0b8efd79f109445c /media-sound
parentmedia-plugins/hexter: Drop 1.0.3 (diff)
downloadgentoo-66645e2f9cf414253a052fad4b174b364747a7bb.tar.gz
gentoo-66645e2f9cf414253a052fad4b174b364747a7bb.tar.bz2
gentoo-66645e2f9cf414253a052fad4b174b364747a7bb.zip
media-sound/bitmeter: EAPI-7 bump, virtual/jack, https
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/bitmeter/bitmeter-1.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/bitmeter/bitmeter-1.2-r2.ebuild b/media-sound/bitmeter/bitmeter-1.2-r2.ebuild
new file mode 100644
index 000000000000..4ee1222e4afe
--- /dev/null
+++ b/media-sound/bitmeter/bitmeter-1.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Diagnosis tool for JACK audio software"
+HOMEPAGE="https://devel.tlrmx.org/audio/"
+SRC_URI="https://devel.tlrmx.org/audio/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ virtual/jack
+ x11-libs/gtk+:2
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.2-qa-desktop-file.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/*.{png,html} )
+ default
+}