summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-03 23:20:25 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-03 23:20:56 +0200
commit6924f47fe17a0242f9fffeacf3b8b61cce748083 (patch)
tree47fe21497790567720c13cc7d811131622784cb1 /media-sound
parentnet-nds/jxplorer: clean up old. (diff)
downloadgentoo-6924f47fe17a0242f9fffeacf3b8b61cce748083.tar.gz
gentoo-6924f47fe17a0242f9fffeacf3b8b61cce748083.tar.bz2
gentoo-6924f47fe17a0242f9fffeacf3b8b61cce748083.zip
media-sound/adplay: Allow for compiling with GCC 6
Gentoo-bug: 596092 Package-Manager: portage-2.3.1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/adplay/adplay-1.7.ebuild9
-rw-r--r--media-sound/adplay/files/adplay-1.7-fix-c++14.patch22
2 files changed, 26 insertions, 5 deletions
diff --git a/media-sound/adplay/adplay-1.7.ebuild b/media-sound/adplay/adplay-1.7.ebuild
index c84830cac6cc..6d5680f602af 100644
--- a/media-sound/adplay/adplay-1.7.ebuild
+++ b/media-sound/adplay/adplay-1.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
DESCRIPTION="A console player for AdLib music"
HOMEPAGE="http://adplug.sourceforge.net"
@@ -20,14 +20,13 @@ RDEPEND=">=media-libs/adplug-2.2.1
sdl? ( media-libs/libsdl )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=( "${FILESDIR}/${PN}-1.7-fix-c++14.patch" )
src_configure() {
econf \
+ --disable-output-esound \
$(use_enable alsa output-alsa) \
$(use_enable ao output-ao) \
- --disable-output-esound \
$(use_enable oss output-oss) \
$(use_enable sdl output-sdl)
}
diff --git a/media-sound/adplay/files/adplay-1.7-fix-c++14.patch b/media-sound/adplay/files/adplay-1.7-fix-c++14.patch
new file mode 100644
index 000000000000..aedbbc0ab1c5
--- /dev/null
+++ b/media-sound/adplay/files/adplay-1.7-fix-c++14.patch
@@ -0,0 +1,22 @@
+From 48dcaa87ff91369eb41998abd72e226fe138b528 Mon Sep 17 00:00:00 2001
+From: Adam Nielsen <malvineous@shikadi.net>
+Date: Sun, 22 May 2016 08:49:47 +1000
+Subject: [PATCH] Cast -1 to unsigned int to prevent compiler error
+
+---
+ src/adplay.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/adplay.cc b/src/adplay.cc
+index d73ec25..da00730 100644
+--- a/src/adplay.cc
++++ b/src/adplay.cc
+@@ -90,7 +90,7 @@ static struct {
+ 1, 16, 0, // Else default to mono (until stereo w/ single OPL is fixed)
+ #endif
+ MSG_NOTE,
+- -1,
++ (unsigned int)-1,
+ NULL,
+ NULL,
+ true, false, false, false,