summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-02-10 12:51:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-10 17:16:44 +0100
commit6f92f92780d3cbc45e4553808e12d71854e15a77 (patch)
tree8fbb47f6da376c10c9d1db61840e2b85029cb585 /media-sound
parentmedia-sound/id3ed: fix LICENSE, SRC_URI and HOMEPAGE (diff)
downloadgentoo-6f92f92780d3cbc45e4553808e12d71854e15a77.tar.gz
gentoo-6f92f92780d3cbc45e4553808e12d71854e15a77.tar.bz2
gentoo-6f92f92780d3cbc45e4553808e12d71854e15a77.zip
media-sound/id3ed: EAPI7 revbump
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/id3ed/id3ed-1.10.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/id3ed/id3ed-1.10.4-r1.ebuild b/media-sound/id3ed/id3ed-1.10.4-r1.ebuild
new file mode 100644
index 000000000000..f1c44b651575
--- /dev/null
+++ b/media-sound/id3ed/id3ed-1.10.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="ID3 tag editor for mp3 files"
+HOMEPAGE="http://code.fluffytapeworm.com/projects/id3ed"
+SRC_URI="http://code.fluffytapeworm.com/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="sys-libs/ncurses:0=
+ sys-libs/readline:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/install/s:-s::' \
+ -e 's:$(CXX) $(CXXFLAGS):$(CXX) $(LDFLAGS) $(CXXFLAGS):' \
+ Makefile.in || die
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CFLAGS="${CFLAGS} -I./" || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+ default
+}