summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-17 18:16:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-17 20:16:06 +0100
commit79de2de023843ad9849d7c070065c2127e18da8a (patch)
tree1b246c2f27c20a11912393d53ce308f7bd35ca11 /media-sound
parentmedia-libs/libshout: EAPI 6, fix header checksum mismatch (diff)
downloadgentoo-79de2de023843ad9849d7c070065c2127e18da8a.tar.gz
gentoo-79de2de023843ad9849d7c070065c2127e18da8a.tar.bz2
gentoo-79de2de023843ad9849d7c070065c2127e18da8a.zip
media-sound/clementine: Fix lastfm paths
Unfortunately clementine relies on downstream paths. Closes: https://bugs.gentoo.org/645638 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/clementine/clementine-1.3.1_p20180203.ebuild8
-rw-r--r--media-sound/clementine/clementine-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/media-sound/clementine/clementine-1.3.1_p20180203.ebuild b/media-sound/clementine/clementine-1.3.1_p20180203.ebuild
index 8a8acf0c01cb..91cb135683fa 100644
--- a/media-sound/clementine/clementine-1.3.1_p20180203.ebuild
+++ b/media-sound/clementine/clementine-1.3.1_p20180203.ebuild
@@ -117,6 +117,14 @@ src_prepare() {
sed -e "/find_package.*Qt5/s:\ Test::" -i CMakeLists.txt || die
cmake_comment_add_subdirectory tests
fi
+
+ # Fix clementine relying on downstream renaming of lastfm header dir
+ sed -i -e "/^#include/s/lastfm5/lastfm/" \
+ tests/albumcoverfetcher_test.cpp \
+ src/internet/lastfm/lastfm{settingspage.cpp,service.cpp,compat.h} \
+ src/core/song.cpp || die "Failed to sed lastfm header suffix"
+ sed -e "/^find_path.*LASTFM5/s/lastfm5/lastfm/" \
+ -i CMakeLists.txt || die "Failed to sed lastfm header suffix"
}
src_configure() {
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
index caae648812d0..43167c9035aa 100644
--- a/media-sound/clementine/clementine-9999.ebuild
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -117,6 +117,14 @@ src_prepare() {
sed -e "/find_package.*Qt5/s:\ Test::" -i CMakeLists.txt || die
cmake_comment_add_subdirectory tests
fi
+
+ # Fix clementine relying on downstream renaming of lastfm header dir
+ sed -i -e "/^#include/s/lastfm5/lastfm/" \
+ tests/albumcoverfetcher_test.cpp \
+ src/internet/lastfm/lastfm{settingspage.cpp,service.cpp,compat.h} \
+ src/core/song.cpp || die "Failed to sed lastfm header suffix"
+ sed -e "/^find_path.*LASTFM5/s/lastfm5/lastfm/" \
+ -i CMakeLists.txt || die "Failed to sed lastfm header suffix"
}
src_configure() {