summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-09 10:09:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-09 10:10:23 +0200
commita317a27554bcb3709acf96ba050d8e8bc4ad2753 (patch)
tree131667e087dc46f8889c405ac41bb43cdf7db5d8 /media-sound
parentnet-analyzer/sslscan: remove obsolete openssl dependency (diff)
downloadgentoo-a317a27554bcb3709acf96ba050d8e8bc4ad2753.tar.gz
gentoo-a317a27554bcb3709acf96ba050d8e8bc4ad2753.tar.bz2
gentoo-a317a27554bcb3709acf96ba050d8e8bc4ad2753.zip
media-sound/freebirth: Remove last-rited pkg
Closes: https://bugs.gentoo.org/731008 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/freebirth/Manifest1
-rw-r--r--media-sound/freebirth/files/freebirth-0.3.2-gentoo-2.patch214
-rw-r--r--media-sound/freebirth/files/freebirth-0.3.2-segfault.patch17
-rw-r--r--media-sound/freebirth/freebirth-0.3.2-r1.ebuild40
-rw-r--r--media-sound/freebirth/metadata.xml11
5 files changed, 0 insertions, 283 deletions
diff --git a/media-sound/freebirth/Manifest b/media-sound/freebirth/Manifest
deleted file mode 100644
index f47225e04db8..000000000000
--- a/media-sound/freebirth/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST freebirth-0.3.2.tar.gz 2456900 BLAKE2B 1000dbf87cb1138c7650e26a5d2c8ff08c986ab86a24742f43d5334c2b02b6e88231a3131ca437fd3bbb6ce024b91a1104cce3e3b369ce0087b4f9cc451f626f SHA512 a532905e687d8ebc415dea3794a4dfc4c55037123c79cc0dd2111fc74e6db1ba367e8210da75e3586c5ee4d2521a21b5cd03a5a0afcfd3a04e678834f140590a
diff --git a/media-sound/freebirth/files/freebirth-0.3.2-gentoo-2.patch b/media-sound/freebirth/files/freebirth-0.3.2-gentoo-2.patch
deleted file mode 100644
index 52b184b04b2f..000000000000
--- a/media-sound/freebirth/files/freebirth-0.3.2-gentoo-2.patch
+++ /dev/null
@@ -1,214 +0,0 @@
---- freebirth.c
-+++ freebirth.c
-@@ -248,15 +248,15 @@
- //bass_e = env_new(1025,10000,(sample_producer *)osc_blender);
- sl = g_slist_append(sl, bass_e);
-
-- kick = raw_wave_new("raw/kick.raw");
-+ kick = raw_wave_new("/usr/share/freebirth/raw/kick.raw");
- sl = g_slist_append(sl, kick);
-- snare = raw_wave_new("raw/snare.raw");
-+ snare = raw_wave_new("/usr/share/freebirth/raw/snare.raw");
- sl = g_slist_append(sl, snare);
-- cl_hat = raw_wave_new("raw/cl_hat.raw");
-+ cl_hat = raw_wave_new("/usr/share/freebirth/raw/cl_hat.raw");
- sl = g_slist_append(sl, cl_hat);
-- op_hat = raw_wave_new("raw/op_hat.raw");
-+ op_hat = raw_wave_new("/usr/share/freebirth/raw/op_hat.raw");
- sl = g_slist_append(sl, op_hat);
-- samp_1 = raw_wave_new("raw/samp_1.raw");
-+ samp_1 = raw_wave_new("/usr/share/freebirth/raw/samp_1.raw");
- sl = g_slist_append(sl, samp_1);
-
- sources = (sample_producer**)
-@@ -1087,7 +1087,7 @@
-
-
- /*effect window */
-- effect_window = gtk_window_new (GTK_WINDOW_DIALOG);
-+ effect_window = gtk_window_new (GTK_WINDOW_TOPLEVEL);
- gtk_window_set_title(GTK_WINDOW (effect_window), "Effects");
- gtk_widget_set_style(effect_window,window_style);
- effect_box = gtk_vbox_new(FALSE,10);
-@@ -1109,7 +1109,7 @@
-
-
- /* sample freq window */
-- sample_freq_window = gtk_window_new (GTK_WINDOW_DIALOG);
-+ sample_freq_window = gtk_window_new (GTK_WINDOW_TOPLEVEL);
- gtk_window_set_title(GTK_WINDOW (sample_freq_window), "Sample Pitch");
- sample_freq_box = gtk_vbox_new(TRUE,10);
- gtk_widget_set_style(sample_freq_window,window_style);
---- fuse_loops.c
-+++ fuse_loops.c
-@@ -122,7 +122,18 @@
- fprintf(file, "/* generated file -- don't edit */\n");
- fprintf(file, "#include <unistd.h>\n");
- fprintf(file, "#include <math.h>\n");
-+ fprintf(file, "#include <endian.h>\n");
- fprintf(file, "#include \"freebirth.h\"\n");
-+ fprintf(file, "/* borrowed from glib2 */\n");
-+ fprintf(file, "#define SHORT_SWAP_LE_BE(val) ((short) ( \\\n");
-+ fprintf(file, " (short) ((short) (val) >> 8) | \\\n");
-+ fprintf(file, " (short) ((short) (val) << 8)))\n");
-+ fprintf(file, "static void swap_endian(short *data, int length)\n");
-+ fprintf(file, "{\n");
-+ fprintf(file, " int i;\n");
-+ fprintf(file, " for (i = 0; i < length; i += 1, data++)\n");
-+ fprintf(file, " *data = SHORT_SWAP_LE_BE(*data);\n");
-+ fprintf(file, "}\n");
- fprintf(file, "\n");
-
- fprintf(file, "sample_producer *sp[%d];\n", g_list_length(order));
-@@ -172,6 +183,9 @@
- fprintf(file, " }\n");
- fprintf(file, "\n");
-
-+ fprintf(file, "#if __BYTE_ORDER == __BIG_ENDIAN\n");
-+ fprintf(file, " swap_endian(buffer, 2 * TBASS_BUFF_SIZE);\n");
-+ fprintf(file, "#endif\n");
- fprintf(file, " write(fd, buffer, 2 * TBASS_BUFF_SIZE * sizeof(short));\n");
- fprintf(file, "\n");
-
---- gtkdial.c
-+++ gtkdial.c
-@@ -75,8 +75,6 @@
- sizeof (GtkDialClass),
- (GtkClassInitFunc) gtk_dial_class_init,
- (GtkObjectInitFunc) gtk_dial_init,
-- (GtkArgSetFunc) NULL,
-- (GtkArgGetFunc) NULL,
- };
-
- dial_type = gtk_type_unique (gtk_widget_get_type (), &dial_info);
---- Makefile
-+++ Makefile
-@@ -1,10 +1,9 @@
- # Makefile for Freebirth
- #
-
--CC=gcc
--LOADLIBES=-lm $(shell gtk-config --libs)
--CFLAGS=-g -O6 -Wall $(shell gtk-config --cflags)
--LDFLAGS=
-+CC?=gcc
-+CFLAGS+=-Wall $(shell pkg-config --cflags gtk+-2.0)
-+LIBS=-lm $(shell pkg-config --libs gtk+-2.0)
-
- OFILES=\
- oscillator.o sequencer.o envelope.o filter.o gtkdial.o mixer.o \
-@@ -22,16 +21,18 @@
- -rm -f *.o freebirth fusebirth fused_loop.c Makefile.deps *~
-
- freebirth: $(OFILES) fused_loop.o freebirth.o
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o freebirth $(OFILES) fused_loop.o freebirth.o $(LIBS)
-
- fused_loop.c: fusebirth
- ./fusebirth > fused_loop.c 2>/dev/null
-
- fusebirth: $(OFILES) fuse_loops.o fusebirth.o
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o fusebirth $(OFILES) fuse_loops.o fusebirth.o $(LIBS)
-
- fusebirth.o: freebirth.c
- $(CC) -c $(CFLAGS) -DFUSE_LOOPS -o fusebirth.o freebirth.c
-
- Makefile.deps:
-- gcc -MM $(CFLAGS) $(CFILES) > Makefile.deps
-+ $(CC) -MM $(CFLAGS) $(CFILES) > Makefile.deps
-
- include Makefile.deps
---- raw_wave.c
-+++ raw_wave.c
-@@ -21,18 +21,36 @@
- #include "raw_wave.h"
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <math.h>
-+#include <endian.h>
-+
-+/* borrowed from glib2 */
-+#define SHORT_SWAP_LE_BE(val) ((short) ( \
-+ (short) ((short) (val) >> 8) | \
-+ (short) ((short) (val) << 8)))
-+static void swap_endian(short *data, int length)
-+{
-+ int i;
-+ for (i = 0; i < length; i += 1, data++)
-+ *data = SHORT_SWAP_LE_BE(*data);
-+}
-
- static char *get_full_path(char *fn)
- {
- char *full_fn;
- char *fb_samples;
-
-- if (fn == NULL || fn[0] == '/') return fn;
- fb_samples = getenv("FB_SAMPLES");
- if (fb_samples == NULL) fb_samples = FB_SAMPLES;
-- sprintf(full_fn = (char *)malloc(strlen(fb_samples) + 1 + strlen(fn) + 1),
-- "%s/%s", fb_samples, fn);
-+ full_fn = (char *)malloc(strlen(fb_samples) + 1 + strlen(fn) + 1);
-+
-+ if (fn == NULL || fn[0] == '/') { /* path is valid already */
-+ sprintf(full_fn, "%s", fn);
-+ } else {
-+ sprintf(full_fn, "%s/%s", fb_samples, fn); /* add path */
-+ }
-+
- return full_fn;
- }
-
-@@ -76,10 +94,13 @@
-
- }
- this->length += count;
-+#if __BYTE_ORDER == __BIG_ENDIAN
-+ swap_endian(tmp, this->length);
-+#endif
- this->table = (sample *)malloc(sizeof(sample) * this->length);
-- for(i = 0; i < this->length;i++)
-+ for(i = 0; i < this->length;i++) {
- this->table[i] = (sample)tmp[i];
--
-+ }
- fclose(in);
- free(tmp);
- }
-@@ -126,6 +147,7 @@
-
- }
- }
-+
- return this->buffer;
- }
-
-@@ -145,7 +167,7 @@
- void raw_wave_set_sample_file(raw_wave* this, char *filename)
- {
- FILE *in;
-- if (this->filename != 0) free(this->filename);
-+ if (this->filename != NULL) free(this->filename);
- this->filename = get_full_path(filename);
- in = fopen(this->filename,"r");
- if( in==NULL )
-@@ -243,7 +265,7 @@
- /* set table to zero here check if it is zero in */
- /* _fill_table */
- out->table = 0;
-- out->filename = 0;
-+ out->filename = NULL;
- raw_wave_set_sample_file(out, filename);
-
- out->buffer = (sample *)malloc(sizeof(sample) * TBASS_BUFF_SIZE);
---- raw_wave.h
-+++ raw_wave.h
-@@ -62,7 +62,7 @@
- event *event_pitch_change_new(int seq_handle, double pitch);
-
- // #define FB_SAMPLES "/usr/local/lib/freebirth"
--#define FB_SAMPLES "."
-+#define FB_SAMPLES "/usr/share/freebirth"
-
- /*
- Local Variables:
diff --git a/media-sound/freebirth/files/freebirth-0.3.2-segfault.patch b/media-sound/freebirth/files/freebirth-0.3.2-segfault.patch
deleted file mode 100644
index 2a3a40711f1c..000000000000
--- a/media-sound/freebirth/files/freebirth-0.3.2-segfault.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=320123
-
-Index: freebirth-0.3.2/oscillator.c
-===================================================================
---- freebirth-0.3.2.orig/oscillator.c
-+++ freebirth-0.3.2/oscillator.c
-@@ -237,8 +237,8 @@ event *event_freq_change_new(int seq_han
-
- static sample_producer **get_children(osc *this)
- {
-- static sample_producer *no_kids[] = { NULL };
-- return no_kids;
-+ static sample_producer no_kids[] = {{ NULL }};
-+ return &no_kids;
- }
-
- static char **get_header(osc *this)
diff --git a/media-sound/freebirth/freebirth-0.3.2-r1.ebuild b/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
deleted file mode 100644
index 271853ab4567..000000000000
--- a/media-sound/freebirth/freebirth-0.3.2-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Free software bass synthesizer step sequencer"
-HOMEPAGE="http://freshmeat.net/releases/8834"
-SRC_URI="http://www.bitmechanic.com/projects/freebirth/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc sparc x86"
-IUSE=""
-
-RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo-2.patch \
- "${FILESDIR}"/${P}-segfault.patch
-}
-
-src_compile() {
- tc-export CC
- emake
-}
-
-src_install() {
- dobin ${PN}
-
- insinto /usr/share/${PN}/raw
- doins raw/*.raw
-
- dodoc CHANGES NEXT_VERSION README
-
- doicon xpm/${PN}.xpm
- make_desktop_entry ${PN} ${PN}
-}
diff --git a/media-sound/freebirth/metadata.xml b/media-sound/freebirth/metadata.xml
deleted file mode 100644
index a38ef435258d..000000000000
--- a/media-sound/freebirth/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sound@gentoo.org</email>
- <name>Gentoo Sound project</name>
- </maintainer>
- <upstream>
- <remote-id type="freshmeat">8834</remote-id>
- </upstream>
-</pkgmetadata>