summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-03-16 21:52:52 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-03-16 19:58:19 +0000
commitbfb56406f279fc842864c081501c4cb6c7c00149 (patch)
treedb660af5e3f756a3e25685f863dafdff9c7fcf89 /media-sound
parentnet-proxy/haproxy: Version bump to 1.5.16 and 1.6.3. Also fixes bug 576580 (diff)
downloadgentoo-bfb56406f279fc842864c081501c4cb6c7c00149.tar.gz
gentoo-bfb56406f279fc842864c081501c4cb6c7c00149.tar.bz2
gentoo-bfb56406f279fc842864c081501c4cb6c7c00149.zip
media-sound/flacon: remove old
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1070
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/flacon/Manifest1
-rw-r--r--media-sound/flacon/files/flacon-1.2.0-fix-corrupt-file-crash.patch22
-rw-r--r--media-sound/flacon/files/flacon-1.2.0-fix-disks-or-tracks-number-change-crash.patch85
-rw-r--r--media-sound/flacon/files/flacon-1.2.0-fix-qpainter-error.patch87
-rw-r--r--media-sound/flacon/flacon-1.2.0.ebuild90
5 files changed, 0 insertions, 285 deletions
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index b746790f5b7e..626e41a8deb6 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1,2 +1 @@
-DIST flacon-1.2.0.tar.gz 283187 SHA256 2ebc83d733ea6d50f2bd4ad8c20c65368be5eaf351e0195c9b4d47a54957b8f8 SHA512 4cc64467350c941eed16299a562ddc3c6c83d785dddffe6825e3df50a988ce9494517b3ea862d90398110564ec3f828ef6760a6c02d24163f9247930330a3b6d WHIRLPOOL 918926069daaf5e9a16711d641c873a70d1dc97f04b05387f649f1d1d6e1d652f3e676f1100d5fe0d70d03fa9edb1d4e64fc67b489f5c5e74d21108a437f87ea
DIST flacon-2.0.1.tar.gz 317356 SHA256 3408304e7ab524a2e8a621ea780579e1be7b3359fefe7d37a1b88f34d6120e02 SHA512 d095880f4aba0d528fb03a860aef6cb818af7fea52642db4a42ed26a1e5bf412d6fb8bff604e148a885ac661275fcc43966b3f56fea133e6acb3ccea15fe5f2c WHIRLPOOL e1c95430473616d79396fa42a7d9c8e4e6ac92ccd32e2c74e185e164607f61faeeb59743c052a93fb140a77e3a0b40738716bbe5e2efdae5ae6a99aae693ae9a
diff --git a/media-sound/flacon/files/flacon-1.2.0-fix-corrupt-file-crash.patch b/media-sound/flacon/files/flacon-1.2.0-fix-corrupt-file-crash.patch
deleted file mode 100644
index 11a4f1307a1c..000000000000
--- a/media-sound/flacon/files/flacon-1.2.0-fix-corrupt-file-crash.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 01bf112e4bfd0718829b7dc6f83de6fbceb3ac0c Mon Sep 17 00:00:00 2001
-From: "sokoloff (Alexander)" <sokoloff.a@gmail.com>
-Date: Fri, 18 Sep 2015 20:15:16 +0300
-Subject: [PATCH] Fix crash if audio file is corrupt
-
----
- disk.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/disk.cpp b/disk.cpp
-index 99c7dff..23d7ab2 100644
---- a/disk.cpp
-+++ b/disk.cpp
-@@ -577,7 +577,7 @@ bool Disk::replaceAudioFile(const QString &fileName, bool force)
- audio = 0;
- }
-
-- if (force || audio->isValid())
-+ if (force || audio)
- {
- delete mAudioFile;
- mAudioFile = audio;
diff --git a/media-sound/flacon/files/flacon-1.2.0-fix-disks-or-tracks-number-change-crash.patch b/media-sound/flacon/files/flacon-1.2.0-fix-disks-or-tracks-number-change-crash.patch
deleted file mode 100644
index 1e9a3369671a..000000000000
--- a/media-sound/flacon/files/flacon-1.2.0-fix-disks-or-tracks-number-change-crash.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-From bf2dc4aa42e91bda2d41e129f7fe6597b9f86673 Mon Sep 17 00:00:00 2001
-From: "sokoloff (Alexander)" <sokoloff.a@gmail.com>
-Date: Sun, 27 Sep 2015 09:24:35 +0300
-Subject: [PATCH] Fix: the program sometimes crash when you change the number
- of disks or tracks
-
----
- disk.cpp | 3 +++
- project.cpp | 9 +++++----
- tests/testflacon.cpp | 6 +++---
- 3 files changed, 11 insertions(+), 7 deletions(-)
-
-diff --git a/disk.cpp b/disk.cpp
-index 969cb71..3b624de 100644
---- a/disk.cpp
-+++ b/disk.cpp
-@@ -433,6 +433,9 @@ void Disk::loadFromCue(const CueTagSet &cueTags, bool activate)
- for (int i=mTracks.count(); i<mCount; ++i)
- mTracks.append(new Track(this, i));
-
-+ while (mTracks.count() > mCount)
-+ mTracks.takeLast()->deleteLater();
-+
- for (int t=0; t<cueTags.tracksCount(); ++t)
- {
- for (int idx=0; idx<100; ++idx)
-diff --git a/project.cpp b/project.cpp
-index 00486e4..38710ae 100644
---- a/project.cpp
-+++ b/project.cpp
-@@ -169,7 +169,8 @@ void Project::removeDisk(const QList<Disk*> *disks)
- Disk *disk = disks->at(i);
- emit beforeRemoveDisk(disk);
- if (mDisks.removeAll(disk))
-- delete disk;
-+ disk->deleteLater();
-+
- emit afterRemoveDisk();
- }
-
-@@ -274,10 +275,10 @@ DiskList Project::addCueFile(const QString &fileName, bool showErrors)
- }
- else
- {
-- foreach(Disk *d, res)
-+ foreach(Disk *disk, res)
- {
-- mDisks.removeAll(d);
-- delete d;
-+ mDisks.removeAll(disk);
-+ disk->deleteLater();
- }
-
- emit layoutChanged();
-diff --git a/tests/testflacon.cpp b/tests/testflacon.cpp
-index bcd7c46..571b425 100644
---- a/tests/testflacon.cpp
-+++ b/tests/testflacon.cpp
-@@ -830,7 +830,7 @@ void TestFlacon::testTrackResultFileName()
- expected);
- QFAIL(msg.toLocal8Bit());
- }
-- delete disk;
-+ disk->deleteLater();
- }
-
-
-@@ -983,7 +983,7 @@ void TestFlacon::testTrackResultFilePath()
- QFAIL(msg.toLocal8Bit());
- }
- //QCOMPARE(result, expected);
-- delete disk;
-+ disk->deleteLater();
- }
-
-
-@@ -1117,7 +1117,7 @@ void TestFlacon::testTrackSetCodepages()
- QFAIL((msg + "\n " + cmd).toLocal8Bit());
- }
-
-- delete disk;
-+ disk->deleteLater();
- }
-
-
diff --git a/media-sound/flacon/files/flacon-1.2.0-fix-qpainter-error.patch b/media-sound/flacon/files/flacon-1.2.0-fix-qpainter-error.patch
deleted file mode 100644
index cc7398730eda..000000000000
--- a/media-sound/flacon/files/flacon-1.2.0-fix-qpainter-error.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From 8ffd4d83e19e8f1e28841f37248e99fae0796b10 Mon Sep 17 00:00:00 2001
-From: "sokoloff (Alexander)" <sokoloff.a@gmail.com>
-Date: Fri, 18 Sep 2015 20:14:31 +0300
-Subject: [PATCH] Fix QPainter::font: Painter not active error
-
----
- gui/trackviewdelegate.cpp | 20 +++++++++-----------
- gui/trackviewdelegate.h | 4 ++--
- 2 files changed, 11 insertions(+), 13 deletions(-)
-
-diff --git a/gui/trackviewdelegate.cpp b/gui/trackviewdelegate.cpp
-index ab05833..02b6137 100644
---- a/gui/trackviewdelegate.cpp
-+++ b/gui/trackviewdelegate.cpp
-@@ -261,8 +261,8 @@ void TrackViewDelegate::paintDisk(QPainter *painter, const QStyleOptionViewItem
- //cache = self.cache(index)
- painter->save();
- painter->setClipRect(option.rect);
-- QFont titleFont = this->titleFont(painter);
-- QFont filesFont = this->filesFont(painter);
-+ QFont titleFont = this->titleFont(painter->font());
-+ QFont filesFont = this->filesFont(painter->font());
-
-
- int topPadding = index.row() ? TOP_PADDING : 0;
-@@ -408,19 +408,17 @@ QSize TrackViewDelegate::sizeHint(const QStyleOptionViewItem &option, const QMod
-
- if (!index.parent().isValid())
- {
--
- if (!mDiskHeightHint)
- {
- int h = 8;
-- QPainter painter(mTrackView);
-- QFont titleFont = this->titleFont(&painter);
-- QFont filesFont = this->filesFont(&painter);
-+
-+ QFont titleFont = this->titleFont(option.font);
-+ QFont filesFont = this->filesFont(option.font);
- h += QFontMetrics(titleFont).height();
- h += QFontMetrics(filesFont).height() * 2;
- mDiskHeightHint = qMax(IMG_HEIGHT, h) + 2 * MARGIN + BOTTOM_PADDING; //For Line
- }
-
--
- res.rheight() = mDiskHeightHint;
- if (index.row())
- res.rheight() += TOP_PADDING;
-@@ -533,9 +531,9 @@ void TrackViewDelegate::downloadingFinished(DataProvider *provider)
- /************************************************
-
- ************************************************/
--QFont TrackViewDelegate::titleFont(const QPainter *painter) const
-+QFont TrackViewDelegate::titleFont(const QFont &font) const
- {
-- QFont res = painter->font();
-+ QFont res = font;
- res.setPointSize(res.pointSize() + 1);
- res.setBold(true);
- return res;
-@@ -545,9 +543,9 @@ QFont TrackViewDelegate::titleFont(const QPainter *painter) const
- /************************************************
-
- ************************************************/
--QFont TrackViewDelegate::filesFont(const QPainter *painter) const
-+QFont TrackViewDelegate::filesFont(const QFont &font) const
- {
-- QFont res = painter->font();
-+ QFont res = font;
- return res;
- }
-
-diff --git a/gui/trackviewdelegate.h b/gui/trackviewdelegate.h
-index 3a6aa09..492e514 100644
---- a/gui/trackviewdelegate.h
-+++ b/gui/trackviewdelegate.h
-@@ -76,8 +76,8 @@ private slots:
- QMovie mDownloadMovie;
- mutable int mDiskHeightHint;
-
-- QFont titleFont(const QPainter *painter) const;
-- QFont filesFont(const QPainter *painter) const;
-+ QFont titleFont(const QFont &font) const;
-+ QFont filesFont(const QFont &font) const;
- void paintTrack(QPainter *painter, const QStyleOptionViewItem &option, const QModelIndex &index, const Track *track) const;
- void paintDisk(QPainter *painter, const QStyleOptionViewItem &option, const QModelIndex &index, const Disk *disk) const;
- QRect drawLabel(const QString &text, QRect rect, QPainter *painter) const;
diff --git a/media-sound/flacon/flacon-1.2.0.ebuild b/media-sound/flacon/flacon-1.2.0.ebuild
deleted file mode 100644
index 52f4cfc10e4d..000000000000
--- a/media-sound/flacon/flacon-1.2.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# Ignore rudimentary uz@Latn, zh_TW translation(s)
-PLOCALES="cs_CZ cs de es_MX es fr gl hu it ja_JP lt pl_PL pl pt_BR pt_PT ro_RO ru sr tr uk zh_CN"
-
-inherit cmake-utils fdo-mime gnome2-utils l10n
-
-DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
-HOMEPAGE="https://flacon.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aac flac mac mp3 opus qt4 qt5 replaygain tta vorbis wavpack"
-
-DEPEND="
- dev-libs/uchardet
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- )
- qt5? (
- dev-qt/linguist-tools:5
- dev-qt/qtnetwork:5
- dev-qt/qtwidgets:5
- )
-"
-RDEPEND="${DEPEND}
- media-sound/shntool[mac?]
- aac? ( media-libs/faac )
- flac? ( media-libs/flac )
- mac? ( media-sound/mac )
- mp3? ( media-sound/lame )
- opus? ( media-sound/opus-tools )
- replaygain? (
- mp3? ( media-sound/mp3gain )
- vorbis? ( media-sound/vorbisgain )
- )
- tta? ( media-sound/ttaenc )
- vorbis? ( media-sound/vorbis-tools )
- wavpack? ( media-sound/wavpack )
-"
-
-REQUIRED_USE="^^ ( qt4 qt5 )"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-qpainter-error.patch"
- "${FILESDIR}/${P}-fix-corrupt-file-crash.patch"
- "${FILESDIR}/${P}-fix-disks-or-tracks-number-change-crash.patch"
-)
-
-src_prepare() {
- # Ignore rudimentary uz@Latn, zh_TW translation(s)
- rm "translations/${PN}_uz@Latn.desktop" || die
- rm "translations/${PN}_zh_TW.ts" || die
-
- remove_locale() {
- rm "translations/${PN}_${1}."{ts,desktop} || die
- }
-
- l10n_find_plocales_changes 'translations' "${PN}_" '.ts'
- l10n_for_each_disabled_locale_do remove_locale
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_use qt4 QT4)
- $(cmake-utils_use_use qt5 QT5)
- )
- cmake-utils_src_configure
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
-}