summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-10 22:28:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-10 22:34:14 +0200
commitc3c6bc2129c964462846ea2625d96c52f6ba040e (patch)
treee27cb8b1ef6db3cd207d2ad319745bd2962a56b6 /media-sound
parentmedia-libs/fluidsynth-dssi: revbump with fluidsynth-2 support, EAPI 7 (diff)
downloadgentoo-c3c6bc2129c964462846ea2625d96c52f6ba040e.tar.gz
gentoo-c3c6bc2129c964462846ea2625d96c52f6ba040e.tar.bz2
gentoo-c3c6bc2129c964462846ea2625d96c52f6ba040e.zip
media-sound/tuxguitar: fdo-mime->xdg-utils, eutils->desktop, HOMEPAGE
Add missing media-sound/fluidsynth slot op Minur tidy-up: no ${PN} in DESCRIPTION CDEPEND -> COMMON_DEPEND Sort DEPENDs Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/tuxguitar/tuxguitar-1.3.2.ebuild47
1 files changed, 24 insertions, 23 deletions
diff --git a/media-sound/tuxguitar/tuxguitar-1.3.2.ebuild b/media-sound/tuxguitar/tuxguitar-1.3.2.ebuild
index 61ca5827d67c..7c0a2bf1b65c 100644
--- a/media-sound/tuxguitar/tuxguitar-1.3.2.ebuild
+++ b/media-sound/tuxguitar/tuxguitar-1.3.2.ebuild
@@ -1,39 +1,40 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-JAVA_PKG_IUSE="source"
-
-inherit eutils java-pkg-2 java-ant-2 toolchain-funcs flag-o-matic fdo-mime gnome2-utils
+EAPI=6
MY_P="${P}-src"
-DESCRIPTION="TuxGuitar is a multitrack guitar tablature editor and player written in Java-SWT"
-HOMEPAGE="http://tuxguitar.herac.com.ar/"
+JAVA_PKG_IUSE="source"
+inherit desktop java-pkg-2 java-ant-2 toolchain-funcs flag-o-matic xdg-utils
+
+DESCRIPTION="Multitrack guitar tablature editor and player written in Java-SWT"
+HOMEPAGE="http://www.tuxguitar.com.ar/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
LICENSE="LGPL-2.1"
SLOT="0"
-
IUSE="alsa fluidsynth jack lilypond oss pdf timidity tray"
-
KEYWORDS="~amd64 ~x86"
-CDEPEND="dev-java/swt:3.7[cairo]
+COMMON_DEPEND="
+ dev-java/swt:3.7[cairo]
alsa? ( media-libs/alsa-lib )
pdf? ( dev-java/itext:5 )
- fluidsynth? ( media-sound/fluidsynth )
- lilypond? ( media-sound/lilypond )"
-
-RDEPEND=">=virtual/jre-1.5
+ fluidsynth? ( media-sound/fluidsynth:= )
+ lilypond? ( media-sound/lilypond )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=virtual/jre-1.5
timidity? ( media-sound/timidity++[alsa?,oss?] )
- ${CDEPEND}"
+"
+DEPEND="${COMMON_DEPEND}
+ >=virtual/jdk-1.5
+"
-DEPEND=">=virtual/jdk-1.5
- ${CDEPEND}"
+PATCHES=( "${FILESDIR}"/${PN}-fixed-ant-files.patch )
S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-fixed-ant-files.patch )
-
LIBRARY_LIST=()
PLUGIN_LIST=()
@@ -116,8 +117,8 @@ src_install() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
if use fluidsynth; then
ewarn "Fluidsynth plugin blocks behavior of JSA plugin."
ewarn "Enable only one of them in \"Tools > Plugins\""
@@ -125,6 +126,6 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
}