summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-06-18 18:04:45 +0200
committerJohannes Huber <johu@gentoo.org>2019-06-18 18:05:12 +0200
commitf765a8b852e8fe86b7d4608865a62ea8074f39e3 (patch)
treeafba534bb3abf2d6975cf127910886b7df9eea98 /media-sound
parentnet-misc/cadaver: Fix eautoreconf with >=sys-devel/gettext-0.20. (diff)
downloadgentoo-f765a8b852e8fe86b7d4608865a62ea8074f39e3.tar.gz
gentoo-f765a8b852e8fe86b7d4608865a62ea8074f39e3.tar.bz2
gentoo-f765a8b852e8fe86b7d4608865a62ea8074f39e3.zip
media-sound/lollypop: Version bump 1.0.12
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.0.12.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index 6dc3974e0042..3c02ca6d4200 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.0.11.tar.xz 448424 BLAKE2B 80cbd622b46d667ca566e8aac9f523a83cf8b43e61abe06eb0aeaa6fd22a45611ba38fdfd64dfce7b1e1f946bea8b7a2b589152c6b3c762cbdffb041c4c7de08 SHA512 9a885a88af8a4d58b12ef7da82d35bbc3256cabd2a38ac0b35e8a0753b1e10dfa7e69e8e5f6c7f8ba68d2557cfe47c6003ee1f68ecf6c434e5ab81f18c2ae935
+DIST lollypop-1.0.12.tar.xz 448864 BLAKE2B 65681bc29f8256ad8f9d6dadac7a6d147150a8f779e25c85744a39428176c6887e3a9f90f0af81f432db771806351301712ec2431c3a79bcb230c8c0e6fb055b SHA512 d6ad6fb638ac994c2c0367234c8ab35b79d619b3669c46f27bc1df221e41410f464a0a157faccf0ed1b2b5fbdb9f1ecad10ec7466bdff03231e4724948c8c3a2
DIST lollypop-1.0.7.tar.xz 436000 BLAKE2B 8b41a3378e39b0cba59323bbd7946226bcce29f80c878833ac920f337c036fcaca9c81caca2e360972295c6446c67d79e201093f86cad0685f7365a332d0e116 SHA512 ce537e60e3f1c678fcbf26d1305a178a3f2299abd4f75bb3c3a2cf717295e14aa73a8f21fb88d0c1fc790a80a572dbce84d01a0fe3229879124f89f8a5fa8305
diff --git a/media-sound/lollypop/lollypop-1.0.12.ebuild b/media-sound/lollypop/lollypop-1.0.12.ebuild
new file mode 100644
index 000000000000..3d527f7332d4
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.0.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+HASH="011cb4140566625941a0fc645ac6d528"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://gitlab.gnome.org/World/${PN}/uploads/${HASH}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}