summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-06-07 15:26:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-06-08 08:56:47 +0300
commitf99a5d4c1caffc20532913020d394a9e1e855ebe (patch)
tree3efed62f50133f7cb00d20552b1f536c7b17b490 /media-sound
parentdev-python/myst_parser: Bump to 0.18.0 (diff)
downloadgentoo-f99a5d4c1caffc20532913020d394a9e1e855ebe.tar.gz
gentoo-f99a5d4c1caffc20532913020d394a9e1e855ebe.tar.bz2
gentoo-f99a5d4c1caffc20532913020d394a9e1e855ebe.zip
media-sound/sndio: fix hardcoded pkgconfdir path
- on a multilib system sndio will install the 64-bit pkgconfig file under /usr/lib which then won't get found by non-multilib packages. Closes: https://bugs.gentoo.org/842420 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch12
-rw-r--r--media-sound/sndio/sndio-1.8.0-r1.ebuild55
2 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch b/media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch
new file mode 100644
index 000000000000..70c66157fab8
--- /dev/null
+++ b/media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch
@@ -0,0 +1,12 @@
+diff -Naur a/configure b/configure
+--- a/configure 2021-05-07 10:49:58.000000000 +0300
++++ b/configure 2022-06-07 14:49:07.623069325 +0300
+@@ -205,7 +205,7 @@
+ datadir="${datadir:-$prefix/share}"
+ includedir="${includedir:-$prefix/include}"
+ libdir="${libdir:-$exec_prefix/lib}"
+-pkgconfdir="${pkgconfdir:-$prefix/lib/pkgconfig}"
++pkgconfdir="${pkgconfdir:-$libdir/pkgconfig}"
+ mandir="${mandir:-$prefix/share/man}"
+
+ #
diff --git a/media-sound/sndio/sndio-1.8.0-r1.ebuild b/media-sound/sndio/sndio-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..3a22a2e82ac8
--- /dev/null
+++ b/media-sound/sndio/sndio-1.8.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="http://www.sndio.org/"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://caoua.org/git/sndio"
+ EGIT_MIN_CLONE_TYPE="single+tags"
+else
+ SRC_URI="http://www.sndio.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0/7.1"
+IUSE="alsa"
+
+DEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/sndiod
+"
+
+PATCHES=( "${FILESDIR}"/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch )
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --privsep-user=sndiod \
+ --with-libbsd \
+ $(use_enable alsa) \
+ || die "Configure failed"
+}
+
+src_install() {
+ multilib-minimal_src_install
+
+ doinitd "${FILESDIR}/sndiod"
+}