summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-11-26 22:49:59 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-11-26 22:50:39 +0000
commiteb84f08c04519b2273a8d6729039e783b70eafc1 (patch)
treee2dcdee6533b7e030efad816319f68cbca94b878 /media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
parentsys-auth/rtkit: stable 0.11-r2 for sparc, bug #626788 (thanks to Rolf Eike Beer) (diff)
downloadgentoo-eb84f08c04519b2273a8d6729039e783b70eafc1.tar.gz
gentoo-eb84f08c04519b2273a8d6729039e783b70eafc1.tar.bz2
gentoo-eb84f08c04519b2273a8d6729039e783b70eafc1.zip
media-tv/dtv-scan-tables: New package to supersede linuxtv-dvb-apps
This doesn't need to block linuxtv-dvb-apps as they install the tables into different directories. Closes: https://bugs.gentoo.org/503028 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild')
-rw-r--r--media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild b/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
new file mode 100644
index 000000000000..08c15c3ef583
--- /dev/null
+++ b/media-tv/dtv-scan-tables/dtv-scan-tables-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV#9999} != ${PV} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.linuxtv.org/dtv-scan-tables.git"
+else
+ COMMIT="c1986d5148d8"
+ SRC_URI="https://linuxtv.org/downloads/dtv-scan-tables/dtv-scan-tables-${PV:3:4}-${PV:7:2}-${PV:9:2}-${COMMIT}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/usr/share/dvb"
+fi
+
+DESCRIPTION="Digital TV scan tables in v3 and v5 format"
+HOMEPAGE="https://linuxtv.org/"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=media-tv/v4l-utils-1.4"
+
+DOCS=( README )
+
+src_compile() {
+ emake dvbv3 dvbv5
+}
+
+src_install() {
+ emake PREFIX="${ED}usr" install install_v3
+ einstalldocs
+}