summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-tv/ivtv-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-tv/ivtv-utils')
-rw-r--r--media-tv/ivtv-utils/Manifest1
-rw-r--r--media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch99
-rw-r--r--media-tv/ivtv-utils/files/ivtv-utils-1.4.1-overflow.patch71
-rw-r--r--media-tv/ivtv-utils/ivtv-utils-1.4.1.ebuild47
-rw-r--r--media-tv/ivtv-utils/metadata.xml13
5 files changed, 231 insertions, 0 deletions
diff --git a/media-tv/ivtv-utils/Manifest b/media-tv/ivtv-utils/Manifest
new file mode 100644
index 000000000000..b5c4b1e79764
--- /dev/null
+++ b/media-tv/ivtv-utils/Manifest
@@ -0,0 +1 @@
+DIST ivtv-utils-1.4.1.tar.gz 189918 SHA256 8eebe8bda62f348779c24522f78fb3c0231e33d303b6381185eeb795fe761ef6
diff --git a/media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch b/media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch
new file mode 100644
index 000000000000..4b75d177e391
--- /dev/null
+++ b/media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch
@@ -0,0 +1,99 @@
+Fixing multiple QA issues
+ * respect user {CC,CXX,LD}FLAGS
+ * fix linking order
+ * make job server for install phase
+
+Don't install ivtv-ctl (bug #333291) and v4l2-ctl (bug #278255)
+Don't install duplicate kernel headers (bug #244584)
+
+https://bugs.gentoo.org/show_bug.cgi?id=321303
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- test/Makefile
++++ test/Makefile
+@@ -7,13 +7,13 @@
+ ivtv-osd-dma-test ivtv-fb-colormap-test \
+ ivtv-fb-16-bit-test ps-analyzer
+
+-CFLAGS = -I../utils -D_GNU_SOURCE -O2 -Wall
+-CXXFLAGS = $(CFLAGS)
+-LDFLAGS = -lm
++CFLAGS += -I../utils -D_GNU_SOURCE -Wall
++CXXFLAGS += -I../utils -D_GNU_SOURCE -Wall
++LDLIBS = -lm
+
+ all: $(EXES)
+
+-install: all
++install:
+
+ clean:
+ rm -f *.o $(EXES)
+--- utils/Makefile.orig 2010-05-24 15:35:11.321677941 +0000
++++ utils/Makefile 2010-05-24 15:35:15.595615306 +0000
+@@ -9,41 +9,39 @@
+ X86_EXES := ivtvplay ivtv-mpegindex #ivtv-encoder
+ endif
+
+-EXES := v4l2-ctl ivtv-ctl ivtv-radio $(X86_EXES)
++EXES := ivtv-radio $(X86_EXES)
+
+ BIN := $(EXES) ivtv-tune/ivtv-tune cx25840ctl/cx25840ctl
+
+
+ HEADERS := linux/ivtv.h linux/ivtvfb.h
+
+-CFLAGS = -D_GNU_SOURCE -O2 -Wall -g -I.
+-CXXFLAGS = $(CFLAGS)
++CFLAGS += -D_GNU_SOURCE -Wall -I.
++CXXFLAGS += -D_GNU_SOURCE -Wall -I.
+
+-all:: $(EXES)
+- $(MAKE) CFLAGS="$(CFLAGS)" -C ivtv-tune
+- $(MAKE) CFLAGS="$(CFLAGS)" -C cx25840ctl
++all: $(EXES)
++ $(MAKE) $(MAKEOPTS) CFLAGS="$(CFLAGS)" -C ivtv-tune
++ $(MAKE) $(MAKEOPTS) CFLAGS="$(CFLAGS)" -C cx25840ctl
+
+ ivtv-ctl: ivtv-ctl.o
+- $(CC) -lm -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+ v4l2-ctl: v4l2-ctl.o
+- $(CXX) -lm -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+ v4l2-dbg: v4l2-dbg.o v4l2-driverids.o v4l2-chipids.o
+- $(CXX) -lm -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ -lm
+
+ ivtvplay: ivtvplay.cc
+- $(CXX) $(CXXFLAGS) -lm -lpthread -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ -lm -lpthread
+
+ encoder.o: encoder.c
+ $(CC) $(CFLAGS) -DVIDEO_PORT=0 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -c $^
+
+ ivtv-encoder: enc_mindex.o enc_chann.o encoder.o
+- $(CC) -lpthread -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lpthread
+
+-install: all
+- install -d $(DESTDIR)/$(HDRDIR)
+- install -m 0644 $(HEADERS) $(DESTDIR)/$(HDRDIR)
++install:
+ install -d $(DESTDIR)/$(BINDIR)
+ install -m 0755 $(BIN) $(DESTDIR)/$(BINDIR)
+
+--- Makefile
++++ Makefile
+@@ -1,6 +1,6 @@
+ all clean install:
+- make -C utils $@
+- make -C test $@
++ $(MAKE) -C utils $@
++ $(MAKE) -C test $@
+
+ distclean: clean
+
diff --git a/media-tv/ivtv-utils/files/ivtv-utils-1.4.1-overflow.patch b/media-tv/ivtv-utils/files/ivtv-utils-1.4.1-overflow.patch
new file mode 100644
index 000000000000..1c2a66159639
--- /dev/null
+++ b/media-tv/ivtv-utils/files/ivtv-utils-1.4.1-overflow.patch
@@ -0,0 +1,71 @@
+http://bugs.gentoo.org/339405
+
+--- utils/cx25840ctl/cx25840ctl.c
++++ utils/cx25840ctl/cx25840ctl.c
+@@ -57,7 +57,7 @@
+ return 0;
+ }
+
+- sprintf(device, "/dev/i2c-%s", opt.inputs[0]);
++ snprintf(device, sizeof(device), "/dev/i2c-%s", opt.inputs[0]);
+
+ // open the device
+ if ((fd = open(device, O_RDWR)) < 0)
+@@ -67,7 +67,7 @@
+ exit(1);
+ }
+
+- sprintf(sysfile, "/sys/bus/i2c/devices/%s-%04x/name", opt.inputs[0], address);
++ snprintf(sysfile, sizeof(sysfile), "/sys/bus/i2c/devices/%s-%04x/name", opt.inputs[0], address);
+ if ((fp = fopen(sysfile, "r")) != NULL)
+ {
+ fgets(name, sizeof(name), fp);
+--- utils/ivtv-ctl.c
++++ utils/ivtv-ctl.c
+@@ -358,7 +358,7 @@
+ __u32 reset = 0;
+ int new_debug_level, gdebug_level;
+ double timestamp;
+- char ptsstr[64];
++ char ptsstr[256];
+ char short_options[26 * 2 * 2 + 1];
+
+ if (argc == 1) {
+@@ -420,7 +420,7 @@
+ static char newdev[20];
+ char dev = device[0];
+
+- sprintf(newdev, "/dev/video%c", dev);
++ snprintf(newdev, sizeof(newdev), "/dev/video%c", dev);
+ device = newdev;
+ }
+ break;
+@@ -600,7 +600,7 @@
+ char buf[20];
+ new_debug_level = debug_level;
+
+- sprintf(buf, "%d", debug_level);
++ snprintf(buf, sizeof(buf), "%d", debug_level);
+ if (dowrite(buf, "/sys/module/ivtv/parameters/debug") == 0) {
+ printf(" set debug level: ");
+ print_debug_mask(new_debug_level);
+--- utils/v4l2-ctl.cpp
++++ utils/v4l2-ctl.cpp
+@@ -416,7 +416,7 @@
+ {
+ char buf[10];
+
+- sprintf(buf, "%08x", num);
++ snprintf(buf, sizeof(buf), "%08x", num);
+ return buf;
+ }
+
+@@ -1449,7 +1449,7 @@
+ static char newdev[20];
+ char dev = device[0];
+
+- sprintf(newdev, "/dev/video%c", dev);
++ snprintf(newdev, sizeof(newdev), "/dev/video%c", dev);
+ device = newdev;
+ }
+ break;
diff --git a/media-tv/ivtv-utils/ivtv-utils-1.4.1.ebuild b/media-tv/ivtv-utils/ivtv-utils-1.4.1.ebuild
new file mode 100644
index 000000000000..26a18c1aabfa
--- /dev/null
+++ b/media-tv/ivtv-utils/ivtv-utils-1.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IVTV utilities for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org/"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.4.x/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="perl"
+
+DEPEND="!media-tv/ivtv"
+RDEPEND="${DEPEND}
+ media-tv/v4l-utils
+ perl? (
+ dev-perl/Video-Frequencies
+ dev-perl/Video-ivtv
+ dev-perl/Config-IniFiles
+ virtual/perl-Getopt-Long
+ dev-perl/perl-tk
+ )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.4.0-gentoo.patch \
+ "${FILESDIR}"/${PN}-1.4.1-overflow.patch
+}
+
+src_compile() {
+ tc-export CC CXX
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc ChangeLog README doc/*
+
+ if use perl; then
+ dobin utils/perl/*.pl
+ dodoc utils/perl/README.ptune
+ fi
+}
diff --git a/media-tv/ivtv-utils/metadata.xml b/media-tv/ivtv-utils/metadata.xml
new file mode 100644
index 000000000000..1d7f067588e9
--- /dev/null
+++ b/media-tv/ivtv-utils/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+ <longdescription>
+ Driver for ivtv based tv tuner cards, currently supports Hauppauge
+ PVR-[23]50 cards
+ </longdescription>
+</pkgmetadata>