summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2015-09-14 09:19:49 -0500
committerDoug Goldstein <cardoe@gentoo.org>2015-09-14 09:20:13 -0500
commit67fb506813d922889a077e6bd04ebd9277234a1a (patch)
tree9e747d3092600a03bf0421610c966ca68e5a8e8e /media-tv/mythtv
parentsys-kernel/aufs-sources: Clean old (diff)
downloadgentoo-67fb506813d922889a077e6bd04ebd9277234a1a.tar.gz
gentoo-67fb506813d922889a077e6bd04ebd9277234a1a.tar.bz2
gentoo-67fb506813d922889a077e6bd04ebd9277234a1a.zip
media-tv/mythtv: multiple init script fixes
The new init scripts had a few bugs related to permissions and command line switches. Gentoo-Bug: 560142 Gentoo-Bug: 560144 Package-Manager: portage-2.2.20.1 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/files/mythbackend.init-r2 (renamed from media-tv/mythtv/files/mythbackend.init-r1)8
-rw-r--r--media-tv/mythtv/mythtv-0.27.5_p20150904-r1.ebuild (renamed from media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild)2
2 files changed, 5 insertions, 5 deletions
diff --git a/media-tv/mythtv/files/mythbackend.init-r1 b/media-tv/mythtv/files/mythbackend.init-r2
index e7bbeb186e93..43f53e876ff4 100644
--- a/media-tv/mythtv/files/mythbackend.init-r1
+++ b/media-tv/mythtv/files/mythbackend.init-r2
@@ -38,13 +38,13 @@ start() {
# Work around any strange permissions that may be on these files.
[ "x${MYTHBACKEND_LOGGING}" = "xfiles" ] && \
- checkpath --dir --owner mythv:video --mode 0664 /var/log/mythtv
- checkpath --dir --owner mythv:video --mode 0664 /home/mythtv
+ checkpath --directory --owner mythv:video --mode 0775 /var/log/mythtv
+ checkpath --directory --owner mythv:video --mode 0775 /home/mythtv
ebegin "Starting MythTV Backend"
start-stop-daemon --start --quiet --exec /usr/bin/mythbackend \
- --pidfile /var/run/mythbackend.pid -- \
- --daemon --pidfile /var/run/mythbackend.pid --user mythtv:video \
+ --pidfile /var/run/mythbackend.pid --user mythtv:video -- \
+ --daemon --pidfile /var/run/mythbackend.pid \
--verbose ${MYTHBACKEND_VERBOSE} \
${logging} ${MYTHBACKEND_OPTS}
eend $?
diff --git a/media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild b/media-tv/mythtv/mythtv-0.27.5_p20150904-r1.ebuild
index 62926a852ba7..05358ad15155 100644
--- a/media-tv/mythtv/mythtv-0.27.5_p20150904.ebuild
+++ b/media-tv/mythtv/mythtv-0.27.5_p20150904-r1.ebuild
@@ -275,7 +275,7 @@ src_install() {
insinto /usr/share/mythtv/database
doins database/*
- newinitd "${FILESDIR}"/mythbackend.init-r1 mythbackend
+ newinitd "${FILESDIR}"/mythbackend.init-r2 mythbackend
newconfd "${FILESDIR}"/mythbackend.conf-r1 mythbackend
systemd_dounit "${FILESDIR}"/mythbackend.service