summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2017-12-04 22:11:05 +0000
committerJames Le Cuirot <chewi@gentoo.org>2017-12-04 22:20:07 +0000
commitf3544384630a818ea97571db41ee93919ad9c719 (patch)
tree0d3ce3a0d1093821041df346a5493805f035abe1 /media-tv/tvheadend/tvheadend-4.2.4.ebuild
parentmedia-sound/rosegarden: Bump to EAPI 6 (diff)
downloadgentoo-f3544384630a818ea97571db41ee93919ad9c719.tar.gz
gentoo-f3544384630a818ea97571db41ee93919ad9c719.tar.bz2
gentoo-f3544384630a818ea97571db41ee93919ad9c719.zip
media-tv/tvheadend: Version bump to 4.2.4 and 9999 update
* Add support for dvbcsa via USE flag * Add support for dvben50221 via USE flag * Drop support for libav (fails version checks, missing symbols) * Source DTV scan tables from new media-tv/dtv-scan-tables package * Set tvheadend user HOME to /etc/tvheadend to allow for XMLTV data * Tighten up the systemd service unit * Add debug USE flag for trace support * Fix inotify kernel config check * Add ffmpeg sub-dependencies and associated USE flags (9999 only) Closes: https://bugs.gentoo.org/579048 Closes: https://bugs.gentoo.org/579986 Closes: https://bugs.gentoo.org/586448 Closes: https://bugs.gentoo.org/588210 Closes: https://bugs.gentoo.org/626238 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'media-tv/tvheadend/tvheadend-4.2.4.ebuild')
-rw-r--r--media-tv/tvheadend/tvheadend-4.2.4.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/media-tv/tvheadend/tvheadend-4.2.4.ebuild b/media-tv/tvheadend/tvheadend-4.2.4.ebuild
new file mode 100644
index 000000000000..d56276ff4fcd
--- /dev/null
+++ b/media-tv/tvheadend/tvheadend-4.2.4.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs user
+
+DESCRIPTION="Tvheadend is a TV streaming server and digital video recorder"
+HOMEPAGE="https://tvheadend.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="+capmt +constcw +cwc dbus debug dvbcsa dvben50221 +dvb +ffmpeg hdhomerun +imagecache +inotify iptv satip systemd +timeshift uriparser xmltv zeroconf zlib"
+
+RDEPEND="
+ dev-libs/openssl:=
+ virtual/libiconv
+ dbus? ( sys-apps/dbus )
+ dvbcsa? ( media-libs/libdvbcsa )
+ dvben50221? ( media-tv/linuxtv-dvb-apps )
+ ffmpeg? ( media-video/ffmpeg:0/55.57.57 )
+ hdhomerun? ( media-libs/libhdhomerun )
+ uriparser? ( dev-libs/uriparser )
+ zeroconf? ( net-dns/avahi )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ dvb? ( virtual/linuxtv-dvb-headers )"
+
+RDEPEND+="
+ dvb? ( media-tv/dtv-scan-tables )
+ xmltv? ( media-tv/xmltv )"
+
+REQUIRED_USE="dvbcsa? ( || ( capmt constcw cwc dvben50221 ) )"
+
+# Some patches from:
+# https://github.com/rpmfusion/tvheadend
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.9-use_system_queue.patch"
+ "${FILESDIR}/${PN}-4.2.1-hdhomerun.patch"
+ "${FILESDIR}/${PN}-4.2.2-dtv_scan_tables.patch"
+)
+
+DOCS=( README.md )
+
+pkg_setup() {
+ use inotify &&
+ CONFIG_CHECK="~INOTIFY_USER" linux-info_pkg_setup
+
+ enewuser tvheadend -1 -1 /etc/tvheadend video
+}
+
+src_configure() {
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="${CHOST}-pkg-config" \
+ econf \
+ --disable-bundle \
+ --disable-ccache \
+ --disable-dvbscan \
+ --disable-ffmpeg_static \
+ --disable-hdhomerun_static \
+ --nowerror \
+ $(use_enable capmt) \
+ $(use_enable constcw) \
+ $(use_enable cwc) \
+ $(use_enable dbus dbus_1) \
+ $(use_enable debug trace) \
+ $(use_enable dvb linuxdvb) \
+ $(use_enable dvbcsa) \
+ $(use_enable dvben50221) \
+ $(use_enable ffmpeg libav) \
+ $(use_enable hdhomerun hdhomerun_client) \
+ $(use_enable imagecache) \
+ $(use_enable inotify) \
+ $(use_enable iptv) \
+ $(use_enable satip satip_server) \
+ $(use_enable satip satip_client) \
+ $(use_enable systemd libsystemd_daemon) \
+ $(use_enable timeshift) \
+ $(use_enable uriparser) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable zlib)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/tvheadend.initd tvheadend
+ newconfd "${FILESDIR}"/tvheadend.confd tvheadend
+
+ use systemd &&
+ systemd_dounit "${FILESDIR}"/tvheadend.service
+
+ dodir /etc/tvheadend
+ fperms 0700 /etc/tvheadend
+ fowners tvheadend:video /etc/tvheadend
+}
+
+pkg_postinst() {
+ elog "The Tvheadend web interface can be reached at:"
+ elog "http://localhost:9981/"
+ elog
+ elog "Make sure that you change the default username"
+ elog "and password via the Configuration / Access control"
+ elog "tab in the web interface."
+}