summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@ts.fujitsu.com>2017-07-12 00:12:02 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-12 07:46:28 +0200
commite0c1035aba761db0cbb2e72144fffa6b70d753a8 (patch)
treee4290551e31e2d4d4c16e26780d03fef1d2132a3 /media-tv/v4l-dvb-saa716x
parentmedia-tv/v4l-dvb-saa716x: updated ebuild for kernel 4.6 and up, #612420 (diff)
downloadgentoo-e0c1035aba761db0cbb2e72144fffa6b70d753a8.tar.gz
gentoo-e0c1035aba761db0cbb2e72144fffa6b70d753a8.tar.bz2
gentoo-e0c1035aba761db0cbb2e72144fffa6b70d753a8.zip
media-tv/v4l-dvb-saa716x: fix 4.9 compile warnings, 4.10+ compile errors
Closes: https://github.com/gentoo/gentoo/pull/4192 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-tv/v4l-dvb-saa716x')
-rw-r--r--media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.10-fix-compile.patch18
-rw-r--r--media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.9-fix-warnings.patch146
-rw-r--r--media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild12
3 files changed, 171 insertions, 5 deletions
diff --git a/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.10-fix-compile.patch b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.10-fix-compile.patch
new file mode 100644
index 000000000000..4086da102b80
--- /dev/null
+++ b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.10-fix-compile.patch
@@ -0,0 +1,18 @@
+--- a/linux/drivers/media/common/saa716x/saa716x_ff.h
++++ b/linux/drivers/media/common/saa716x/saa716x_ff.h
+@@ -1,7 +1,6 @@
+ #ifndef __SAA716x_FF_H
+ #define __SAA716x_FF_H
+
+-#include "dvb_filter.h"
+ #include "dvb_ringbuffer.h"
+ #include <linux/version.h>
+ #include <linux/workqueue.h>
+@@ -95,6 +94,7 @@
+ #define MAX_RESULT_LEN 256
+ #define MAX_DATA_LEN (1024 * 1024)
+
++#define TS_SIZE 188
+ #define TSOUT_LEN (1024 * TS_SIZE)
+ #define TSOUT_LEVEL_FILL (350 * TS_SIZE)
+ #define TSOUT_LEVEL_HIGH (30 * TS_SIZE)
diff --git a/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.9-fix-warnings.patch b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.9-fix-warnings.patch
new file mode 100644
index 000000000000..a32ab60868a6
--- /dev/null
+++ b/media-tv/v4l-dvb-saa716x/files/v4l-dvb-saa716x-4.9-fix-warnings.patch
@@ -0,0 +1,146 @@
+--- a/linux/drivers/media/common/saa716x/saa716x_rom.c 2015-12-29 19:40:55.000000000 +0100
++++ a/linux/drivers/media/common/saa716x/saa716x_rom.c 2017-07-11 00:51:19.149941914 +0200
+@@ -113,7 +113,7 @@
+ memcpy(rom_header, &buf[*offset], sizeof (struct saa716x_romhdr));
+ if (rom_header->header_size != sizeof (struct saa716x_romhdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%zd bytes, Expected=%d",
+ sizeof (struct saa716x_romhdr),
+ rom_header->header_size);
+
+@@ -237,7 +237,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_decoder_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_decoder_hdr));
+
+@@ -268,7 +268,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_gpio_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_gpio_hdr));
+
+@@ -305,7 +305,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_video_decoder_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_video_decoder_hdr));
+
+@@ -386,7 +386,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_audio_decoder_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_audio_decoder_hdr));
+
+@@ -417,7 +417,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_evsrc_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_evsrc_hdr));
+
+@@ -448,7 +448,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_xbar_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_xbar_hdr));
+
+@@ -486,7 +486,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_tuner_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_tuner_hdr));
+
+@@ -516,7 +516,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_pll_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_pll_hdr));
+
+@@ -546,7 +546,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_channel_decoder_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_channel_decoder_hdr));
+
+@@ -576,7 +576,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_encoder_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_encoder_hdr));
+
+@@ -606,7 +606,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_ir_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_ir_hdr));
+
+@@ -637,7 +637,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_eeprom_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_eeprom_hdr));
+
+@@ -668,7 +668,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_filter_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_filter_hdr));
+
+@@ -699,7 +699,7 @@
+ saa716x_descriptor_dbg(saa716x, buf, offset, header.size, header.ext_data);
+ if (header.size != sizeof (struct saa716x_streamdev_hdr)) {
+ dprintk(SAA716x_ERROR, 1,
+- "ERROR: Header size mismatch! Read size=%d bytes, Expected=%d",
++ "ERROR: Header size mismatch! Read size=%d bytes, Expected=%zd",
+ header.size,
+ sizeof (struct saa716x_streamdev_hdr));
+
+@@ -789,7 +789,7 @@
+
+ memcpy(device, &buf[*offset], sizeof (struct saa716x_devinfo));
+ if (device->struct_size != sizeof (struct saa716x_devinfo)) {
+- dprintk(SAA716x_ERROR, 1, "ERROR: Device size mismatch! Read=%d bytes, expected=%d bytes",
++ dprintk(SAA716x_ERROR, 1, "ERROR: Device size mismatch! Read=%d bytes, expected=%zd bytes",
+ device->struct_size,
+ sizeof (struct saa716x_devinfo));
+
diff --git a/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild b/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild
index 7a1ee35379db..bf52baeeac2c 100644
--- a/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild
+++ b/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild
@@ -26,10 +26,10 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/powARman-v4l-dvb-saa716x-${HG_REVISION}"
BUILD_TARGETS="modules"
-MODULE_NAMES="saa716x_ff(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
- saa716x_core(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
- saa716x_budget(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
- saa716x_hybrid(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)"
+MODULE_NAMES="saa716x_ff(misc:${EROOT%/}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
+ saa716x_core(misc:${EROOT%/}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
+ saa716x_budget(misc:${EROOT%/}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
+ saa716x_hybrid(misc:${EROOT%/}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)"
CONFIG_CHECK="DVB_CORE DVB_STV6110x DVB_STV090x"
@@ -42,12 +42,14 @@ src_prepare() {
kernel_is ge 4 2 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.2-fix-compile.patch"
kernel_is ge 4 5 2 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.5.2-fix-compile.patch"
kernel_is ge 4 6 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.6.0-fix-compile.patch"
+ kernel_is ge 4 9 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.9-fix-warnings.patch"
+ kernel_is ge 4 10 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.10-fix-compile.patch"
}
src_compile() {
BUILD_PARAMS="SUBDIRS=${S}/linux/drivers/media/common/saa716x \
CONFIG_SAA716X_CORE=m CONFIG_DVB_SAA716X_FF=m CONFIG_DVB_SAA716X_BUDGET=m \
CONFIG_DVB_SAA716X_HYBRID=m"
- addpredict "${ROOT}"/usr/src/linux/
+ addpredict "${EROOT%/}"/usr/src/linux/
linux-mod_src_compile
}