summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-01-17 10:27:16 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-01-17 10:27:16 +0000
commit9eca9891419d58dde8eb284ed60a6dd71278e08f (patch)
tree0cc75ab04a57d581f874a54e0d6314c813faaf24 /media-tv/v4l-utils
parentapp-misc/rpick: Replace 0.7.1 with 0.7.2 (diff)
downloadgentoo-9eca9891419d58dde8eb284ed60a6dd71278e08f.tar.gz
gentoo-9eca9891419d58dde8eb284ed60a6dd71278e08f.tar.bz2
gentoo-9eca9891419d58dde8eb284ed60a6dd71278e08f.zip
media-tv/v4l-utils: Only check Clang in pkg_pretend when installed
I forgot that pkg_pretend() fires before dependencies are installed. We therefore need to check again in pkg_setup(). Bug: https://bugs.gentoo.org/763654 Package-Manager: Portage-3.0.13, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv/v4l-utils')
-rw-r--r--media-tv/v4l-utils/v4l-utils-1.20.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
index a200a8d31f7c..38e272fbe767 100644
--- a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
+++ b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
@@ -46,7 +46,7 @@ PATCHES=(
# Not really prebuilt but BPF objects make our QA checks go crazy.
QA_PREBUILT="*/rc_keymaps/protocols/*.o"
-pkg_pretend() {
+check_llvm() {
if [[ ${MERGE_TYPE} != binary ]] && use bpf; then
local clang=${ac_cv_prog_CLANG:-${CLANG:-clang}}
${clang} -target bpf -print-supported-cpus &>/dev/null ||
@@ -54,6 +54,14 @@ pkg_pretend() {
fi
}
+pkg_pretend() {
+ has_version -b sys-devel/clang && check_llvm
+}
+
+pkg_setup() {
+ check_llvm
+}
+
src_prepare() {
default
eautoreconf