summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-29 08:03:00 +0100
committerSam James <sam@gentoo.org>2023-04-29 08:08:35 +0100
commit8e6ea2a32454b265ef68be83bbc28b5319061421 (patch)
tree79d6572e33cfad1fc12b1f0ddc85881387edd247 /media-tv
parentgames-action/astromenace: backport ODR fix (diff)
downloadgentoo-8e6ea2a32454b265ef68be83bbc28b5319061421.tar.gz
gentoo-8e6ea2a32454b265ef68be83bbc28b5319061421.tar.bz2
gentoo-8e6ea2a32454b265ef68be83bbc28b5319061421.zip
media-tv/mythtv: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/899770 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/files/mythtv-32.0-gcc13.patch40
-rw-r--r--media-tv/mythtv/mythtv-32.0-r4.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/media-tv/mythtv/files/mythtv-32.0-gcc13.patch b/media-tv/mythtv/files/mythtv-32.0-gcc13.patch
new file mode 100644
index 000000000000..5d60da0c72b1
--- /dev/null
+++ b/media-tv/mythtv/files/mythtv-32.0-gcc13.patch
@@ -0,0 +1,40 @@
+https://bugs.gentoo.org/899770
+https://github.com/MythTV/mythtv/commit/3b76df2bb45789f075b6b83d6e6b436aebaf2e83
+
+From 3b76df2bb45789f075b6b83d6e6b436aebaf2e83 Mon Sep 17 00:00:00 2001
+From: David Hampton <mythtv@love2code.net>
+Date: Thu, 19 Jan 2023 14:52:28 -0500
+Subject: [PATCH] Assume existence of stdint.h in exiv2.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Based on this commit to exiv2.
+
+ Author: Luis Díaz Más <piponazo@gmail.com>
+ Date: Wed Sep 16 21:40:05 2020 +0200
+
+ Assume existence of stdint.h
+--- a/external/libexiv2/xmpsdk/include/MD5.h
++++ b/external/libexiv2/xmpsdk/include/MD5.h
+@@ -25,18 +25,7 @@
+
+ #include <sys/types.h>
+
+-#ifdef _MSC_VER
+-// _MSC_VER 1600 == Visual Studio 2010
+-# if _MSC_VER < 1600
+-# ifdef EXV_HAVE_STDINT_H
+-# undef EXV_HAVE_STDINT_H
+-# endif
+-# endif
+-#endif
+-
+-#if defined(EXV_HAVE_STDINT_H) || defined(__MINGW32__) || defined(__MING64__) || defined(__APPLE__)
+-# include <stdint.h>
+-#endif
++#include <cstdint>
+
+ /* MSVC doesn't provide C99 types, but it has MS specific variants */
+ #ifdef _MSC_VER
+
diff --git a/media-tv/mythtv/mythtv-32.0-r4.ebuild b/media-tv/mythtv/mythtv-32.0-r4.ebuild
index ce9af87d74fa..80e017be9774 100644
--- a/media-tv/mythtv/mythtv-32.0-r4.ebuild
+++ b/media-tv/mythtv/mythtv-32.0-r4.ebuild
@@ -152,6 +152,7 @@ python_check_deps() {
PATCHES=(
"${FILESDIR}"/${PN}-32.0-python-version.patch
+ "${FILESDIR}"/${PN}-32.0-gcc13.patch
)
DISABLE_AUTOFORMATTING="yes"