summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-06-04 20:51:57 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-06-28 17:38:17 +0000
commit856366c5b4b00916caa4263b9970d29d0b9838e8 (patch)
tree5376b488b17dc858e73fbc93a89312bd1d3a2584 /media-video/aegisub/files
parentprofiles: mask test USE for aegisub on x86 (diff)
downloadgentoo-856366c5b4b00916caa4263b9970d29d0b9838e8.tar.gz
gentoo-856366c5b4b00916caa4263b9970d29d0b9838e8.tar.bz2
gentoo-856366c5b4b00916caa4263b9970d29d0b9838e8.zip
media-video/aegisub: verbump to 3.2.2_p20160518
Major revamp of the ebuild and the patchset: - EAPI=6; - add testing support; - remove ffmpeg USE and depend on ffmpegsource unconditionally (otherwise aegisub can only open blank 'videos' without any video); - cleanup dependencies; - update the patchset (all changes were submitted upstream); - update LICENSE. Package-Manager: portage-2.3.0_rc1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-video/aegisub/files')
-rw-r--r--media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-system-luajit-build.patch121
-rw-r--r--media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-respect-compiler-flags.patch53
-rw-r--r--media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-support-system-gtest.patch75
3 files changed, 249 insertions, 0 deletions
diff --git a/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-system-luajit-build.patch b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-system-luajit-build.patch
new file mode 100644
index 000000000000..42b57e5fcf45
--- /dev/null
+++ b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-fix-system-luajit-build.patch
@@ -0,0 +1,121 @@
+See http://devel.aegisub.org/ticket/1904
+and http://devel.aegisub.org/ticket/1913
+and http://devel.aegisub.org/ticket/1922
+
+diff --git a/Makefile.inc.in b/Makefile.inc.in
+index d8b3f4a..52e4cf6 100644
+--- a/Makefile.inc.in
++++ b/Makefile.inc.in
+@@ -9,6 +9,7 @@ HAVE_OPENAL = @with_openal@
+ HAVE_OSS = @with_oss@
+ HAVE_PORTAUDIO = @with_portaudio@
+ HAVE_UCHARDET = @with_uchardet@
++SYSTEM_LUAJIT = @with_system_luajit@
+
+ ##############
+ # BUILD OUTPUT
+diff --git a/automation/Makefile b/automation/Makefile
+index 5483dbd..1231aab 100644
+--- a/automation/Makefile
++++ b/automation/Makefile
+@@ -12,10 +12,16 @@ DATA_AUTOMATION_INSTALLED = $(addprefix $(DESTDIR)$(P_DATA)/automation/, $(DATA_
+ $(DESTDIR)$(P_DATA)/automation/%: $(d)%
+ $(MKDIR_INSTALL)
+
+-aegisub-lua_OBJ := $(d)tests/aegisub.o $(TOP)lib/libaegisub.a $(TOP)lib/libluabins.a $(LIBS_LUA)
++aegisub-lua_OBJ := $(d)tests/aegisub.o $(TOP)lib/libaegisub.a $(TOP)lib/libluabins.a
+ aegisub-lua_CPPFLAGS := $(CPPFLAGS_BOOST) $(CFLAGS_LUA) -I$(TOP)libaegisub/include -I$(TOP)src $(CXXFLAGS_WX)
+ aegisub-lua_LIBS := $(LIBS_WX) $(LIBS_BOOST) $(LIBS_ICU) $(LIBS_PTHREAD)
+
++ifeq (no, $(SYSTEM_LUAJIT))
++aegisub-lua_OBJ += $(LIBS_LUA)
++else
++aegisub-lua_LIBS += $(LIBS_LUA)
++endif
++
+ PROGRAM += $(d)aegisub-lua
+
+ test-automation: $(PROGRAM)
+diff --git a/configure.ac b/configure.ac
+index 1649efc..81b1413 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -429,13 +429,15 @@ AS_IF([test $with_system_luajit = no],
+ [AC_SUBST([LUAJIT_CFLAGS], ['-I$(TOP)vendor/luajit/include'])
+ AC_SUBST([LUAJIT_LIBS], ['$(TOP)vendor/luajit/src/libluajit.a'])])
+
++AC_SUBST(with_system_luajit)
++
+ # We also need a Lua binary to run part of the build system
+ # Which version doesn't matter as the scripts are portable between them
+-AC_CHECK_PROGS([LUA], [lua luajit lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1])
++AC_PATH_PROGS([LUA], [luajit lua lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1])
+
+ # If the user doesn't have an installed copy of Lua, just use the one built
+ # as part of building LuaJIT
+-AS_IF([test -z $LUA], [LUA="$srcdir/vendor/luajit/src/host/minilua"])
++AS_IF([test -z $LUA], [LUA='$(TOP)vendor/luajit/src/host/minilua'])
+
+ ######################################################
+ # Debugging support
+diff --git a/header.mk b/header.mk
+index 613b38f..a9ce1d7 100644
+--- a/header.mk
++++ b/header.mk
+@@ -13,7 +13,10 @@ subdirs := \
+ tests \
+ tools \
+ vendor/luabins \
+- vendor/luajit
++
++ifeq (no, $(SYSTEM_LUAJIT))
++subdirs += vendor/luajit
++endif
+
+ subdirs := $(addprefix $(TOP),$(addsuffix /Makefile,$(subdirs)))
+
+diff --git a/src/Makefile b/src/Makefile
+index 0ee6c84..1a6f015 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -6,7 +6,7 @@ src_CPPFLAGS := -I$(d) -I.. -I$(d)include -I$(TOP)libaegisub/include -I$(TOP)bui
+ $(CFLAGS_PTHREAD) $(CFLAGS_FFTW3) $(CFLAGS_ICU) $(CPPFLAGS_BOOST)
+ src_CXXFLAGS := $(CXXFLAGS_WX)
+ src_LIBS := $(LIBS_GL) $(LIBS_PTHREAD) $(LIBS_WX) $(LIBS_FREETYPE) \
+- $(LIBS_LIBASS) $(LIBS_FONTCONFIG) $(LIBS_FFTW3) $(LIBS_BOOST) $(LIBS_ICU)
++ $(LIBS_LIBASS) $(LIBS_FONTCONFIG) $(LIBS_FFTW3) $(LIBS_BOOST) $(LIBS_ICU)
+ src_PCH := $(d)agi_pre.h
+ src_INSTALLNAME := $(AEGISUB_COMMAND)
+
+@@ -111,11 +111,16 @@ src_OBJ := \
+ $(d)video_provider_yuv4mpeg.o \
+ $(d)video_slider.o \
+ $(d)visual_feature.o \
+- $(LIBS_LUA) \
+ $(TOP)lib/libaegisub.a \
+ $(TOP)lib/libluabins.a \
+ $(TOP)lib/libresrc.a \
+
++ifeq (no, $(SYSTEM_LUAJIT))
++src_OBJ += $(LIBS_LUA)
++else
++src_LIBS += $(LIBS_LUA)
++endif
++
+ ifeq (yes, $(BUILD_DARWIN))
+ src_OBJ += $(d)font_file_lister_coretext.o
+ src_OBJ += $(subst .mm,.o,$(wildcard $(d)osx/*.mm))
+diff --git a/tools/Makefile b/tools/Makefile
+index de6166a..e3d108a 100644
+--- a/tools/Makefile
++++ b/tools/Makefile
+@@ -12,6 +12,8 @@ repack-thes-dict_CPPFLAGS := -I$(TOP) -I$(TOP)libaegisub/include $(CFLAGS_ICU)
+
+ PROGRAM += $(d)repack-thes-dict
+
+-$(TOP)tools/respack.lua: $(shell command -v "$(BIN_LUA)")
++ifeq (no, $(SYSTEM_LUAJIT))
++$(TOP)tools/respack.lua: $(BIN_LUA)
++endif
+
+ include $(TOP)Makefile.target
diff --git a/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-respect-compiler-flags.patch b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-respect-compiler-flags.patch
new file mode 100644
index 000000000000..90e57f178dc4
--- /dev/null
+++ b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-respect-compiler-flags.patch
@@ -0,0 +1,53 @@
+See http://devel.aegisub.org/ticket/1899
+and http://devel.aegisub.org/ticket/1900
+
+diff --git a/configure.ac b/configure.ac
+index 1649efc..2f4470b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -133,20 +133,17 @@ AS_IF([test x$build_darwin != xyes], [
+ AC_ARG_ENABLE(compiler-flags, AS_HELP_STRING([--disable-compiler-flags],[Disable *all* additional compiler flags. [no]]))
+
+ AS_IF([test x$enable_compiler_flags != xno], [
+- CFLAGS="$CFLAGS -Wall -Wextra -Wno-unused-parameter -std=gnu99 -pipe -g"
+- CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wno-unused-parameter -fno-strict-aliasing -pipe -g"
++ CFLAGS="$CFLAGS -Wall -Wextra -Wno-unused-parameter"
++ CXXFLAGS="$CXXFLAGS -Wall -Wextra -Wno-unused-parameter -fno-strict-aliasing"
++ AC_C_FLAG([-std=gnu99])
+ AC_CXX_FLAG([-std=c++11])
+- AC_CXX_FLAG([-Wno-c++11-narrowing])
+ AC_C_FLAG([-Wno-unused-local-typedefs])
+ AC_CXX_FLAG([-Wno-unused-local-typedefs])
+
+ # -O* messes with debugging.
+ AS_IF([test x$enable_debug = xyes], [
+- CFLAGS="$CFLAGS -O0"
+- CXXFLAGS="$CXXFLAGS -O0"
+- ], [
+- CFLAGS="$CFLAGS -O3"
+- CXXFLAGS="$CXXFLAGS -O3"
++ CFLAGS="$CFLAGS -O0 -g"
++ CXXFLAGS="$CXXFLAGS -O0 -g"
+ ])
+ ])
+
+diff --git a/src/Makefile b/src/Makefile
+index 0ee6c84..cad213b 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -188,14 +188,13 @@ endif
+ #####################
+ # SOURCE-LEVEL CFLAGS
+ #####################
+-$(d)MatroskaParser.o_FLAGS := -Wno-sometimes-uninitialized
+ $(d)audio_player.o_FLAGS := $(CFLAGS_ALSA) $(CFLAGS_PORTAUDIO) $(CFLAGS_LIBPULSE) $(CFLAGS_OPENAL)
+ $(d)audio_provider_factory.o_FLAGS := $(CFLAGS_FFMS2)
+ $(d)auto4_base.o_FLAGS := $(CFLAGS_FREETYPE)
+ $(d)charset_detect.o_FLAGS := -D_X86_
+ $(d)font_file_lister_fontconfig.o_FLAGS := $(CFLAGS_FONTCONFIG)
+ $(d)subtitles_provider.o_FLAGS := $(CFLAGS_LIBASS)
+-$(d)subtitles_provider_libass.o_FLAGS := $(CFLAGS_LIBASS) -Wno-c++11-narrowing
++$(d)subtitles_provider_libass.o_FLAGS := $(CFLAGS_LIBASS)
+ $(d)text_file_reader.o_FLAGS := -D_X86_
+ $(d)video_provider_manager.o_FLAGS := $(CFLAGS_FFMS2)
+ $(d)auto4_lua.o_FLAGS := $(CFLAGS_LUA)
diff --git a/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-support-system-gtest.patch b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-support-system-gtest.patch
new file mode 100644
index 000000000000..8209ac5ec7c3
--- /dev/null
+++ b/media-video/aegisub/files/3.2.2_p20160518/aegisub-3.2.2_p20160518-support-system-gtest.patch
@@ -0,0 +1,75 @@
+commit 83f868ea8decbbe97891631fe142e84c883ee33d
+Author: Ilya Tumaykin <itumaykin@gmail.com>
+Date: Wed Jun 1 20:00:37 2016 +0300
+
+Allow to build and run tests with a system copy of gtest (googletest)
+
+Also add LIBS_UCHARDET to the mix only when uchardet is requested.
+
+Closes #1923
+
+Bug: http://devel.aegisub.org/ticket/1923
+---
+
+diff --git a/tests/Makefile b/tests/Makefile
+index 8c30c1d..c5bf049 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -1,24 +1,45 @@
+ include $(dir $(lastword $(MAKEFILE_LIST)))../header.mk
+
++WITH_SYSTEM_GTEST ?= no
++
++ifeq (no, $(WITH_SYSTEM_GTEST))
+ GTEST_ROOT ?= $(TOP)vendor/googletest
+ GTEST_FILE := ${GTEST_ROOT}/src/gtest-all
++GTEST_CPPFLAGS := -I$(GTEST_ROOT) -I$(GTEST_ROOT)/include
++GTEST_CXXFLAGS := $(CFLAGS_PTHREAD)
++GTEST_LIBS := $(LIBS_PTHREAD)
++else
++GTEST_CPPFLAGS := $(shell gtest-config --cppflags)
++GTEST_CXXFLAGS := $(shell gtest-config --cxxflags)
++GTEST_LIBS := $(shell gtest-config --libs)
++endif
+
+ run_PCH := $(d)support/tests_pre.h
+ run_CPPFLAGS := -I$(TOP)libaegisub/include -I$(TOP) -I$(d)support \
+- -I$(GTEST_ROOT) -I$(GTEST_ROOT)/include $(CPPFLAGS_BOOST) $(CFLAGS_LUA)
+-run_CXXFLAGS := -Wno-unused-value -Wno-sign-compare
+-run_LIBS := $(LIBS_BOOST) $(LIBS_ICU) $(LIBS_UCHARDET) $(LIBS_PTHREAD)
++ $(CPPFLAGS_BOOST) $(CFLAGS_ICU) $(CFLAGS_LUA) $(GTEST_CPPFLAGS)
++run_CXXFLAGS := -Wno-unused-value -Wno-sign-compare $(GTEST_CXXFLAGS)
++run_LIBS := $(LIBS_BOOST) $(LIBS_ICU) $(GTEST_LIBS)
+ run_OBJ := \
+ $(subst .cpp,.o,$(wildcard $(d)tests/*.cpp)) \
+ $(d)support/main.o \
+ $(d)support/util.o \
+- $(TOP)lib/libaegisub.a \
+- $(GTEST_FILE).o
++ $(TOP)lib/libaegisub.a
+
++ifeq (yes, $(HAVE_UCHARDET))
++run_LIBS += $(LIBS_UCHARDET)
++endif
++
++ifeq (no, $(WITH_SYSTEM_GTEST))
++run_OBJ += $(GTEST_FILE).o
+ # This bit of goofiness is to make it only try to build the tests if google
+ # test can be found and silently skip it if not, by using $(wildcard) to check
+ # for file existence
+ PROGRAM += $(subst $(GTEST_FILE).cc,$(d)run,$(wildcard $(GTEST_FILE).cc))
++test: $(subst $(GTEST_FILE).cc,test-libaegisub,$(wildcard $(GTEST_FILE).cc))
++else
++PROGRAM += $(d)run
++test: test-libaegisub
++endif
+
+ ifeq (yes, $(BUILD_DARWIN))
+ run_LIBS += -framework ApplicationServices -framework Foundation
+@@ -31,6 +52,4 @@ gtest_filter ?= *
+ test-libaegisub: $(d)run $(d)data
+ cd $(TOP)tests; ./run --gtest_filter="$(gtest_filter)"
+
+-test: $(subst $(GTEST_FILE).cc,test-libaegisub,$(wildcard $(GTEST_FILE).cc))
+-
+ include $(TOP)Makefile.target