summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-01-01 05:53:07 +0300
committerIan Delaney <idella4@gentoo.org>2016-01-01 15:55:09 +0800
commit68efac96d646a880a0941040b53290275e8bb85e (patch)
tree582d0c494628c792c61e0af776ca5d4d3319a938 /media-video/aegisub
parentmedia-gfx/splashutils: add missing openrc dependency (diff)
downloadgentoo-68efac96d646a880a0941040b53290275e8bb85e.tar.gz
gentoo-68efac96d646a880a0941040b53290275e8bb85e.tar.bz2
gentoo-68efac96d646a880a0941040b53290275e8bb85e.zip
media-video/aegisub: fix installation of 3.0.4 with empty LINGUAS
3.2.2 and live are not affected. Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/aegisub')
-rw-r--r--media-video/aegisub/aegisub-3.0.4.ebuild3
-rw-r--r--media-video/aegisub/files/aegisub-3.0.4-fix-install-with-empty-LINGUAS.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/media-video/aegisub/aegisub-3.0.4.ebuild b/media-video/aegisub/aegisub-3.0.4.ebuild
index 6320424e2c32..93bc4fef317b 100644
--- a/media-video/aegisub/aegisub-3.0.4.ebuild
+++ b/media-video/aegisub/aegisub-3.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -57,6 +57,7 @@ REQUIRED_USE="
PATCHES=(
"${FILESDIR}/${P}-fix-lua-macro.patch"
+ "${FILESDIR}/${P}-fix-install-with-empty-LINGUAS.patch"
"${FILESDIR}/${P}-respect-user-compiler-flags.patch"
)
diff --git a/media-video/aegisub/files/aegisub-3.0.4-fix-install-with-empty-LINGUAS.patch b/media-video/aegisub/files/aegisub-3.0.4-fix-install-with-empty-LINGUAS.patch
new file mode 100644
index 000000000000..59927d30a7fd
--- /dev/null
+++ b/media-video/aegisub/files/aegisub-3.0.4-fix-install-with-empty-LINGUAS.patch
@@ -0,0 +1,23 @@
+Upstream always installs all available localization files. We workaround it by
+sed'ing out unneeded languages from PO variable in aegisub/po/Makefile file.
+This can lead to an empty PO definition and in this case install target fails.
+Thus a simple guard is introduced to prevent this fail.
+
+diff --git a/aegisub/po/Makefile b/aegisub/po/Makefile
+index 0b73bde..957c123 100644
+--- a/aegisub/po/Makefile
++++ b/aegisub/po/Makefile
+@@ -38,11 +38,13 @@ all: $(MO)
+ $(BIN_MSGFMT) -o $@ $<
+
+ install:
++ifdef PO
+ @$(BIN_MKDIR) -p $(addsuffix /LC_MESSAGES/, $(addprefix $(DESTDIR)$(P_LOCALE)/, $(basename $(PO))))
+ @for i in $(basename $(PO)); do \
+ echo $(BIN_INSTALL) $$i.mo $(DESTDIR)$(P_LOCALE)/$$i/LC_MESSAGES/$(AEGISUB_CATALOG).mo; \
+ $(BIN_INSTALL) $$i.mo $(DESTDIR)$(P_LOCALE)/$$i/LC_MESSAGES/$(AEGISUB_CATALOG).mo; \
+ done
++endif
+
+
+ CLEANFILES = $(MO)