summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/alevt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/alevt/files')
-rw-r--r--media-video/alevt/files/alevt-1.6.2-libpng15.patch11
-rw-r--r--media-video/alevt/files/alevt-1.6.2-respectflags.patch34
2 files changed, 45 insertions, 0 deletions
diff --git a/media-video/alevt/files/alevt-1.6.2-libpng15.patch b/media-video/alevt/files/alevt-1.6.2-libpng15.patch
new file mode 100644
index 000000000000..337a6f7c709f
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.2-libpng15.patch
@@ -0,0 +1,11 @@
+--- exp-gfx.c
++++ exp-gfx.c
+@@ -4,6 +4,8 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#include <zlib.h> /* Z_DEFAULT_COMPRESSION */
++
+ #include "lang.h"
+ #include "export.h"
+
diff --git a/media-video/alevt/files/alevt-1.6.2-respectflags.patch b/media-video/alevt/files/alevt-1.6.2-respectflags.patch
new file mode 100644
index 000000000000..368b0ff614cd
--- /dev/null
+++ b/media-video/alevt/files/alevt-1.6.2-respectflags.patch
@@ -0,0 +1,34 @@
+--- alevt-1.6.2/Makefile.orig 2007-12-03 06:19:54.000000000 +0100
++++ alevt-1.6.2/Makefile 2009-05-14 10:17:39.000000000 +0200
+@@ -1,5 +1,4 @@
+ VER=1.6.2
+-OPT=-O2 -s -w
+ #OPT=-O -g
+ DEFS=-DWITH_PNG
+ FONT=vtxt
+@@ -11,7 +10,7 @@
+ # a smaller and thinner font
+ #FONT=neep9
+
+-CFLAGS=$(OPT) -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
++CFLAGS += -DVERSION=\"$(VER)\" $(DEFS) -I$(USR_X11R6)/include
+
+ EXPOBJS=export.o exp-txt.o exp-html.o exp-gfx.o font.o
+ OBJS=main.o ui.o xio.o fdset.o vbi.o cache.o help.o edline.o search.o edit.o misc.o hamm.o lang.o $(EXPOBJS)
+@@ -25,13 +24,13 @@
+ all: alevt alevt-date alevt-cap alevt.1x alevt-date.1 alevt-cap.1
+
+ alevt: $(OBJS)
+- $(CC) $(OPT) $(OBJS) -o alevt -L$(USR_X11R6)/lib -L$(USR_X11R6)/lib64 -lX11 $(EXPLIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) -o alevt -L$(USR_X11R6)/lib -L$(USR_X11R6)/lib64 -lX11 $(EXPLIBS)
+
+ alevt-date: $(TOBJS)
+- $(CC) $(OPT) $(TOBJS) -o alevt-date
++ $(CC) $(CFLAGS) $(LDFLAGS) $(TOBJS) -o alevt-date
+
+ alevt-cap: $(COBJS)
+- $(CC) $(OPT) $(COBJS) -o alevt-cap $(EXPLIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(COBJS) -o alevt-cap $(EXPLIBS)
+
+ font.o: font1.xbm font2.xbm
+ fontsize.h: font1.xbm font2.xbm