summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2019-01-15 15:20:04 +0000
committerLuca Barbato <lu_zero@gentoo.org>2019-01-15 15:20:43 +0000
commit05fb115367d4e3b2de2a0d98f63b8685a974bf6f (patch)
tree8dd5c0c3850f7de41e332cd08281cf60b96349e0 /media-video/aravis/aravis-0.6.1.ebuild
parentapp-admin/helm: Stabilize 2.12.2 (diff)
downloadgentoo-05fb115367d4e3b2de2a0d98f63b8685a974bf6f.tar.gz
gentoo-05fb115367d4e3b2de2a0d98f63b8685a974bf6f.tar.bz2
gentoo-05fb115367d4e3b2de2a0d98f63b8685a974bf6f.zip
media-video/aravis: Version bump
New stable version Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'media-video/aravis/aravis-0.6.1.ebuild')
-rw-r--r--media-video/aravis/aravis-0.6.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-video/aravis/aravis-0.6.1.ebuild b/media-video/aravis/aravis-0.6.1.ebuild
new file mode 100644
index 000000000000..6136076e6a19
--- /dev/null
+++ b/media-video/aravis/aravis-0.6.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/AravisProject/aravis.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="mirror://gnome/sources/${PN}/$(ver_cut 1-2)/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+HOMEPAGE="https://wiki.gnome.org/Projects/Aravis"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="X gstreamer caps"
+
+GST_DEPEND="media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0"
+
+RDEPEND=">=dev-libs/glib-2.32
+ dev-libs/libxml2
+ X? (
+ >=x11-libs/gtk+-3.12:3
+ ${GST_DEPEND}
+ media-libs/gst-plugins-base:1.0
+ x11-libs/libnotify
+ )
+ caps? (
+ sys-libs/libcap-ng
+ sys-process/audit
+ )
+ gstreamer? ( ${GST_DEPEND} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/gobject-introspection"
+
+if [[ ${PV} != *9999 ]]; then
+ DEPEND+=" dev-util/gtk-doc dev-util/intltool"
+fi
+
+src_prepare() {
+ default
+ if [[ ${PV} = *9999 ]]; then
+ intltoolize || die
+ gtkdocize || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ $(use_enable X viewer) \
+ $(use_enable gstreamer gst-plugin) \
+ $(use_enable caps packet-socket) \
+ --enable-introspection
+}
+
+src_install() {
+ emake install DESTDIR="${D}" aravisdocdir="/usr/share/doc/${PF}"
+ find "${D}" -name '*.la' -delete
+}