summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-11-29 22:59:06 +0100
committerDavid Seifert <soap@gentoo.org>2018-11-29 22:59:06 +0100
commit115c5abe1f92131d0f68487b4f81fb9119e063f3 (patch)
treec3efb6a6b3d92c054671b0ec5280cb81e9e9a6c7 /media-video/bino
parentdev-util/statifier: [QA] Honour CC flags (diff)
downloadgentoo-115c5abe1f92131d0f68487b4f81fb9119e063f3.tar.gz
gentoo-115c5abe1f92131d0f68487b4f81fb9119e063f3.tar.bz2
gentoo-115c5abe1f92131d0f68487b4f81fb9119e063f3.zip
media-video/bino: Fix building with GCC 5
Closes: https://bugs.gentoo.org/649282 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video/bino')
-rw-r--r--media-video/bino/bino-1.6.6.ebuild3
-rw-r--r--media-video/bino/bino-1.6.7.ebuild5
2 files changed, 7 insertions, 1 deletions
diff --git a/media-video/bino/bino-1.6.6.ebuild b/media-video/bino/bino-1.6.6.ebuild
index b082c236f107..8d2731215ba0 100644
--- a/media-video/bino/bino-1.6.6.ebuild
+++ b/media-video/bino/bino-1.6.6.ebuild
@@ -32,6 +32,9 @@ DEPEND="${RDEPEND}
"
src_configure() {
+ # Qt5 now requires C++11, #649282
+ append-cxxflags -std=c++11
+
use video_cards_nvidia && append-cppflags "-I/usr/include/NVCtrl" \
&& append-ldflags "-L/usr/$(get_libdir)/opengl/nvidia/lib \
-L/usr/$(get_libdir)" && append-libs "Xext"
diff --git a/media-video/bino/bino-1.6.7.ebuild b/media-video/bino/bino-1.6.7.ebuild
index 5a98d40353a7..feefaa39d38b 100644
--- a/media-video/bino/bino-1.6.7.ebuild
+++ b/media-video/bino/bino-1.6.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,6 +34,9 @@ DEPEND="${RDEPEND}
"
src_configure() {
+ # Qt5 now requires C++11, #649282
+ append-cxxflags -std=c++11
+
if use video_cards_nvidia; then
append-cppflags "-I/usr/include/NVCtrl"
append-ldflags "-L/usr/$(get_libdir)/opengl/nvidia/lib -L/usr/$(get_libdir)"