summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-12-18 20:59:03 -0500
committerMatt Turner <mattst88@gentoo.org>2021-12-18 21:00:07 -0500
commit74be232e0ab0578a714615f612a317c45c47e7a3 (patch)
tree651d43757d9b1467d88321dbee7e0511ac751435 /media-video/cheese
parentsci-geosciences/gnome-maps: Version bump to 41.2 (diff)
downloadgentoo-74be232e0ab0578a714615f612a317c45c47e7a3.tar.gz
gentoo-74be232e0ab0578a714615f612a317c45c47e7a3.tar.bz2
gentoo-74be232e0ab0578a714615f612a317c45c47e7a3.zip
media-video/cheese: Version bump to 41.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-video/cheese')
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-41.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index 777126265c80..55cdc4e177c0 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,2 @@
DIST cheese-3.38.0.tar.xz 1086428 BLAKE2B b26a19a019de0385bdd7adbc55c873ebceca90a8f477d2041ef4a5045654f46ee8f7fdfc64f5fd34e059116528cc790610353791a7cbd13d7927a8c3abf38132 SHA512 210b50fc79a7b3a72c94163fe0dd76f7f29f576c1085c671c2c6c3b7f59ee362aec288f885a590ebfd9530534b6a6bad569c6df57874b9fcecf7e9f1ba9531ae
+DIST cheese-41.1.tar.xz 1092912 BLAKE2B 9bbfbc59868f39b344b1102f819ca647d82e9dee327f1d2a2e6b30fcfd2c59dd5f79236355d7148e01a4b07d80d630406708d2a152535b5732cfb52690f9f402 SHA512 2c0922dda97f4ce701add45977b405eff9ddbc24eb286e9e05a9f9bfbd7998e8e77ef2a8f1bbce9f8349ff522ee3cb6d6566fa5df80d782e6d844bff69a30074
diff --git a/media-video/cheese/cheese-41.1.ebuild b/media-video/cheese/cheese-41.1.ebuild
new file mode 100644
index 000000000000..67324c0a5595
--- /dev/null
+++ b/media-video/cheese/cheese-41.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson vala virtualx xdg
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ media-libs/clutter-gst:3.0
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ >=dev-libs/glib-2.39.90:2
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[ogg,pango,theora,vorbis]
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=x11-libs/gtk+-3.13.4:3
+ >=media-libs/libcanberra-0.26[gtk3]
+ x11-libs/libX11
+ sys-apps/dbus
+ media-video/gnome-video-effects
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+
+ media-libs/cogl:1.0=[introspection?]
+
+"
+RDEPEND="${DEPEND}
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.3
+ dev-util/itstool
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( x11-libs/libXtst )
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.38.0-buildfix.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ -Dman=true
+ )
+
+ meson_src_configure
+
+ # Hack: version.xml is not generated if gtk-doc is not enabled
+ echo ${PV} > docs/reference/version.xml
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}