summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-10-27 13:04:53 +0100
committerSebastian Pipping <sping@gentoo.org>2019-10-27 13:06:24 +0100
commit2ba8b7f4c872fb56ad28c03e80e1cb1024a2f7f6 (patch)
tree8e407af79e1647d45ab4abbf6f5b79a4a5d62263 /media-video/cpvts
parentapp-admin/filebeat: amd64 stable wrt bug #698536 (diff)
downloadgentoo-2ba8b7f4c872fb56ad28c03e80e1cb1024a2f7f6.tar.gz
gentoo-2ba8b7f4c872fb56ad28c03e80e1cb1024a2f7f6.tar.bz2
gentoo-2ba8b7f4c872fb56ad28c03e80e1cb1024a2f7f6.zip
media-video/cpvts: EAPI 7
Bug: https://bugs.gentoo.org/697264 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.16
Diffstat (limited to 'media-video/cpvts')
-rw-r--r--media-video/cpvts/cpvts-1.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-video/cpvts/cpvts-1.2-r1.ebuild b/media-video/cpvts/cpvts-1.2-r1.ebuild
new file mode 100644
index 000000000000..0138d6ee6d01
--- /dev/null
+++ b/media-video/cpvts/cpvts-1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs
+
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+DESCRIPTION="raw copy title sets from a DVD to your harddisc"
+SRC_URI="http://www.lallafa.de/bp/files/${P}.tgz"
+HOMEPAGE="http://www.lallafa.de/bp/cpvts.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libdvdread"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dvdread.patch"
+)
+
+echodo() {
+ echo "$@"
+ "$@" || die "failed"
+}
+
+src_compile () {
+ echodo $(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wl,-rpath,/usr/lib -o cpvts \
+ cpvts.c -lm -ldvdread
+}
+
+src_install () {
+ dobin ${PN}
+}