summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dvbsnoop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dvbsnoop')
-rw-r--r--media-video/dvbsnoop/Manifest1
-rw-r--r--media-video/dvbsnoop/dvbsnoop-1.4.50-r1.ebuild28
-rw-r--r--media-video/dvbsnoop/files/dvbsnoop-1.4.50-crc32.patch59
-rw-r--r--media-video/dvbsnoop/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/media-video/dvbsnoop/Manifest b/media-video/dvbsnoop/Manifest
new file mode 100644
index 000000000000..5e8f33245015
--- /dev/null
+++ b/media-video/dvbsnoop/Manifest
@@ -0,0 +1 @@
+DIST dvbsnoop-1.4.50.tar.gz 333992 SHA256 7658498b26a5d2a0242e81f0cfafa0e43a2bec56f8674e7ac197dfc310866ec6 SHA512 288b98e9205b9ee6638b65cd0d7c463c2c243c1f7e650a6df8592acd3f40eca3352a563cc8a1a04f0f2731b3718e6dc3d09f56f59da4b59fbe25b86acf434f81 WHIRLPOOL 2e9c779cf2689759be0c04b74952313d2b026e4819f7064fe919cbd41465a325300e1e0e0f864983b881006dea3de2fe30365c375f430d667e0cfc589eeb4690
diff --git a/media-video/dvbsnoop/dvbsnoop-1.4.50-r1.ebuild b/media-video/dvbsnoop/dvbsnoop-1.4.50-r1.ebuild
new file mode 100644
index 000000000000..3d9534bb4a2b
--- /dev/null
+++ b/media-video/dvbsnoop/dvbsnoop-1.4.50-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="DVB/MPEG stream analyzer program"
+SRC_URI="mirror://sourceforge/dvbsnoop/${P}.tar.gz"
+HOMEPAGE="http://dvbsnoop.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc x86"
+DEPEND="virtual/linuxtv-dvb-headers"
+
+RDEPEND=""
+SLOT="0"
+IUSE=""
+
+src_prepare () {
+ epatch "${FILESDIR}/${P}-crc32.patch"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog README
+}
diff --git a/media-video/dvbsnoop/files/dvbsnoop-1.4.50-crc32.patch b/media-video/dvbsnoop/files/dvbsnoop-1.4.50-crc32.patch
new file mode 100644
index 000000000000..eb663a4426c4
--- /dev/null
+++ b/media-video/dvbsnoop/files/dvbsnoop-1.4.50-crc32.patch
@@ -0,0 +1,59 @@
+diff -rupN dvbsnoop-1.4.50-origdeb/src/misc/crc32.c dvbsnoop-1.4.50/src/misc/crc32.c
+--- dvbsnoop-1.4.50-origdeb/src/misc/crc32.c 2006-01-02 21:24:04.000000000 +0200
++++ dvbsnoop-1.4.50/src/misc/crc32.c 2010-01-19 13:21:37.000000000 +0200
+@@ -17,14 +17,14 @@ $Id$
+
+
+
+-#include <sys/types.h>
++#include <stdint.h>
+ #include "crc32.h"
+
+
+
+ // CRC32 lookup table for polynomial 0x04c11db7
+
+-static u_long crc_table[256] = {
++static uint32_t crc_table[256] = {
+ 0x00000000, 0x04c11db7, 0x09823b6e, 0x0d4326d9, 0x130476dc, 0x17c56b6b,
+ 0x1a864db2, 0x1e475005, 0x2608edb8, 0x22c9f00f, 0x2f8ad6d6, 0x2b4bcb61,
+ 0x350c9b64, 0x31cd86d3, 0x3c8ea00a, 0x384fbdbd, 0x4c11db70, 0x48d0c6c7,
+@@ -69,10 +69,10 @@ static u_long crc_table[256] = {
+ 0x933eb0bb, 0x97ffad0c, 0xafb010b1, 0xab710d06, 0xa6322bdf, 0xa2f33668,
+ 0xbcb4666d, 0xb8757bda, 0xb5365d03, 0xb1f740b4};
+
+-u_long crc32 (char *data, int len)
++uint32_t crc32 (char *data, int len)
+ {
+ register int i;
+- u_long crc = 0xffffffff;
++ uint32_t crc = 0xffffffff;
+
+ for (i=0; i<len; i++)
+ crc = (crc << 8) ^ crc_table[((crc >> 24) ^ *data++) & 0xff];
+diff -rupN dvbsnoop-1.4.50-origdeb/src/misc/crc32.h dvbsnoop-1.4.50/src/misc/crc32.h
+--- dvbsnoop-1.4.50-origdeb/src/misc/crc32.h 2006-01-02 21:24:04.000000000 +0200
++++ dvbsnoop-1.4.50/src/misc/crc32.h 2010-01-19 13:21:37.000000000 +0200
+@@ -19,8 +19,9 @@ $Id$
+ #ifndef __CRC32_H
+ #define __CRC32_H
+
++#include <stdint.h>
+
+-u_long crc32 (char *data, int len);
++uint32_t crc32 (char *data, int len);
+
+
+ #endif
+diff -rupN dvbsnoop-1.4.50-origdeb/src/sections/sectables.c dvbsnoop-1.4.50/src/sections/sectables.c
+--- dvbsnoop-1.4.50-origdeb/src/sections/sectables.c 2005-12-29 05:43:40.000000000 +0200
++++ dvbsnoop-1.4.50/src/sections/sectables.c 2010-01-19 13:59:07.000000000 +0200
+@@ -269,7 +269,7 @@ void decodeSI_packet (u_char *buf, int l
+ softcrc_fail = 0;
+
+ if (opt->soft_crc) {
+- u_long crc = crc32 ((char *)buf,len);
++ uint32_t crc = crc32 ((char *)buf,len);
+ if (crc) {
+ softcrc_fail = 1;
+ }
diff --git a/media-video/dvbsnoop/metadata.xml b/media-video/dvbsnoop/metadata.xml
new file mode 100644
index 000000000000..70732c4e54bf
--- /dev/null
+++ b/media-video/dvbsnoop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-tv</herd>
+ <upstream>
+ <remote-id type="sourceforge">dvbsnoop</remote-id>
+ </upstream>
+</pkgmetadata>