summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-18 15:20:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-18 15:21:11 +0200
commit0603682dbcb28c52877652130f23b74f1a00ecd9 (patch)
tree66e1921fe732675f9fb7b5dc789f2d1b63a4d37c /media-video/ffmpeg
parentprofiles/arch/arm: unmask zvbi useflag, media-libs/zvbi is stable on arm (diff)
downloadgentoo-0603682dbcb28c52877652130f23b74f1a00ecd9.tar.gz
gentoo-0603682dbcb28c52877652130f23b74f1a00ecd9.tar.bz2
gentoo-0603682dbcb28c52877652130f23b74f1a00ecd9.zip
media-video/ffmpeg: set hostcc when cross compiling
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-3.3.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-3.3.ebuild b/media-video/ffmpeg/ffmpeg-3.3.ebuild
index 0404912f5acf..5c66b742a78e 100644
--- a/media-video/ffmpeg/ffmpeg-3.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.3.ebuild
@@ -402,7 +402,7 @@ multilib_src_configure() {
# cross compile support
if tc-is-cross-compiler ; then
- myconf+=( --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}- )
+ myconf+=( --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}- --host-cc="$(tc-getBUILD_CC)" )
case ${CHOST} in
*freebsd*)
myconf+=( --target-os=freebsd )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 12172bafc688..c3bf69113f8f 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -402,7 +402,7 @@ multilib_src_configure() {
# cross compile support
if tc-is-cross-compiler ; then
- myconf+=( --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}- )
+ myconf+=( --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}- --host-cc="$(tc-getBUILD_CC)" )
case ${CHOST} in
*freebsd*)
myconf+=( --target-os=freebsd )