summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-11 21:09:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-11 21:09:17 +0100
commit0ad2a95a4188fd99800f9a6a1b73a37c55b70ade (patch)
tree29e4c2d03e5d37f6e7df8f920f66d5e0401b16a1 /media-video/ffmpeg
parentx86/package.use.mask: update reason for app-emulation/qemu (diff)
downloadgentoo-0ad2a95a4188fd99800f9a6a1b73a37c55b70ade.tar.gz
gentoo-0ad2a95a4188fd99800f9a6a1b73a37c55b70ade.tar.bz2
gentoo-0ad2a95a4188fd99800f9a6a1b73a37c55b70ade.zip
media-video/ffmpeg: Do not infer --cpu option from mtune CFLAG.
mtune is meant for optimizing code but not generating specific instructions. ffmpeg --cpu option is for generating specific instuctions. Bug #577078 by gentoobugs@mysteryvortex.com. Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-2.6.3.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-2.6.4.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-2.8.5.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-2.8.6.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-3.0.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/media-video/ffmpeg/ffmpeg-2.6.3.ebuild b/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
index 3593fbdb1fe4..146a372267b0 100644
--- a/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
@@ -364,7 +364,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-2.6.4.ebuild b/media-video/ffmpeg/ffmpeg-2.6.4.ebuild
index 4432056eb38c..4cfdb9438351 100644
--- a/media-video/ffmpeg/ffmpeg-2.6.4.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.6.4.ebuild
@@ -364,7 +364,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-2.8.5.ebuild b/media-video/ffmpeg/ffmpeg-2.8.5.ebuild
index cd122a660c1f..9d520366dd02 100644
--- a/media-video/ffmpeg/ffmpeg-2.8.5.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.8.5.ebuild
@@ -369,7 +369,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-2.8.6.ebuild b/media-video/ffmpeg/ffmpeg-2.8.6.ebuild
index 5737bce7e21e..ef2179dfccbf 100644
--- a/media-video/ffmpeg/ffmpeg-2.8.6.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.8.6.ebuild
@@ -369,7 +369,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-3.0.ebuild b/media-video/ffmpeg/ffmpeg-3.0.ebuild
index 9fbf3efe29b6..fd5dd6f44171 100644
--- a/media-video/ffmpeg/ffmpeg-3.0.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.0.ebuild
@@ -370,7 +370,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 31e83554f745..c97b7cc70556 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -370,7 +370,7 @@ multilib_src_configure() {
# We need to do this so that features of that CPU will be better used
# If they contain an unknown CPU it will not hurt since ffmpeg's configure
# will just ignore it.
- for i in $(get-flag mcpu) $(get-flag march) $(get-flag mtune) ; do
+ for i in $(get-flag mcpu) $(get-flag march) ; do
[[ ${i} = native ]] && i="host" # bug #273421
myconf+=( --cpu=${i} )
break