summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-15 12:56:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-15 13:17:15 +0100
commit2c9e73d87ed557ac1c247c18ba33932be8b6bbcc (patch)
tree00824b1f66cf3308f8d26188bb17340b2febb965 /media-video/ffmpeg
parentmedia-video/ffmpeg: do not build doc for non-native abis; they are overwritte... (diff)
downloadgentoo-2c9e73d87ed557ac1c247c18ba33932be8b6bbcc.tar.gz
gentoo-2c9e73d87ed557ac1c247c18ba33932be8b6bbcc.tar.bz2
gentoo-2c9e73d87ed557ac1c247c18ba33932be8b6bbcc.zip
media-video/ffmpeg: let the build system install and decide whether to install docs.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 830fa7780e32..045efbebd4ba 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -411,7 +411,11 @@ multilib_src_configure() {
fi
# doc
- myconf+=( $(multilib_native_use_enable doc) )
+ myconf+=(
+ $(multilib_native_use_enable doc)
+ $(multilib_native_use_enable doc htmlpages)
+ $(multilib_native_enable manpages)
+ )
set -- "${S}/configure" \
--prefix="${EPREFIX}/usr" \
@@ -443,7 +447,7 @@ multilib_src_compile() {
}
multilib_src_install() {
- emake V=1 DESTDIR="${D}" install install-man
+ emake V=1 DESTDIR="${D}" install install-doc
if multilib_is_native_abi; then
for i in "${FFTOOLS[@]}" ; do