summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 16:23:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 16:23:22 +0200
commit6e3e90a076ea1f51d2db375d1be797be89cc5f0f (patch)
treec9238c5293b47302871cb5a490d29170932bebd9 /media-video/ffmpeg
parentmedia-libs/rubberband: Convert to multilib. (diff)
downloadgentoo-6e3e90a076ea1f51d2db375d1be797be89cc5f0f.tar.gz
gentoo-6e3e90a076ea1f51d2db375d1be797be89cc5f0f.tar.bz2
gentoo-6e3e90a076ea1f51d2db375d1be797be89cc5f0f.zip
media-video/ffmpeg: Add rubberband useflag.
Package-Manager: portage-2.2.21
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild3
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 3 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 8a1727babc11..394941d14905 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -80,7 +80,7 @@ FFMPEG_FLAG_MAP=(
zvbi:libzvbi
# libavfilter options
bs2b:libbs2b flite:libflite frei0r fribidi:libfribidi fontconfig ladspa
- libass truetype:libfreetype
+ libass truetype:libfreetype rubberband:librubberband
# libswresample options
libsoxr
# Threads; we only support pthread for now but ffmpeg supports more
@@ -210,6 +210,7 @@ RDEPEND="
pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
quvi? ( media-libs/libquvi:0.4[${MULTILIB_USEDEP}] )
librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+ rubberband? ( >=media-libs/rubberband-1.8.1-r1[${MULTILIB_USEDEP}] )
samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
sdl? ( >=media-libs/libsdl-1.2.15-r4[sound,video,${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index dbd3f79f44f4..ab2aef51409c 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -39,6 +39,7 @@
<flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
<flag name="postproc">Build and install libpostproc.</flag>
<flag name="quvi">Adds support for playing media from Internet services using the quvi project.</flag>
+ <flag name="rubberband">Adds time-stretching and pitch-shifting audio filter based on <pkg>media-libs/rubberband</pkg>.</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="snappy">Enable <pkg>app-arch/snappy</pkg> support. Required for e.g. Vidvox Hap encoder.</flag>
<flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>