summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/gnome-subtitles
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/gnome-subtitles')
-rw-r--r--media-video/gnome-subtitles/Manifest2
-rw-r--r--media-video/gnome-subtitles/gnome-subtitles-1.2.ebuild33
-rw-r--r--media-video/gnome-subtitles/gnome-subtitles-1.3.ebuild33
-rw-r--r--media-video/gnome-subtitles/metadata.xml15
4 files changed, 83 insertions, 0 deletions
diff --git a/media-video/gnome-subtitles/Manifest b/media-video/gnome-subtitles/Manifest
new file mode 100644
index 000000000000..6507b71dc08b
--- /dev/null
+++ b/media-video/gnome-subtitles/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-subtitles-1.2.tar.gz 1116649 SHA256 0232937123159a9e87d110f29b921704c9934472dd4a7c6de437fed159fb498c SHA512 7be09d284ae256959e86f582ac7c2d67eb9f8f869a75ce4024491e8d0f0e97333e687dd31b09676a7c28f5f32cc0462a520cb1a88288e6e9deb7e6a32eceac0d WHIRLPOOL 6bcf3c2986279ecf41602579cafe288a1e0d3e5fab4b3f2291c592a42e0e4ae55001755a25b16f435062085bd972d1631af684e35ceec9d3aa4e1b75c00b52ef
+DIST gnome-subtitles-1.3.tar.gz 1182246 SHA256 eb1b5954c0bda76da16d6887244a7c0769a80f7cfb3aa8ad838ba087d1d44aa9 SHA512 eef9fcb616d98248249c0a18102f8d36e68edcb966de848dc130d60892546a55f5485fe5448a36aabe68abe42a4e09357bbe4a473f5e4c0a8f319ac1368c23d1 WHIRLPOOL 2dc650462422fe11fabfc9e2677616777cabb054faf8dd5d4a65b9de41d3bf46b3561eed2a079bc45b9e0ec051d22f69b2482f073bf459e464c301553dfbb8bc
diff --git a/media-video/gnome-subtitles/gnome-subtitles-1.2.ebuild b/media-video/gnome-subtitles/gnome-subtitles-1.2.ebuild
new file mode 100644
index 000000000000..6a8ebd75f28a
--- /dev/null
+++ b/media-video/gnome-subtitles/gnome-subtitles-1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit mono gnome2
+
+DESCRIPTION="Video subtitling for the Gnome desktop"
+HOMEPAGE="http://gnome-subtitles.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnome-subtitles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=dev-lang/mono-1.1
+ >=dev-dotnet/glade-sharp-2.12
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gconf-sharp-2.12
+ media-libs/gstreamer:0.10
+ >=app-text/gtkspell-2.0:2
+ >=app-text/enchant-1.3
+ media-libs/gst-plugins-base:0.10"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ virtual/pkgconfig
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog NEWS README"
diff --git a/media-video/gnome-subtitles/gnome-subtitles-1.3.ebuild b/media-video/gnome-subtitles/gnome-subtitles-1.3.ebuild
new file mode 100644
index 000000000000..2e3eb1bf3599
--- /dev/null
+++ b/media-video/gnome-subtitles/gnome-subtitles-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit mono-env gnome2
+
+DESCRIPTION="Video subtitling for the Gnome desktop"
+HOMEPAGE="http://gnome-subtitles.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnome-subtitles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-lang/mono-1.1
+ >=dev-dotnet/glade-sharp-2.12
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gconf-sharp-2.12
+ media-libs/gstreamer:1.0
+ >=app-text/gtkspell-2.0:2
+ >=app-text/enchant-1.3
+ media-libs/gst-plugins-base:1.0"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ virtual/pkgconfig
+ app-text/gnome-doc-utils"
+
+DOCS="AUTHORS ChangeLog NEWS README"
diff --git a/media-video/gnome-subtitles/metadata.xml b/media-video/gnome-subtitles/metadata.xml
new file mode 100644
index 000000000000..82a9dd81ffbf
--- /dev/null
+++ b/media-video/gnome-subtitles/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>proxy-maintainers</herd>
+ <herd>dotnet</herd>
+ <maintainer>
+ <email>mail@pedrocastro.org</email>
+ <name>Pedro Castro</name>
+ <description>Upstream</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gnome-subtitles</remote-id>
+ </upstream>
+</pkgmetadata>