summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/gpac/gpac-0.5.1_pre5456.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/gpac/gpac-0.5.1_pre5456.ebuild')
-rw-r--r--media-video/gpac/gpac-0.5.1_pre5456.ebuild120
1 files changed, 120 insertions, 0 deletions
diff --git a/media-video/gpac/gpac-0.5.1_pre5456.ebuild b/media-video/gpac/gpac-0.5.1_pre5456.ebuild
new file mode 100644
index 000000000000..bb85dde97281
--- /dev/null
+++ b/media-video/gpac/gpac-0.5.1_pre5456.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="subversion"
+ ESVN_REPO_URI="svn://svn.code.sf.net/p/gpac/code/trunk/gpac"
+ KEYWORDS="alpha sparc"
+else
+ if [[ ${PV%_p*} != ${PV} ]] ; then
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+ else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ fi
+ KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
+fi
+
+inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
+
+DESCRIPTION="GPAC is an implementation of the MPEG-4 Systems standard developed from scratch in ANSI C"
+HOMEPAGE="http://gpac.wp.mines-telecom.fr/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="a52 aac alsa debug dvb ffmpeg ipv6 jack jpeg jpeg2k mad opengl oss png pulseaudio sdl ssl static-libs theora truetype vorbis xml xvid"
+
+S="${WORKDIR}"/${PN}
+
+RDEPEND="
+ a52? ( media-libs/a52dec )
+ aac? ( >=media-libs/faad2-2.0 )
+ alsa? ( media-libs/alsa-lib )
+ dvb? ( media-tv/linuxtv-dvb-apps )
+ ffmpeg? ( virtual/ffmpeg )
+ jack? ( media-sound/jack-audio-connection-kit )
+ jpeg? ( virtual/jpeg )
+ mad? ( >=media-libs/libmad-0.15.1b )
+ opengl? ( virtual/opengl media-libs/freeglut virtual/glu )
+ >=media-libs/libogg-1.1
+ png? ( >=media-libs/libpng-1.4 )
+ vorbis? ( >=media-libs/libvorbis-1.1 )
+ theora? ( media-libs/libtheora )
+ truetype? ( >=media-libs/freetype-2.1.4 )
+ xml? ( >=dev-libs/libxml2-2.6.0 )
+ xvid? ( >=media-libs/xvid-1.0.1 )
+ sdl? ( media-libs/libsdl )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ ssl? ( dev-libs/openssl )
+ pulseaudio? ( media-sound/pulseaudio )
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXext"
+# disabled upstream, see applications/Makefile
+# wxwidgets? ( =x11-libs/wxGTK-2.8* )
+
+DEPEND="${RDEPEND}"
+
+my_use() {
+ local flag="$1" pflag="${2:-$1}"
+ if use ${flag}; then
+ echo "--use-${pflag}=system"
+ else
+ echo "--use-${pflag}=no"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/110_all_implicitdecls.patch \
+ "${FILESDIR}"/${PN}-0.5.1-build-fixes.patch \
+ "${FILESDIR}"/ffmpeg25.patch
+ sed -i -e "s:\(--disable-.*\)=\*):\1):" configure || die
+}
+
+src_configure() {
+ tc-export CC CXX AR RANLIB
+
+ econf \
+ --enable-svg \
+ --enable-pic \
+ --disable-amr \
+ --use-js=no \
+ --use-ogg=system \
+ $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable jack jack yes) \
+ $(use_enable opengl) \
+ $(use_enable oss oss-audio) \
+ $(use_enable pulseaudio pulseaudio yes) \
+ $(use_enable sdl) \
+ $(use_enable ssl) \
+ $(use_enable static-libs static-lib) \
+ --disable-wx \
+ $(my_use a52) \
+ $(my_use aac faad) \
+ $(my_use dvb dvbx) \
+ $(my_use ffmpeg) \
+ $(my_use jpeg) \
+ $(my_use jpeg2k openjpeg) \
+ $(my_use mad) \
+ $(my_use png) \
+ $(my_use theora) \
+ $(my_use truetype ft) \
+ $(my_use vorbis) \
+ $(my_use xvid) \
+ --extra-cflags="${CFLAGS}" \
+ --cc="$(tc-getCC)" \
+ --libdir="/$(get_libdir)"
+}
+
+src_install() {
+ emake STRIP="true" DESTDIR="${D}" install
+ emake STRIP="true" DESTDIR="${D}" install-lib
+ dodoc AUTHORS BUGS Changelog README TODO INSTALLME
+ dodoc doc/*.txt
+ dohtml doc/*.html
+}