summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-03-07 19:06:49 +0100
committerJohannes Huber <johu@gentoo.org>2017-03-07 19:07:00 +0100
commita1cf2cea618f7cc48102add51140d4e1c19d95ab (patch)
tree4878bc959e55ba4711d56d2d29888257e3da2b89 /media-video/kaffeine/files
parentapp-crypt/gpa: ppc ppc64 stable (bug 611468). (diff)
downloadgentoo-a1cf2cea618f7cc48102add51140d4e1c19d95ab.tar.gz
gentoo-a1cf2cea618f7cc48102add51140d4e1c19d95ab.tar.bz2
gentoo-a1cf2cea618f7cc48102add51140d4e1c19d95ab.zip
media-video/kaffeine: Version bump 2.0.8
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-video/kaffeine/files')
-rw-r--r--media-video/kaffeine/files/kaffeine-2.0.8-build.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/kaffeine/files/kaffeine-2.0.8-build.patch b/media-video/kaffeine/files/kaffeine-2.0.8-build.patch
new file mode 100644
index 000000000000..1507f46da213
--- /dev/null
+++ b/media-video/kaffeine/files/kaffeine-2.0.8-build.patch
@@ -0,0 +1,38 @@
+commit 2dbc752d644440f963bad172cf3ec83dc681ec7f
+Author: Mauro Carvalho Chehab <mchehab@s-opensource.com>
+Date: Tue Mar 7 06:54:39 2017 -0300
+
+ CMakeLists.txt: fix it to allow building from tarball
+
+ Kaffeine has a script at tools/update_l10n.sh that allows one to
+ download and test all translations locally, with is useful during
+ Kaffeine development. Such script creates a file at po/CMakeLists.txt.
+
+ However, normal users will use the Kaffeine tarball, downloaded from
+ kde.org.
+
+ The translations at the po/ directory on the tarballs don't
+ have a CMakeLists.txt, as this file is created only if the
+ tools/update_l10n.sh is called.
+
+ So, change the main CMakeLists.txt to cope with both ways.
+
+ Signed-off-by: Mauro Carvalho Chehab <mchehab@s-opensource.com>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3215e94..d24e848 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,7 +93,11 @@ add_subdirectory(icons)
+ add_subdirectory(profiles)
+ add_subdirectory(src)
+ if (IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/po")
+- add_subdirectory(po)
++ if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/po/CMakeLists.txt" )
++ add_subdirectory(po)
++ else()
++ ki18n_install(po)
++ endif()
+ endif()
+
+ if(KF5DocTools_VERSION)