summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/kaffeine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/kaffeine')
-rw-r--r--media-video/kaffeine/Manifest1
-rw-r--r--media-video/kaffeine/files/kaffeine-1.2.2-gcc4.7.patch32
-rw-r--r--media-video/kaffeine/kaffeine-1.2.2-r1.ebuild39
-rw-r--r--media-video/kaffeine/metadata.xml9
4 files changed, 81 insertions, 0 deletions
diff --git a/media-video/kaffeine/Manifest b/media-video/kaffeine/Manifest
new file mode 100644
index 000000000000..78d91185f289
--- /dev/null
+++ b/media-video/kaffeine/Manifest
@@ -0,0 +1 @@
+DIST kaffeine-1.2.2.tar.gz 489727 SHA256 b6476a93ddbf84142d4fe29f0757de871e11ce6ca32590affe863a75a231c8cb SHA512 31db518943c223e635822369548949a0c2162cdbbe59edbadb77f4820acf697293d67681553d5552b9435471240fee551786c8c652f1ae5ab9cfe9b8a9cf4459 WHIRLPOOL 232f4875398c4ce889cbf1f3d0aeadefce09d5c6ed64aaf82df9fb57472b7fc814f20fb0fec54db715b45965ff79ae2ae064bb008c4c5fcf96d5b4dd3c860157
diff --git a/media-video/kaffeine/files/kaffeine-1.2.2-gcc4.7.patch b/media-video/kaffeine/files/kaffeine-1.2.2-gcc4.7.patch
new file mode 100644
index 000000000000..e74563e0bc67
--- /dev/null
+++ b/media-video/kaffeine/files/kaffeine-1.2.2-gcc4.7.patch
@@ -0,0 +1,32 @@
+commit 2da9df1e67004c3cfa879578c351300a99f23da1
+Author: Christoph Pfister <christophpfister@gmail.com>
+Date: Wed Apr 4 21:22:09 2012 +0200
+
+ fix build for gcc 4.7
+
+diff --git a/src/dvb/dvbepg.cpp b/src/dvb/dvbepg.cpp
+index 7fc8f68..e70d8b8 100644
+--- a/src/dvb/dvbepg.cpp
++++ b/src/dvb/dvbepg.cpp
+@@ -690,15 +690,15 @@ void AtscEpgFilter::processEitSection(const char *data, int size)
+ // 1980-01-06T000000 minus 15 secs (= UTC - GPS in 2011)
+ QDateTime baseDateTime = QDateTime(QDate(1980, 1, 5), QTime(23, 59, 45), Qt::UTC);
+
+- for (AtscEitSectionEntry entry = eitSection.entries(); (entryCount > 0) && entry.isValid();
+- --entryCount, entry.advance()) {
++ for (AtscEitSectionEntry eitEntry = eitSection.entries();
++ (entryCount > 0) && eitEntry.isValid(); --entryCount, eitEntry.advance()) {
+ DvbEpgEntry epgEntry;
+ epgEntry.channel = channel;
+- epgEntry.begin = baseDateTime.addSecs(entry.startTime());
+- epgEntry.duration = QTime().addSecs(entry.duration());
+- epgEntry.title = entry.title();
++ epgEntry.begin = baseDateTime.addSecs(eitEntry.startTime());
++ epgEntry.duration = QTime().addSecs(eitEntry.duration());
++ epgEntry.title = eitEntry.title();
+
+- quint32 id = ((quint32(fakeChannel.networkId) << 16) | quint32(entry.eventId()));
++ quint32 id = ((quint32(fakeChannel.networkId) << 16) | quint32(eitEntry.eventId()));
+ DvbSharedEpgEntry entry = epgEntries.value(id);
+
+ if (entry.isValid() && (entry->channel == epgEntry.channel) &&
diff --git a/media-video/kaffeine/kaffeine-1.2.2-r1.ebuild b/media-video/kaffeine/kaffeine-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..eabd2404a0dd
--- /dev/null
+++ b/media-video/kaffeine/kaffeine-1.2.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et fi fr ga gl
+hr hu it ja km ko ku lt mai nb nds nl nn pa pl pt pt_BR ro ru se sk
+sr@ijekavian sr@ijekavianlatin sr@latin sv th tr uk zh_CN zh_TW"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE media player with digital TV support"
+HOMEPAGE="http://kaffeine.kde.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="4"
+KEYWORDS="amd64 ppc x86"
+IUSE="debug"
+
+DEPEND="
+ x11-libs/libXScrnSaver
+ dev-qt/qtsql:4[sqlite]
+ >=media-libs/xine-lib-1.1.18.1
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( Changelog NOTES )
+
+PATCHES=( "${FILESDIR}/${PN}-1.2.2-gcc4.7.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build debug DEBUG_MODULE)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/media-video/kaffeine/metadata.xml b/media-video/kaffeine/metadata.xml
new file mode 100644
index 000000000000..62c56c83007a
--- /dev/null
+++ b/media-video/kaffeine/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">kaffeine</remote-id>
+ </upstream>
+</pkgmetadata>