summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/makemkv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/makemkv')
-rw-r--r--media-video/makemkv/Manifest2
-rw-r--r--media-video/makemkv/files/makemkv-makefile.patch18
-rw-r--r--media-video/makemkv/files/makemkv-path.patch13
-rw-r--r--media-video/makemkv/makemkv-1.9.5.ebuild124
-rw-r--r--media-video/makemkv/metadata.xml25
5 files changed, 182 insertions, 0 deletions
diff --git a/media-video/makemkv/Manifest b/media-video/makemkv/Manifest
new file mode 100644
index 000000000000..996262eca24c
--- /dev/null
+++ b/media-video/makemkv/Manifest
@@ -0,0 +1,2 @@
+DIST makemkv-bin-1.9.5.tar.gz 5257139 SHA256 57468cc5d34fc442f2d4a7888e1baa2ec7f006027dc5ba3322472724636ef3e3 SHA512 6d1555593fedcb1c28a2a5b091db16f190b7615c41ba3c03b3824141910581f82387af95ebd76afb7b0b81dde9d6f345a28305a4c69bce78972e881aee1c16f8 WHIRLPOOL 517c458ec158481462c16326b0655ff8095a31b03cce8235aa26a0ea57cdd5af2c8e5c8780ada7d6242ea692367c6e8c0fdd385e8d99c74c1d2e10a16901e34b
+DIST makemkv-oss-1.9.5.tar.gz 4405616 SHA256 cfd1729a40063dde2a52d3100091d2a0002aa616f87597108fa8d11c3ab5b5c6 SHA512 f7865fb8cba9fb0a6e595f427bf3c19054d5e2d45495a9b9c8cedbfa807211968f797f02661d143549877f7543f0991ca080a05f6ade36d9b6212fffa2675b5e WHIRLPOOL 9df57929bb350db7a97ce36f7cb86476d4c5ec7b534fd1e59d9a23f48ebce993d8c00df68cdc8259f5b951af6a2241173fbbf2a504073c3e3d009bf73c028a09
diff --git a/media-video/makemkv/files/makemkv-makefile.patch b/media-video/makemkv/files/makemkv-makefile.patch
new file mode 100644
index 000000000000..224273a5286e
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-makefile.patch
@@ -0,0 +1,18 @@
+--- makemkv-oss-1.9.3/Makefile.in.orig 2015-06-02 13:34:00.000000000 +0200
++++ makemkv-oss-1.9.3/Makefile.in 2015-06-04 12:32:29.752291023 +0200
+@@ -47,7 +47,7 @@
+ endif
+
+ out/%: out/%.full
+- $(OBJCOPY) --strip-all --strip-debug --strip-unneeded --discard-all $< $@
++ $(OBJCOPY) --discard-all $< $@
+
+ out/libdriveio.so.0.full:
+ mkdir -p out
+@@ -91,5 +91,5 @@
+
+ tmp/image_data.o : makemkvgui/bin/image_data.bin
+ mkdir -p tmp
+- $(LD) -r -b binary -o $@ $<
++ $(LD) -r -b binary -z noexecstack -o $@ $<
+
diff --git a/media-video/makemkv/files/makemkv-path.patch b/media-video/makemkv/files/makemkv-path.patch
new file mode 100644
index 000000000000..88f44a9d4ceb
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-path.patch
@@ -0,0 +1,13 @@
+--- makemkv-oss-1.8.10/makemkvgui/src/api_linux.cpp.orig 2014-04-13 14:01:36.000000000 +0100
++++ makemkv-oss-1.8.10/makemkvgui/src/api_linux.cpp 2014-05-08 00:09:52.863784998 +0100
+@@ -36,9 +36,7 @@
+ }
+
+ static const char* const app_locations[]={
+- "/bin",
+- "/usr/bin",
+- "/usr/local/bin",
++ "/opt/bin",
+ NULL };
+
+ const char* const* ApGetAppLocations()
diff --git a/media-video/makemkv/makemkv-1.9.5.ebuild b/media-video/makemkv/makemkv-1.9.5.ebuild
new file mode 100644
index 000000000000..74150adfc94b
--- /dev/null
+++ b/media-video/makemkv/makemkv-1.9.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils multilib flag-o-matic
+
+MY_P=makemkv-oss-${PV}
+MY_PB=makemkv-bin-${PV}
+
+DESCRIPTION="Tool for ripping and streaming Blu-ray, HD-DVD and DVD discs"
+HOMEPAGE="http://www.makemkv.com/"
+SRC_URI="http://www.makemkv.com/download/${MY_P}.tar.gz
+ http://www.makemkv.com/download/${MY_PB}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libav multilib qt4"
+
+QA_PREBUILT="opt/bin/makemkvcon opt/bin/mmdtsdec"
+
+RDEPEND="
+ sys-libs/glibc[multilib?]
+ dev-libs/expat
+ dev-libs/openssl:0
+ sys-libs/zlib
+ qt4? (
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ )
+ !libav? ( >=media-video/ffmpeg-1.0.0:0= )
+ libav? ( >=media-video/libav-0.8.9:0= )
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/makemkv-oss-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-{makefile,path}.patch
+}
+
+src_configure() {
+ replace-flags -O* -Os
+ local args=""
+ use qt4 || args="--disable-gui"
+ if [[ -x ${ECONF_SOURCE:-.}/configure ]] ; then
+ econf $args
+ fi
+}
+
+src_compile() {
+ emake GCC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ # install oss package
+ dolib.so out/libdriveio.so.0
+ dolib.so out/libmakemkv.so.1
+ dolib.so out/libmmbd.so.0
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
+ into /opt
+
+ if use qt4; then
+ dobin out/makemkv
+
+ local res
+ for res in 16 22 32 64 128; do
+ newicon -s ${res} makemkvgui/share/icons/${res}x${res}/makemkv.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} MakeMKV ${PN} 'Qt;AudioVideo;Video'
+ fi
+
+ # install bin package
+ pushd "${WORKDIR}"/${MY_PB}/bin >/dev/null
+ if use x86; then
+ dobin i386/{makemkvcon,mmdtsdec}
+ elif use amd64; then
+ dobin amd64/makemkvcon
+ use multilib && dobin i386/mmdtsdec
+ fi
+ popd >/dev/null
+
+ # install license and default profile
+ pushd "${WORKDIR}"/${MY_PB}/src/share >/dev/null
+ insinto /usr/share/MakeMKV
+ doins *.{gz,xml}
+ popd >/dev/null
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "While MakeMKV is in beta mode, upstream has provided a license"
+ elog "to use if you do not want to purchase one."
+ elog ""
+ elog "See this forum thread for more information, including the key:"
+ elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
+ elog ""
+ elog "Note that beta license may have an expiration date and you will"
+ elog "need to check for newer licenses/releases. "
+ elog ""
+ elog "If this is a new install, remember to copy the default profile"
+ elog "to the config directory:"
+ elog "cp /usr/share/MakeMKV/default.mmcp.xml ~/.MakeMKV/"
+ elog ""
+ elog "MakeMKV can also act as a drop-in replacement for libaacs and"
+ elog "libbdplus, allowing transparent decryption of a wider range of"
+ elog "titles under players like VLC and mplayer. To enable this, set"
+ elog "the following variables when launching the player:"
+ elog "LIBAACS_PATH=libmmbd LIBBDPLUS_PATH=libmmbd"
+}
+
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/media-video/makemkv/metadata.xml b/media-video/makemkv/metadata.xml
new file mode 100644
index 000000000000..767b0076a3cd
--- /dev/null
+++ b/media-video/makemkv/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>
+ MakeMKV is your one-click solution to convert video that you own
+ into free and patents-unencumbered format that can be played
+ everywhere. MakeMKV is a format converter, otherwise called
+ transcoder. It converts the video clips from proprietary (and
+ usually encrypted) disc into a set of MKV files, preserving most
+ information but not changing it in any way. The MKV format can
+ store multiple video/audio tracks with all meta-information and
+ preserve chapters. There are many players that can play MKV
+ files nearly on all platforms, and there are tools to convert
+ MKV files to many formats, including DVD and Blu-ray discs.
+
+ Additionally MakeMKV can instantly stream decrypted video
+ without intermediate conversion to wide range of players, so you
+ may watch Blu-ray and DVD discs with your favorite player on
+ your favorite OS or on your favorite device.
+</longdescription>
+</pkgmetadata>