summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-02 10:14:37 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-02 10:14:37 +0100
commit359ffe81483db138196f20f3492d419fccf208de (patch)
tree3ac592175531a42a727b1a529192653f55d8e99e /media-video/matroxset
parentmedia-sound/umix: Set sub-SLOT operator on sys-libs/ncurses dependency. (diff)
downloadgentoo-359ffe81483db138196f20f3492d419fccf208de.tar.gz
gentoo-359ffe81483db138196f20f3492d419fccf208de.tar.bz2
gentoo-359ffe81483db138196f20f3492d419fccf208de.zip
media-video/matroxset: Fix building against sys-libs/ncurses[tinfo] (bug #646804).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-video/matroxset')
-rw-r--r--media-video/matroxset/matroxset-0.4.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/media-video/matroxset/matroxset-0.4.ebuild b/media-video/matroxset/matroxset-0.4.ebuild
index cd27fbb824d1..9fea3c6f1738 100644
--- a/media-video/matroxset/matroxset-0.4.ebuild
+++ b/media-video/matroxset/matroxset-0.4.ebuild
@@ -1,20 +1,23 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
inherit toolchain-funcs
-IUSE=""
-
DESCRIPTION="Matrox utility to switch output modes (activate tvout)"
HOMEPAGE="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/"
SRC_URI="ftp://platan.vc.cvut.cz/pub/linux/matrox-latest/${P}.tar.gz"
-
-DEPEND="sys-libs/ncurses"
-RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
SLOT="0"
-LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86"
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
doecho() {
echo "$@"
@@ -24,7 +27,8 @@ doecho() {
src_compile() {
doecho $(tc-getCC) -o ${PN} \
${CFLAGS} ${LDFLAGS} \
- ${PN}.c -lncurses \
+ ${PN}.c \
+ $($(tc-getPKG_CONFIG) --libs ncurses) \
|| die "build failed"
#prepare small README
@@ -38,7 +42,7 @@ _EOF_
}
src_install() {
- dobin matroxset || die
+ dobin matroxset
- dodoc README || die
+ dodoc README
}