summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/miro
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/miro')
-rw-r--r--media-video/miro/Manifest3
-rw-r--r--media-video/miro/files/miro-5.0.4-ffmpeg-1.patch78
-rw-r--r--media-video/miro/metadata.xml8
-rw-r--r--media-video/miro/miro-4.0.6.ebuild91
-rw-r--r--media-video/miro/miro-5.0.4.ebuild97
-rw-r--r--media-video/miro/miro-6.0.ebuild96
6 files changed, 373 insertions, 0 deletions
diff --git a/media-video/miro/Manifest b/media-video/miro/Manifest
new file mode 100644
index 000000000000..937ee6fa64a4
--- /dev/null
+++ b/media-video/miro/Manifest
@@ -0,0 +1,3 @@
+DIST miro-4.0.6.tar.gz 13078726 SHA256 f51261d4505f0e9b2e429476ccfc8ce787ade6bfddb13a3eb05dee74a111d7da
+DIST miro-5.0.4.tar.gz 12990017 SHA256 4841c70c59a16647a77ea6c05a6d4d450bcc7973b9d33236d7cff2dbacf1c33a SHA512 fd4c9d95c921361209491f725bd979512c41b8dbffca5c310991fb3c112c8e1d401fccfa3f7de9baba7e169fbe7061501c876b848f765765e0d853b7fb240312 WHIRLPOOL 4aa2f75a2702dbf71523ab5d14db63cb819a85c849dbaa2deea9ed675ff95d88dc79d0e47db223939dedf72f2bd4085521ce501f26711c7be98ca49e0626a4bd
+DIST miro-6.0.tar.gz 13121803 SHA256 558d194278fe5d602ba4d5d6737035b150e907c57da3344afa2ec462062f026b SHA512 d7770af3d4c63812c69cdbf05af7d7a2fe017736dc118ad509ce4e5b9ae66f917bf541e8abba5dd2318f22dac1f8698e77fe7da339ebaf7a72181faa77183370 WHIRLPOOL 961dd8ccf5c311f459f1d51bf939b8b64abbdd4e14721ad51438583e5a509aa764fdb0e286fd6a268be92d1c2a5a734d52b982ff38e27788e4cbfa996c5cfa4e
diff --git a/media-video/miro/files/miro-5.0.4-ffmpeg-1.patch b/media-video/miro/files/miro-5.0.4-ffmpeg-1.patch
new file mode 100644
index 000000000000..93e92ed583ae
--- /dev/null
+++ b/media-video/miro/files/miro-5.0.4-ffmpeg-1.patch
@@ -0,0 +1,78 @@
+commit efe8bec33931522f60719102f53099f1796c7b75
+Author: Ben Dean-Kawamura <ben@pculture.org>
+Date: Fri Aug 31 16:30:59 2012 -0400
+
+ Update segmenter code to not use deprecated functions
+
+diff --git a/tv/linux/miro-segmenter.c b/tv/linux/miro-segmenter.c
+index 1bfdda3..fd2a726 100644
+--- a/tv/linux/miro-segmenter.c
++++ b/tv/linux/miro-segmenter.c
+@@ -156,7 +156,7 @@ int main(int argc, char **argv)
+ exit(1);
+ }
+
+- ret = av_open_input_file(&ic, input, ifmt, 0, NULL);
++ ret = avformat_open_input(&ic, input, ifmt, 0);
+ if (ret != 0) {
+ fprintf(stderr, "Could not open input file, make sure it is an mpegts file: %d\n", ret);
+ exit(1);
+@@ -215,12 +215,7 @@ int main(int argc, char **argv)
+ }
+ }
+
+- if (av_set_parameters(oc, NULL) < 0) {
+- fprintf(stderr, "Invalid output format parameters\n");
+- exit(1);
+- }
+-
+- dump_format(oc, 0, input, 1);
++ av_dump_format(oc, 0, input, 1);
+
+ if (video_st) {
+ codec = avcodec_find_decoder(video_st->codec->codec_id);
+@@ -233,12 +228,12 @@ int main(int argc, char **argv)
+ }
+ }
+
+- if (url_fopen(&oc->pb, output_filename, URL_WRONLY) < 0) {
++ if (avio_open(&oc->pb, output_filename, AVIO_FLAG_WRITE) < 0) {
+ fprintf(stderr, "Could not open '%s'\n", output_filename);
+ exit(1);
+ }
+
+- if (av_write_header(oc)) {
++ if (avformat_write_header(oc, NULL)) {
+ fprintf(stderr, "Could not write mpegts header to first output file\n");
+
+ exit(1);
+@@ -274,10 +269,10 @@ int main(int argc, char **argv)
+ }
+
+ if (segment_time - prev_segment_time >= segment_duration) {
+- put_flush_packet(oc->pb);
+- url_fclose(oc->pb);
++ avio_flush(oc->pb);
++ avio_close(oc->pb);
+
+- if (url_fopen(&oc->pb, output_filename, URL_WRONLY) < 0) {
++ if (avio_open(&oc->pb, output_filename, AVIO_FLAG_WRITE) < 0) {
+ fprintf(stderr, "Could not open '%s'\n", output_filename);
+ break;
+ }
+@@ -307,13 +302,13 @@ int main(int argc, char **argv)
+ av_freep(&oc->streams[i]);
+ }
+
+- url_fclose(oc->pb);
++ avio_close(oc->pb);
+ av_free(oc);
+
+ /* End-of-transcode marker. */
+ {
+ struct sockaddr_in sockaddr;
+- int rc, s;
++ int rc, s;
+
+ memset(&sockaddr, 0, sizeof(sockaddr));
+ sockaddr.sin_family = AF_INET;
diff --git a/media-video/miro/metadata.xml b/media-video/miro/metadata.xml
new file mode 100644
index 000000000000..1baa46d82420
--- /dev/null
+++ b/media-video/miro/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/miro/miro-4.0.6.ebuild b/media-video/miro/miro-4.0.6.ebuild
new file mode 100644
index 000000000000..78f7dbab53c4
--- /dev/null
+++ b/media-video/miro/miro-4.0.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.7"
+PYTHON_USE_WITH="sqlite"
+inherit eutils fdo-mime gnome2-utils distutils
+
+DESCRIPTION="Open source video player and podcast client"
+HOMEPAGE="http://www.getmiro.com/"
+SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libnotify aac musepack xvid"
+
+CDEPEND="
+ dev-libs/glib:2
+ >=dev-python/pyrex-0.9.6.4
+ dev-python/pygtk:2
+ dev-python/pygobject:2
+ >=virtual/ffmpeg-0.6.90"
+
+RDEPEND="${CDEPEND}
+ dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/gconf-python
+ dev-python/gst-python:0.10
+ dev-python/pyrex
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/pycurl
+ >=net-libs/rb_libtorrent-0.14.1[python]
+ media-libs/mutagen
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-pango:0.10
+ aac? ( media-plugins/gst-plugins-faad:0.10 )
+ libnotify? ( dev-python/notify-python )
+ musepack? ( media-plugins/gst-plugins-musepack:0.10 )
+ xvid? ( media-plugins/gst-plugins-xvid:0.10 )"
+
+DEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${P}/linux"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+}
+
+src_install() {
+ # doing the mv now otherwise, distutils_src_install will install it
+ mv README README.gtk || die "mv failed"
+
+ distutils_src_install
+
+ # installing docs
+ dodoc README.gtk ../{CREDITS,README} || die "dodoc failed"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ ewarn
+ ewarn "If miro doesn't play some video or audio format, please"
+ ewarn "check your USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+ elog "Miro for Linux doesn't support Adobe Flash, therefore you"
+ elog "you will not see any embedded video player on MiroGuide."
+ elog
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-video/miro/miro-5.0.4.ebuild b/media-video/miro/miro-5.0.4.ebuild
new file mode 100644
index 000000000000..efefdf5a4958
--- /dev/null
+++ b/media-video/miro/miro-5.0.4.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.7"
+PYTHON_USE_WITH="sqlite"
+inherit eutils fdo-mime gnome2-utils distutils
+
+DESCRIPTION="Open source video player and podcast client"
+HOMEPAGE="http://www.getmiro.com/"
+SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libnotify aac musepack xvid"
+
+CDEPEND="
+ dev-libs/glib:2
+ >=dev-python/pyrex-0.9.6.4
+ dev-python/pygtk:2
+ dev-python/pygobject:2
+ >=virtual/ffmpeg-0.6.90"
+
+RDEPEND="${CDEPEND}
+ dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/gconf-python
+ dev-python/gst-python:0.10
+ dev-python/pyrex
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/pycurl
+ >=net-libs/rb_libtorrent-0.14.1[python]
+ media-libs/mutagen
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-pango:0.10
+ aac? ( media-plugins/gst-plugins-faad:0.10 )
+ libnotify? ( dev-python/notify-python )
+ musepack? ( media-plugins/gst-plugins-musepack:0.10 )
+ xvid? ( media-plugins/gst-plugins-xvid:0.10 )
+ net-dns/avahi[mdnsresponder-compat]"
+
+DEPEND="${CDEPEND}"
+
+# 2 unexpected failures, requires a running gconf which MAY not exist
+# but failing tests not a regression from 4.0.6
+RESTRICT="test"
+
+S="${WORKDIR}/${P}/linux"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-ffmpeg-1.patch"
+}
+
+src_install() {
+ # doing the mv now otherwise, distutils_src_install will install it
+ mv README README.gtk || die "mv failed"
+
+ distutils_src_install
+
+ # installing docs
+ dodoc README.gtk ../{CREDITS,README} || die "dodoc failed"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ ewarn
+ ewarn "If miro doesn't play some video or audio format, please"
+ ewarn "check your USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+ elog "Miro for Linux doesn't support Adobe Flash, therefore you"
+ elog "you will not see any embedded video player on MiroGuide."
+ elog
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-video/miro/miro-6.0.ebuild b/media-video/miro/miro-6.0.ebuild
new file mode 100644
index 000000000000..ba8f821d0257
--- /dev/null
+++ b/media-video/miro/miro-6.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.7"
+PYTHON_USE_WITH="sqlite"
+inherit eutils fdo-mime gnome2-utils distutils
+
+DESCRIPTION="Open source video player and podcast client"
+HOMEPAGE="http://www.getmiro.com/"
+SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libnotify aac musepack xvid"
+
+CDEPEND="
+ dev-libs/glib:2
+ >=dev-python/pyrex-0.9.6.4
+ dev-python/pygtk:2
+ dev-python/pygobject:2
+ >=virtual/ffmpeg-0.6.90"
+
+RDEPEND="${CDEPEND}
+ dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/gconf-python
+ dev-python/gst-python:0.10
+ dev-python/pyrex
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/pycurl
+ >=net-libs/rb_libtorrent-0.14.1[python]
+ media-libs/mutagen
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-pango:0.10
+ aac? ( media-plugins/gst-plugins-faad:0.10 )
+ libnotify? ( dev-python/notify-python )
+ musepack? ( media-plugins/gst-plugins-musepack:0.10 )
+ xvid? ( media-plugins/gst-plugins-xvid:0.10 )
+ net-dns/avahi[mdnsresponder-compat]"
+
+DEPEND="${CDEPEND}"
+
+# 2 unexpected failures, requires a running gconf which MAY not exist
+# but failing tests not a regression from 4.0.6
+RESTRICT="test"
+
+S="${WORKDIR}/${P}/linux"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+}
+
+src_install() {
+ # doing the mv now otherwise, distutils_src_install will install it
+ mv README README.gtk || die "mv failed"
+
+ distutils_src_install
+
+ # installing docs
+ dodoc README.gtk ../{CREDITS,README} || die "dodoc failed"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ ewarn
+ ewarn "If miro doesn't play some video or audio format, please"
+ ewarn "check your USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+ elog "Miro for Linux doesn't support Adobe Flash, therefore you"
+ elog "you will not see any embedded video player on MiroGuide."
+ elog
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}