summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-11-28 11:52:50 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-11-28 11:52:50 +0100
commit94c7343e63831ad7eeeb24c85c311494ebebc86e (patch)
treeea6f98deef6e546aa5b5181bf48ef6fc5c1e9519 /media-video/movit/movit-1.4.0.ebuild
parentwww-apps/grafana-bin: Fix fat-fingered SRC_URI (diff)
downloadgentoo-94c7343e63831ad7eeeb24c85c311494ebebc86e.tar.gz
gentoo-94c7343e63831ad7eeeb24c85c311494ebebc86e.tar.bz2
gentoo-94c7343e63831ad7eeeb24c85c311494ebebc86e.zip
media-video/movit: Bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'media-video/movit/movit-1.4.0.ebuild')
-rw-r--r--media-video/movit/movit-1.4.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-video/movit/movit-1.4.0.ebuild b/media-video/movit/movit-1.4.0.ebuild
new file mode 100644
index 000000000000..9671f5745fa2
--- /dev/null
+++ b/media-video/movit/movit-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+# no sane way to use OpenGL from within tests?
+RESTRICT="test"
+
+DESCRIPTION="Modern Video Toolkit"
+HOMEPAGE="http://movit.sesse.net/"
+# Tests need gtest, makefile unconditionally builds tests, so ... yey!
+SRC_URI="http://movit.sesse.net/${P}.tar.gz
+ https://googletest.googlecode.com/files/gtest-1.7.0.zip"
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/mesa
+ >=dev-cpp/eigen-3.2.0:3
+ media-libs/libepoxy
+ >=sci-libs/fftw-3
+ media-libs/libsdl2
+ "
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake
+}
+
+src_test() {
+ GTEST_DIR="${WORKDIR}/gtest-1.7.0" emake check
+}