summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mpeg-tools/mpeg-tools-1.5b-r5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mpeg-tools/mpeg-tools-1.5b-r5.ebuild')
-rw-r--r--media-video/mpeg-tools/mpeg-tools-1.5b-r5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-video/mpeg-tools/mpeg-tools-1.5b-r5.ebuild b/media-video/mpeg-tools/mpeg-tools-1.5b-r5.ebuild
new file mode 100644
index 000000000000..0a494c89d4f0
--- /dev/null
+++ b/media-video/mpeg-tools/mpeg-tools-1.5b-r5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_PN=mpeg_encode
+DESCRIPTION="Tools for MPEG video"
+HOMEPAGE="http://bmrc.berkeley.edu/research/mpeg/mpeg_encode.html"
+SRC_URI="ftp://mm-ftp.cs.berkeley.edu/pub/multimedia/mpeg/encode/${MY_PN}-${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-64bit_fixes.patch
+ epatch "${FILESDIR}"/${P}-tempfile-convert.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-powerpc.patch
+ cd "${S}"
+ rm -r jpeg
+ epatch "${FILESDIR}"/${P}-jpeg.patch
+ epatch "${FILESDIR}"/${P}-tempfile-mpeg-encode.patch
+ epatch "${FILESDIR}"/${P}-tempfile-tests.patch
+ # don't include malloc.h, but use stdlib.h instead
+ sed -i -e 's:#include <malloc.h>:#include <stdlib.h>:' \
+ convert/*.c convert/mtv/*.c *.c headers/*.h || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+ emake -C convert CC="$(tc-getCC)"
+ emake -C convert/mtv CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin mpeg_encode
+ doman docs/*.1
+ dodoc BUGS CHANGES README TODO VERSION
+ dodoc docs/EXTENSIONS docs/INPUT.FORMAT docs/*.param docs/param-summary
+ docinto examples
+ dodoc examples/*
+
+ cd ../convert
+ dobin eyuvtojpeg jmovie2jpeg mpeg_demux mtv/movieToVid
+ newdoc README README.convert
+ newdoc mtv/README README.mtv
+}
+
+pkg_postinst() {
+ if [[ -z $(best_version media-libs/netpbm) ]]; then
+ elog "If you are looking for eyuvtoppm or ppmtoeyuv, please"
+ elog "emerge the netpbm package. It has updated versions."
+ fi
+}