summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-23 00:17:34 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-23 00:17:34 +0100
commit568f99f6c440db42edc001e6074a50eb614ae131 (patch)
treec15c3e1c9e8202173054acfe3f4fa52e1c6ca800 /media-video/mplayer
parentapp-emulation/cadvisor: 0.35.0 bump (diff)
downloadgentoo-568f99f6c440db42edc001e6074a50eb614ae131.tar.gz
gentoo-568f99f6c440db42edc001e6074a50eb614ae131.tar.bz2
gentoo-568f99f6c440db42edc001e6074a50eb614ae131.zip
media-video/mplayer: Disable GIF support
* mplayer relies on private APIs of giflib that have been moved around and will be removed in a future release. Bug: https://bugs.gentoo.org/682198 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/mplayer-1.3.0-r6.ebuild (renamed from media-video/mplayer/mplayer-1.3.0-r5.ebuild)8
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild10
2 files changed, 11 insertions, 7 deletions
diff --git a/media-video/mplayer/mplayer-1.3.0-r5.ebuild b/media-video/mplayer/mplayer-1.3.0-r6.ebuild
index 925a8f47c763..7163acf21eaa 100644
--- a/media-video/mplayer/mplayer-1.3.0-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.3.0-r6.ebuild
@@ -12,7 +12,7 @@ inherit toolchain-funcs flag-o-matic ${SVN_ECLASS}
IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext a52 aalib +alsa altivec aqua bidi bl bluray
bs2b cddb +cdio cdparanoia cpudetection debug dga
doc dts dv dvb +dvd +dvdnav +enca +encode faac faad fbcon
-ftp gif ggi gsm +iconv ipv6 jack joystick jpeg kernel_linux ladspa
+ftp ggi gsm +iconv ipv6 jack joystick jpeg kernel_linux ladspa
+libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
@@ -55,6 +55,8 @@ X_RDEPS="
"
# Rar: althrought -gpl version is nice, it cant do most functions normal rars can
# nemesi? ( net-libs/libnemesi )
+# mplayer relies on private APIs in giflib that have been removed:
+# https://sourceforge.net/p/giflib/bugs/132/
RDEPEND+="
sys-libs/ncurses:0=
app-arch/bzip2
@@ -84,7 +86,6 @@ RDEPEND+="
enca? ( app-i18n/enca )
faad? ( media-libs/faad2 )
ggi? ( media-libs/libggi media-libs/libggiwmh )
- gif? ( media-libs/giflib:0= )
gsm? ( media-sound/gsm )
iconv? ( virtual/libiconv )
jack? ( virtual/jack )
@@ -371,6 +372,7 @@ src_configure() {
##########
myconf+=" --disable-musepack" # Use internal musepack codecs for SV7 and SV8 support
myconf+=" --disable-libmpeg2-internal" # always use system media-libs/libmpeg2
+ myconf+=" --disable-gif" # relies on to-be-removed giflib internals https://sourceforge.net/p/giflib/bugs/132/
use dts || myconf+=" --disable-libdca"
if ! use mp3; then
myconf+="
@@ -383,7 +385,7 @@ src_configure() {
use ${i} || myconf+=" --disable-lib${i}"
done
- uses="faad gif jpeg libmpeg2 live mad mng png pnm speex tga theora tremor"
+ uses="faad jpeg libmpeg2 live mad mng png pnm speex tga theora tremor"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 8ca4b4a54f5f..ab5fe353ff59 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ inherit toolchain-funcs flag-o-matic ${SVN_ECLASS}
IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext a52 aalib +alsa altivec aqua bidi bl bluray
bs2b cddb +cdio cdparanoia cpudetection debug dga
doc dts dv dvb +dvd +dvdnav +enca +encode faac faad fbcon
-ftp gif ggi gsm +iconv ipv6 jack joystick jpeg kernel_linux ladspa
+ftp ggi gsm +iconv ipv6 jack joystick jpeg kernel_linux ladspa
+libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
@@ -55,6 +55,8 @@ X_RDEPS="
"
# Rar: althrought -gpl version is nice, it cant do most functions normal rars can
# nemesi? ( net-libs/libnemesi )
+# mplayer relies on private APIs in giflib that have been removed:
+# https://sourceforge.net/p/giflib/bugs/132/
RDEPEND+="
sys-libs/ncurses:0=
app-arch/bzip2
@@ -84,7 +86,6 @@ RDEPEND+="
enca? ( app-i18n/enca )
faad? ( media-libs/faad2 )
ggi? ( media-libs/libggi media-libs/libggiwmh )
- gif? ( media-libs/giflib:0= )
gsm? ( media-sound/gsm )
iconv? ( virtual/libiconv )
jack? ( virtual/jack )
@@ -363,6 +364,7 @@ src_configure() {
##########
myconf+=" --disable-musepack" # Use internal musepack codecs for SV7 and SV8 support
myconf+=" --disable-libmpeg2-internal" # always use system media-libs/libmpeg2
+ myconf+=" --disable-gif" # relies on to-be-removed giflib internals https://sourceforge.net/p/giflib/bugs/132/
use dts || myconf+=" --disable-libdca"
if ! use mp3; then
myconf+="
@@ -375,7 +377,7 @@ src_configure() {
use ${i} || myconf+=" --disable-lib${i}"
done
- uses="faad gif jpeg libmpeg2 live mad mng png pnm speex tga theora tremor"
+ uses="faad jpeg libmpeg2 live mad mng png pnm speex tga theora tremor"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done