summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-09 15:00:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-09 15:00:58 +0200
commitc9f197136f2ba5cf2ff546197f66aec6bb4033d2 (patch)
treeaafafe5cf0b631fae1642ee8c409c72e5a82fa32 /media-video/mplayer
parentmedia-video/ffmpeg: bump to 4.4 (diff)
downloadgentoo-c9f197136f2ba5cf2ff546197f66aec6bb4033d2.tar.gz
gentoo-c9f197136f2ba5cf2ff546197f66aec6bb4033d2.tar.bz2
gentoo-c9f197136f2ba5cf2ff546197f66aec6bb4033d2.zip
media-video/mplayer: fix build with ffmpeg 4.4
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video/mplayer')
-rw-r--r--media-video/mplayer/files/ffmpeg44.patch12
-rw-r--r--media-video/mplayer/mplayer-1.4-r1.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/media-video/mplayer/files/ffmpeg44.patch b/media-video/mplayer/files/ffmpeg44.patch
new file mode 100644
index 000000000000..99d54079cab2
--- /dev/null
+++ b/media-video/mplayer/files/ffmpeg44.patch
@@ -0,0 +1,12 @@
+Index: MPlayer-1.4/libmpcodecs/ad_spdif.c
+===================================================================
+--- MPlayer-1.4.orig/libmpcodecs/ad_spdif.c
++++ MPlayer-1.4/libmpcodecs/ad_spdif.c
+@@ -300,7 +300,6 @@ static void uninit(sh_audio_t *sh)
+ av_freep(&lavf_ctx->pb);
+ if (lavf_ctx->streams) {
+ av_freep(&lavf_ctx->streams[0]->codec);
+- av_freep(&lavf_ctx->streams[0]->info);
+ av_freep(&lavf_ctx->streams[0]);
+ }
+ av_freep(&lavf_ctx->streams);
diff --git a/media-video/mplayer/mplayer-1.4-r1.ebuild b/media-video/mplayer/mplayer-1.4-r1.ebuild
index c3f5a2e913cd..e3f376cc7060 100644
--- a/media-video/mplayer/mplayer-1.4-r1.ebuild
+++ b/media-video/mplayer/mplayer-1.4-r1.ebuild
@@ -232,6 +232,7 @@ src_prepare() {
else
eapply "${FILESDIR}"/${PN}-1.3-CVE-2016-4352.patch
fi
+ eapply "${FILESDIR}"/ffmpeg44.patch
if [ ! -f VERSION ] ; then
[ -f "$svf" ] || die "Missing ${svf}. Did you generate your snapshot with prepare_mplayer.sh?"
local sv=$(<$svf)