summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-22 22:41:01 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 15:47:26 +0300
commit2c5623d06461349a05557f354bbc6bf5f4192269 (patch)
tree7a64c9988756937a27d38efc902678612dd79361 /media-video/mpv
parentmedia-video/mpv: update vaapi USE dependencies and configure options (diff)
downloadgentoo-2c5623d06461349a05557f354bbc6bf5f4192269.tar.gz
gentoo-2c5623d06461349a05557f354bbc6bf5f4192269.tar.bz2
gentoo-2c5623d06461349a05557f354bbc6bf5f4192269.zip
media-video/mpv: add compiler check when vaapi is enabled with egl
VAAPI + EGL combo requires Thread Local Storage C++11 feature or GNU __thread extension. Add the corresponding check for sanity. See also https://github.com/mpv-player/mpv/issues/2631 Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/mpv-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 38b675a2e365..484a1ef66fae 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -9,7 +9,7 @@ PYTHON_REQ_USE='threads(+)'
WAF_PV='1.8.12'
-inherit eutils fdo-mime gnome2-utils pax-utils python-any-r1 waf-utils
+inherit eutils fdo-mime gnome2-utils pax-utils python-any-r1 toolchain-funcs waf-utils
DESCRIPTION="Media player based on MPlayer and mplayer2"
HOMEPAGE="https://mpv.io/"
@@ -124,6 +124,10 @@ RDEPEND="${COMMON_DEPEND}
"
pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && ! tc-has-tls && use vaapi && use egl; then
+ die "Your compiler lacks C++11 TLS support. Use GCC>=4.8.0 or Clang>=3.3."
+ fi
+
if ! use libass; then
ewarn "You have disabled the libass support."
ewarn "OSD and subtitles won't be available."