summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2016-05-05 21:23:26 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2016-05-05 21:23:26 +0200
commit91cf3ddad86852356bf48f7bd215d75807a1824d (patch)
tree8d32a587702e9cb3f0d11c54904742102925e8b2 /media-video/noad
parentsci-libs/pastix: Add cast to double for C99 isnan macro (diff)
downloadgentoo-91cf3ddad86852356bf48f7bd215d75807a1824d.tar.gz
gentoo-91cf3ddad86852356bf48f7bd215d75807a1824d.tar.bz2
gentoo-91cf3ddad86852356bf48f7bd215d75807a1824d.zip
compilefix wrt bug 575494
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-video/noad')
-rw-r--r--media-video/noad/noad-0.7.3.ebuild88
-rw-r--r--media-video/noad/noad-0.8.6-r2.ebuild (renamed from media-video/noad/noad-0.8.6.ebuild)15
2 files changed, 11 insertions, 92 deletions
diff --git a/media-video/noad/noad-0.7.3.ebuild b/media-video/noad/noad-0.7.3.ebuild
deleted file mode 100644
index acce5bb5ffb6..000000000000
--- a/media-video/noad/noad-0.7.3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="Mark commercial Breaks in VDR records"
-HOMEPAGE="http://noad.heliohost.org/"
-SRC_URI="http://noad.heliohost.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="ffmpeg imagemagick"
-
-DEPEND="media-libs/libmpeg2
- ffmpeg? ( >=virtual/ffmpeg-0.4.8 )
- imagemagick? ( >=media-gfx/imagemagick-6.2.4.2-r1 )
- !media-plugins/vdr-markad"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-
- epatch "${FILESDIR}"/patches-0.7.x/"${P}"-hangcheck.diff
-
- # UINT64_C is needed by ffmpeg headers
- append-flags -D__STDC_CONSTANT_MACROS
-
- if has_version ">=media-video/vdr-1.7.15"; then
- sed -e "s:2001:6419:" -i svdrpc.cpp
- fi
-
- epatch "${FILESDIR}/patches-0.7.x/${P}_gcc-4.7.diff"
-
- eautoreconf
-}
-
-src_configure() {
-
- local=myconf
- use ffmpeg && myconf="--with-ffmpeg --with-ffmpeginclude=/usr/include"
-
- econf \
- ${myconf} \
- $(use_with imagemagick magick) \
- --with-mpeginclude=/usr/include/mpeg2dec
-# --with-tools # fails on showindex, marcpics compile
-}
-
-src_install() {
-
- dobin noad
-# fix me later!
-# dobin noad showindex
-# use imagemagick && dobin markpics
-
- dodoc README INSTALL
- # example scripts are installed as dokumentation
- dodoc allnewnoad allnoad allnoadnice clearlogos noadifnew stat2html
-
- newconfd "${FILESDIR}"/confd_vdraddon.noad vdraddon.noad
-
- insinto /usr/share/vdr/record
- doins "${FILESDIR}"/record-50-noad.sh
-
- insinto /usr/share/vdr/shutdown
- doins "${FILESDIR}"/pre-shutdown-15-noad.sh
-
- insinto /etc/vdr/reccmds
- doins "${FILESDIR}"/reccmds.noad.conf
-
- exeinto /usr/share/vdr/bin
- doexe "${FILESDIR}"/noad-reccmd
-}
-
-pkg_postinst() {
-
- elog
- elog "Congratulations, you have just installed noad!,"
- elog "To integrate noad in VDR you should do this:"
- elog
- elog "start and set Parameter in /etc/conf.d/vdraddon.noad"
- elog
- elog "Note: You can use here all pararmeters for noad,"
- elog "please look in the documentation of noad."
-}
diff --git a/media-video/noad/noad-0.8.6.ebuild b/media-video/noad/noad-0.8.6-r2.ebuild
index 297a1a3e1e45..bb10d507c4ca 100644
--- a/media-video/noad/noad-0.8.6.ebuild
+++ b/media-video/noad/noad-0.8.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -25,9 +25,16 @@ DEPEND="${RDEPEND}
REQUIRED_USE="|| ( ffmpeg libmpeg2 )"
src_prepare() {
- if has_version '>=media-video/vdr-1.7.15'; then
- sed -i -e 's:2001:6419:' svdrpc.cpp main.cpp || die
- fi
+ sed -i -e 's:2001:6419:' svdrpc.cpp main.cpp
+
+ # wrt bug 575494
+ sed -e "s:CODEC_ID_MP3:AV_CODEC_ID_MP3:" -i audiotools.cpp
+ sed -e "sCODEC_ID_PROBE:AV_CODEC_ID_PROBE:" -i ffmpeg_decoder.cpp
+
+ # tested libav-9, ffmepg-2.2.9
+ epatch "${FILESDIR}/patches-0.8.x/${P}-libav9.diff" \
+ "${FILESDIR}/patches-0.8.x/${P}-ffmpeg25.patch"
+
eautoreconf
}