summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2017-10-18 00:31:02 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-10-27 23:02:18 +0200
commit9bfc25ff5890b96469a72fda162e543596559cfc (patch)
tree21d5bf7ee14cd24401981f217a27f4ed531c02cc /media-video/obs-studio/obs-studio-20.1.0.ebuild
parentwww-apps/redmine: migrate to EAPI6, minor fixes. (diff)
downloadgentoo-9bfc25ff5890b96469a72fda162e543596559cfc.tar.gz
gentoo-9bfc25ff5890b96469a72fda162e543596559cfc.tar.bz2
gentoo-9bfc25ff5890b96469a72fda162e543596559cfc.zip
media-video/obs-studio: version bump to 20.1.0.
Package-Manager: Portage-2.3.11, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5972
Diffstat (limited to 'media-video/obs-studio/obs-studio-20.1.0.ebuild')
-rw-r--r--media-video/obs-studio/obs-studio-20.1.0.ebuild116
1 files changed, 116 insertions, 0 deletions
diff --git a/media-video/obs-studio/obs-studio-20.1.0.ebuild b/media-video/obs-studio/obs-studio-20.1.0.ebuild
new file mode 100644
index 000000000000..55ccd0be37f4
--- /dev/null
+++ b/media-video/obs-studio/obs-studio-20.1.0.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jp9000/obs-studio.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/jp9000/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Software for Recording and Streaming Live Video Content"
+HOMEPAGE="https://obsproject.com"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa fdk imagemagick jack pulseaudio truetype v4l"
+
+COMMON_DEPEND="
+ >=dev-libs/jansson-2.5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qttest:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/ffmpeg:=[x264]
+ net-misc/curl
+ x11-libs/libXcomposite
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ fdk? ( media-libs/fdk-aac:= )
+ imagemagick? ( media-gfx/imagemagick:= )
+ jack? ( virtual/jack )
+ pulseaudio? ( media-sound/pulseaudio )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ v4l? ( media-libs/libv4l )
+"
+DEPEND="${COMMON_DEPEND}
+ imagemagick? (
+ || (
+ <media-gfx/imagemagick-7
+ (
+ >=media-gfx/imagemagick-7
+ >=dev-util/cmake-3.9
+ )
+ )
+ )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DDISABLE_ALSA=$(usex !alsa)
+ -DDISABLE_FREETYPE=$(usex !truetype)
+ -DDISABLE_JACK=$(usex !jack)
+ -DDISABLE_LIBFDK=$(usex !fdk)
+ -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+ -DDISABLE_V4L2=$(usex !v4l)
+ -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+ -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
+ -DOBS_VERSION_OVERRIDE=${PV}
+ -DUNIX_STRUCTURE=1
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! use alsa && ! use pulseaudio; then
+ elog
+ elog "For the audio capture features to be available,"
+ elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
+ elog "be enabled."
+ elog
+ fi
+
+ if ! has_version "sys-apps/dbus"; then
+ elog
+ elog "The 'sys-apps/dbus' package is not installed, but"
+ elog "could be used for disabling hibernating, screensaving,"
+ elog "and sleeping. Where it is not installed,"
+ elog "'xdg-screensaver reset' is used instead"
+ elog "(if 'x11-misc/xdg-utils' is installed)."
+ elog
+ fi
+
+ if ! has_version "media-libs/speex"; then
+ elog
+ elog "For the speexdsp-based noise suppression filter"
+ elog "to be available, the 'media-libs/speex' package needs"
+ elog "to be installed."
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}