summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-08-24 23:51:36 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 16:30:54 +0200
commitbc0aeaf00261b69f028295a49e08e17fea049fb4 (patch)
tree0c3a7ae7a63c20a7d274375aa3317bf17e0c972f /media-video/obs-studio
parentmedia-video/obs-studio: adjust USE="nvenc" on 21.1.2 (diff)
downloadgentoo-bc0aeaf00261b69f028295a49e08e17fea049fb4.tar.gz
gentoo-bc0aeaf00261b69f028295a49e08e17fea049fb4.tar.bz2
gentoo-bc0aeaf00261b69f028295a49e08e17fea049fb4.zip
media-video/obs-studio: switch to python-single-r1 eclass
Previously, the fact that 'python-any-r1.eclass' is intended for build-time dependent packages only was completely missed, while Python is required at run-time when used for OBS Studio scripting. Closes: https://bugs.gentoo.org/662702 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.48, Repoman-2.3.10 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/obs-studio')
-rw-r--r--media-video/obs-studio/obs-studio-21.1.2.ebuild3
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/media-video/obs-studio/obs-studio-21.1.2.ebuild b/media-video/obs-studio/obs-studio-21.1.2.ebuild
index 956bf7750a29..dd53602850c7 100644
--- a/media-video/obs-studio/obs-studio-21.1.2.ebuild
+++ b/media-video/obs-studio/obs-studio-21.1.2.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python{3_4,3_5,3_6} )
CMAKE_MIN_VERSION=3.9.6
-inherit cmake-utils gnome2-utils python-any-r1
+inherit cmake-utils gnome2-utils python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -23,6 +23,7 @@ HOMEPAGE="https://obsproject.com"
LICENSE="GPL-2"
SLOT="0"
IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speexdsp truetype v4l"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
COMMON_DEPEND="
>=dev-libs/jansson-2.5
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 4558c2f4e954..366ec0704341 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
PYTHON_COMPAT=( python{3_4,3_5,3_6} )
CMAKE_MIN_VERSION=3.9.6
-inherit cmake-utils gnome2-utils python-any-r1
+inherit cmake-utils gnome2-utils python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -23,6 +23,7 @@ HOMEPAGE="https://obsproject.com"
LICENSE="GPL-2"
SLOT="0"
IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speexdsp truetype v4l"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
COMMON_DEPEND="
>=dev-libs/jansson-2.5